Releases: H2Owater425/node-hitomi
Releases · H2Owater425/node-hitomi
[email protected]
- release: Update package version to 4.1.0
- chore: Build
- feat: Add getSecondThumbnailIndex type
- fix: Fix typo
- feat: Implement getSecondThumbnailIndex function
- feat: Use url string instead url object
[email protected]
- release: Update package version to 4.0.2
- chore: Build
- fix: Fix error message
[email protected]
- release: Update package version to 4.0.1
- chore: Build
- fix: Fix typo
- fix: Add single quote
- fix: Avoid using this before calling super function
- docs: Fix function name (#25)
- feat: Use custom error class to make error message more coherent
[email protected]
- release: Update package version to 4.0.0
- chore: Build
- Merge pull request #24 from H2Owater425/develop
- For version 4.0.0
- refactor: Fix variable name orderBy to orderCriteria
- refactor: Fix order of tag element
- chore: Build
- docs: Add package and configuration for tester
- feat: Add validity check for gif extension to getImageUrl
- style: Fix arrow function expression to function expression
- feat: Use type of typescript instead of javascript
- feat: Use property of Image to describe type of extension feat: Add difference about types
- feat: Fix function and parameter name (#23)
- docs: Add ignoration for ignore file to .npmignore
- feat: Ensure all errors can be caught and use constructor (#18)
- feat: Implement getVideoUrl (#21)
- feat: Add support gif extension to Image (#21) refactor: Fix overused parameter name value
- refactor: Improve performance of parseTag and queryTag (#20)
- refactor: Fix variable name to matchedNameList refactor: Move every code to index.ts
- docs: Remove ignorance of index.ts
- docs: Move test file ignorance to .npmignore docs: Fix spaces to tab
- docs: Remove unnecessarily added comment
[email protected]
- release: Update package version to 3.1.0
- docs: Add changes to README.md
- Merge pull request #16 from H2Owater425/develop
- refactor: Remove dependency from node-fetch (#15)
- chore: Build
- feat: Avoid re-creating agent every time request
- docs: Remove yarn-related files
- chore: Build
- docs: Add javascript test file to .gitignore
- docs: Remove dependency from node-fetch
- feat: Use custom https request function
- feat: Implement https request logic
- fix: Fix use of Array.filter
- docs: Add usage description about new feature
- docs: Add description about new feature
[email protected]
- release: Update package version to 3.0.1
- chore: Build
- feat: Fix definition file to export module (#11)
- docs: Add building and testing file to .gitignore
P.S. I tried to fix the commit name and description to follow the commit message style, and I eventually changed them all, but this made my commit and release date strangely.
I apologize for the inconvenience from the strange commit and release date, I promise that I won't make mistake like that again.
[email protected]
- release: Update package version to 3.0.0
- chore: Build
- feat: Fix interface and parameter name
- docs: Add build configuration
- feat: Implement logic to get tag list (#8)
- feat: Add TagType and StartingCharacter type
- feat: Fix type name and related function
- style: Remove meaningless try-catch
- style: Move error handling logic
- feat: Fix getImageUrl to reflect code update of hitomi (#10)
- feat: Add type definition to variable used in for loop
[email protected]
- docs: Update package version to 2.0.0
- chore: Build
- feat: Fix Gallery.files type to Image list only
- feat: Add default export
- feat: Fix object key error (#9)
[email protected]
- docs: Update package version to 1.2.0
- chore: Build
- chore: Minify
- feat: Add OrderCriteria option to getGalleryIdList and getNozomiUrl (#4)
- style: Correct error handling code style
- feat: Add jsdoc description to functions
- feat: Set option parameter and it's value of function to optional
- feat: Correct name of object key
- feat: Move some class, constant, and function to utilities.ts
- feat: Rename Number.isInteger to isInteger
[email protected]
- docs: Update package version to 1.1.0
- feat: Split function and type codes into separate files
- feat: Add includeFullData option to getGalleryData
- docs: Update README.md to simplify main page