Skip to content
This repository has been archived by the owner on May 20, 2023. It is now read-only.

Commit

Permalink
upgpkg: raptor 2.0.16-1: Upgrade to 2.0.16.
Browse files Browse the repository at this point in the history
Remove patches for fixed issues.
Update patch for disabling broken test suites: dajobe/raptor#49

git-svn-id: file:///srv/repos/svn-packages/svn@470140 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
dvzrv committed Mar 2, 2023
1 parent 9e1acf7 commit 0f9396e
Show file tree
Hide file tree
Showing 5 changed files with 43 additions and 103 deletions.
44 changes: 19 additions & 25 deletions raptor/trunk/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -6,8 +6,8 @@

_name=raptor2
pkgname=raptor
pkgver=2.0.15
pkgrel=21
pkgver=2.0.16
pkgrel=1
pkgdesc="A C library that parses RDF/XML/N-Triples into RDF triples"
arch=(x86_64)
url="https://librdf.org/raptor"
Expand All @@ -17,42 +17,33 @@ makedepends=(curl gtk-doc icu)
provides=(libraptor2.so)
source=(
https://librdf.org/dist/source/$_name-$pkgver.tar.gz{,.asc}
$pkgname-2.0.15-CVE-2017-18926.patch
$pkgname-2.0.15-out_of_bounds.patch
$pkgname-2.0.15-disable_broken_test_suites.patch
$pkgname-2.0.16-disable_broken_test_suites.patch
)
sha512sums=('563dd01869eb4df8524ec12e2c0a541653874dcd834bd1eb265bc2943bb616968f624121d4688579cdce11b4f00a8ab53b7099f1a0850e256bb0a2c16ba048ee'
sha512sums=('9bd5cff36390e1e0ef15ac56e5413ecfceb4018cb531a4da8850d3623615f12a93690a78be61f9d9ae7a24e16f6446e356bc2b7f34051ddc077761d85a9b7c44'
'SKIP'
'82f2f7ea4b72aa2bf444013a81db3cb17fcce2ae650bdb22eaab00d6d5cf7f950f7a550ffff49348db878f90f2753b407e6026d08d543cd0757c1687c6dad159'
'140f90d74fad8cdc6ef7fa14fa655e425552947d57068021362f8ae9efdded8ed31295e9bdd495fe70e646967062e28fa3ecd5831f9902134da5fe0a82607735'
'bfa5e2c10e33bab9ba85541ca78e903dbcbe07e2fbb654687e0b65fe46531bf385d7b3de36619b9919b7b4db3b803624d294cb8bfd63a89b96fc85cd2fda278e')
b2sums=('0a39c7b5705bfbf2daa0ca633f79693953b4dfe24c144008d1646a9840a36d4d7ce153b527450647127ec2522047dbd0a6e71f307ee5656951f7e4b610adfd22'
'74d7172e67b20be433d41229d24cbceab9a1871215d741d8dbd3e6d1b73ad12910e560bd18acb52153962ed16f5b9a7c8647f6b29a0e6657de9f0b788783d567')
b2sums=('1e5e5742ba4cdaacb98a9ba77a9352589df0da60869e7721ee140c81ed4886bf909b37b247bd925c82a4ac44b3c11a909c913f0851d49a1d9d91c9293189266d'
'SKIP'
'5e86b3bb1e80662363cbefa889b36810a4472c23ddb0a96960c13586124ac13031c6759e4abb3381e17a8f3b7cc941eaa3f97f3bc7c562f165db37efc47a39f8'
'ab11eeb648bf2cf8ac4ef4bbff4cdb77d1b713ad086268b656c7249363bf5752b535763f9a9fd34be4d72b3ff420cd87ee6970d3da6e24e5e2b067b9dbb9c29e'
'5f623afff5566d47d132c24e32b6b683b7eff15a9a819387b1764b1c222ae47f6e1948892b2a93af77375a3616f9276b00e6686108720da1005b47232b3f6b5f')
'615decc1eefd3a17576c6fdc06e64e8083479c6c1409b685419a3e314bb4d9eaa54ba5717506d4c38410b7d77d936a899ec8d9b027babf7718a12048f48fc49e')
validpgpkeys=('F879F0DEDA780198DD08DC6443EC92504F71955A') # Dave Beckett <[email protected]>

prepare() {
# fix CVE-2017-18926:
# https://bugs.archlinux.org/task/68613
# https://github.com/dajobe/raptor/commit/590681e546cd9aa18d57dc2ea1858cb734a3863f
patch -d $_name-$pkgver -Np1 -i ../$pkgname-2.0.15-CVE-2017-18926.patch
# fix out-of-bounds read:
# https://bugs.librdf.org/mantis/view.php?id=650
patch -d $_name-$pkgver -Np1 -i ../$pkgname-2.0.15-out_of_bounds.patch
# remove broken test suites: https://github.com/dajobe/raptor/issues/49
patch -d $_name-$pkgver -Np1 -i ../$pkgname-2.0.15-disable_broken_test_suites.patch
patch -d $_name-$pkgver -Np1 -i ../$pkgname-2.0.16-disable_broken_test_suites.patch

cd $_name-$pkgver
autoreconf -fiv
}

build() {
local configure_options=(
--prefix=/usr
--disable-static
--with-icu-config=/usr/bin/icu-config
)

cd $_name-$pkgver
./configure --prefix=/usr \
--disable-static \
--with-icu-config=/usr/bin/icu-config
./configure "${configure_options[@]}"
# prevent excessive overlinking due to libtool
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
Expand All @@ -63,7 +54,10 @@ check() {
}

package() {
depends+=(libcurl.so libicuuc.so)
depends+=(
curl libcurl.so
icu libicuuc.so
)

make DESTDIR="$pkgdir" install -C $_name-$pkgver
install -vDm 644 $_name-$pkgver/{AUTHORS,ChangeLog*,README} -t "$pkgdir/usr/share/doc/$pkgname/"
Expand Down
40 changes: 0 additions & 40 deletions raptor/trunk/raptor-2.0.15-CVE-2017-18926.patch

This file was deleted.

24 changes: 0 additions & 24 deletions raptor/trunk/raptor-2.0.15-disable_broken_test_suites.patch

This file was deleted.

14 changes: 0 additions & 14 deletions raptor/trunk/raptor-2.0.15-out_of_bounds.patch

This file was deleted.

24 changes: 24 additions & 0 deletions raptor/trunk/raptor-2.0.16-disable_broken_test_suites.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
diff -ruN a/tests/Makefile.am b/tests/Makefile.am
--- a/tests/Makefile.am 2014-11-14 19:11:13.000000000 +0100
+++ b/tests/Makefile.am 2023-03-02 19:49:59.269974344 +0100
@@ -37,7 +37,7 @@
# Used to make N-triples output consistent
BASE_URI=http://librdf.org/raptor/tests/

-SUBDIRS = rdfxml ntriples ntriples-2013 nquads-2013 turtle mkr turtle-2013 trig grddl rdfa rdfa11 json feeds
+SUBDIRS = ntriples ntriples-2013 nquads-2013 mkr turtle-2013 trig grddl rdfa rdfa11 json


$(top_builddir)/src/libraptor2.la:
diff -ruN a/tests/Makefile.in b/tests/Makefile.in
--- a/tests/Makefile.in 2023-03-01 18:58:10.000000000 +0100
+++ b/tests/Makefile.in 2023-03-02 19:50:09.006659970 +0100
@@ -618,7 +618,7 @@

# Used to make N-triples output consistent
BASE_URI = http://librdf.org/raptor/tests/
-SUBDIRS = rdfxml ntriples ntriples-2013 nquads-2013 turtle mkr turtle-2013 trig grddl rdfa rdfa11 json feeds
+SUBDIRS = ntriples ntriples-2013 nquads-2013 mkr turtle-2013 trig grddl rdfa rdfa11 json
all: all-recursive

.SUFFIXES:

0 comments on commit 0f9396e

Please sign in to comment.