Skip to content

Commit

Permalink
firmware: add Intel/Lantiq VRX518 DSL firmware package
Browse files Browse the repository at this point in the history
This is required by the DSL CPE API driver.

Signed-off-by: Martin Schiller <[email protected]>
[update for new license]
Signed-off-by: Andre Heider <[email protected]>
  • Loading branch information
sch-m authored and dhewg committed Jun 2, 2024
1 parent b291bde commit 2e724cf
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 3 deletions.
43 changes: 43 additions & 0 deletions package/firmware/lantiq/dsl_vr11_firmware_xdsl/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# SPDX-License-Identifier: GPL-2.0-or-later

include $(TOPDIR)/rules.mk

PKG_NAME:=dsl_vr11_firmware_xdsl
PKG_VERSION:=8.13.1.5.0.7
PKG_RELEASE:=1

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://gitlab.com/prpl-foundation/intel/dsl_vr11_firmware_xdsl.git
PKG_SOURCE_VERSION:=99cf1fe7a1711b9aa128eeb8419eab698448df9f
PKG_MIRROR_HASH:=7fb37723f8db2558d774ba972f011598d2399609158c5dbc287eca0873b040f1

PKG_LICENSE:=MaxLinear-Software-License-Agreement
PKG_LICENSE_FILES:=LICENSE

include $(INCLUDE_DIR)/package.mk

ANNEX_A_VER:=8D1507_8D0901

define Package/$(PKG_NAME)
SECTION:=firmware
CATEGORY:=Firmware
TITLE:=VRX518 / VR11 CPE xDSL Annex A firmware
URL:=http://www.intel.com
DEPENDS:=@TARGET_ipq40xx
endef

define Package/$(PKG_NAME)/description
VRX518 / VR11 CPE VDSL and ADSL Annex A firmware
endef

define Build/Compile
endef

define Package/$(PKG_NAME)/install
$(INSTALL_DIR) $(1)/lib/firmware/
$(INSTALL_DATA) $(PKG_BUILD_DIR)/LICENSE $(1)/lib/firmware/xcpe_$(ANNEX_A_VER).bin.LICENSE
$(INSTALL_DATA) $(PKG_BUILD_DIR)/xcpe_$(ANNEX_A_VER).bin $(1)/lib/firmware/
ln -s xcpe_$(ANNEX_A_VER).bin $(1)/lib/firmware/vdsl.bin
endef

$(eval $(call BuildPackage,$(PKG_NAME)))
4 changes: 1 addition & 3 deletions package/kernel/lantiq/ltq-vdsl-vr11/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -27,13 +27,11 @@ PKG_BUILD_FLAGS:=no-mold

include $(INCLUDE_DIR)/package.mk

# TODO this driver depends on the vrx518 dsl firmware, add this dependency if
# that ever gets a compatible license
define KernelPackage/ltq-vdsl-vr11
TITLE:=vdsl driver
SECTION:=sys
SUBMENU:=Network Devices
DEPENDS:=@TARGET_ipq40xx +kmod-ltq-vdsl-vr11-mei
DEPENDS:=@TARGET_ipq40xx +kmod-ltq-vdsl-vr11-mei +dsl_vr11_firmware_xdsl
FILES:=$(PKG_BUILD_DIR)/src/drv_dsl_cpe_api.ko
AUTOLOAD:=$(call AutoLoad,51,drv_dsl_cpe_api)
endef
Expand Down

0 comments on commit 2e724cf

Please sign in to comment.