Skip to content

Commit b194cf3

Browse files
committed
merge_driver_ekeyword: Add build system
Signed-off-by: Matt Turner <[email protected]>
1 parent 59a4f91 commit b194cf3

File tree

4 files changed

+49
-0
lines changed

4 files changed

+49
-0
lines changed
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,24 @@
1+
2+
merge_driver_ekeyword_py = configure_file(
3+
input : 'merge_driver_ekeyword.py',
4+
output : 'merge_driver_ekeyword.py',
5+
configuration : conf_data
6+
)
7+
8+
py.install_sources(
9+
[
10+
'__init__.py',
11+
merge_driver_ekeyword_py,
12+
'test_merge_driver_ekeyword.py',
13+
],
14+
subdir : 'gentoolkit/merge_driver_ekeyword'
15+
)
16+
17+
install_data(
18+
[
19+
'pytest.ini',
20+
],
21+
install_dir : py.get_install_dir() / 'gentoolkit' / 'merge_driver_ekeyword'
22+
)
23+
24+
subdir('tests')
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,3 @@
1+
[pytest]
2+
addopts = --cov
3+
python_files = test_*.py
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,21 @@
1+
install_data(
2+
[
3+
'conflict-near-KEYWORDS/A.ebuild',
4+
'conflict-near-KEYWORDS/B.ebuild',
5+
'conflict-near-KEYWORDS/common-ancestor.ebuild',
6+
'conflict-near-KEYWORDS/expected.ebuild',
7+
'multiple-KEYWORDS-conflict/A.ebuild',
8+
'multiple-KEYWORDS-conflict/B.ebuild',
9+
'multiple-KEYWORDS-conflict/common-ancestor.ebuild',
10+
'multiple-KEYWORDS-conflict/expected.ebuild',
11+
'non-KEYWORDS-conflict/A.ebuild',
12+
'non-KEYWORDS-conflict/B.ebuild',
13+
'non-KEYWORDS-conflict/common-ancestor.ebuild',
14+
'single-KEYWORDS-conflict/A.ebuild',
15+
'single-KEYWORDS-conflict/B.ebuild',
16+
'single-KEYWORDS-conflict/common-ancestor.ebuild',
17+
'single-KEYWORDS-conflict/expected.ebuild',
18+
],
19+
preserve_path: true,
20+
install_dir : py.get_install_dir() / 'gentoolkit' / 'merge_driver_ekeyword' / 'tests'
21+
)

pym/gentoolkit/meson.build

+1
Original file line numberDiff line numberDiff line change
@@ -31,5 +31,6 @@ subdir('enalyze')
3131
subdir('equery')
3232
subdir('eshowkw')
3333
subdir('imlate')
34+
subdir('merge_driver_ekeyword')
3435
subdir('revdep_rebuild')
3536
subdir('test')

0 commit comments

Comments
 (0)