Skip to content

Commit 4d6c189

Browse files
committed
Say hello to AuroraPlatform and AuroraCore
AuroraPlatform is a platform abstraction library that glues together compositors with EGL device integration and input device managers. Compositors will use the platform abstraction layer to access input and output devices directly. AuroraCore has utilities for compositors and device integration plugins. Closes: #41
1 parent 7fd7233 commit 4d6c189

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

43 files changed

+4666
-0
lines changed

CMakeLists.txt

+2
Original file line numberDiff line numberDiff line change
@@ -65,6 +65,8 @@ add_subdirectory(src/global)
6565
if(FEATURE_aurora_xkbcommon)
6666
add_subdirectory(src/platformsupport/xkbcommon)
6767
endif()
68+
add_subdirectory(src/core)
69+
add_subdirectory(src/platform)
6870
add_subdirectory(src/compositor)
6971
if(FEATURE_aurora_brcm)
7072
add_subdirectory(src/plugins/hardwareintegration/compositor/brcm-egl)

src/core/CMakeLists.txt

+29
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,29 @@
1+
# SPDX-FileCopyrightText: 2023 Pier Luigi Fiorini <[email protected]>
2+
# SPDX-License-Identifier: BSD-3-Clause
3+
4+
include(ECMQtDeclareLoggingCategory)
5+
ecm_qt_declare_logging_category(
6+
AuroraCore_SOURCES
7+
HEADER "auroracoreloggingcategories.h"
8+
IDENTIFIER "Aurora::Core::gLcAuroraCore"
9+
CATEGORY_NAME "aurora.core"
10+
DEFAULT_SEVERITY "Info"
11+
DESCRIPTION "Aurora core library"
12+
)
13+
14+
liri_add_module(AuroraCore
15+
DESCRIPTION
16+
"Utility library for Wayland compositors using Aurora"
17+
SOURCES
18+
colorspace.cpp colorspace.h
19+
cursorsource.cpp cursorsource.h
20+
shapecursorsource.cpp shapecursorsource.h
21+
xcursor.c xcursor.h
22+
xcursortheme.cpp xcursortheme_p.h
23+
${AuroraCore_SOURCES}
24+
PUBLIC_LIBRARIES
25+
Qt6::Core
26+
Qt6::Gui
27+
)
28+
29+
liri_finalize_module(AuroraCore)

0 commit comments

Comments
 (0)