Skip to content

Commit

Permalink
add: fontviewer (#2205)
Browse files Browse the repository at this point in the history
* Create specfile

Signed-off-by: sadlerm4 <[email protected]>

* Add patch for meson.build

Signed-off-by: sadlerm4 <[email protected]>

* Create anda.hcl and update.rhai

Signed-off-by: sadlerm4 <[email protected]>

* Update version and add packager directive

---------

Signed-off-by: sadlerm4 <[email protected]>
(cherry picked from commit 1a5d368)
  • Loading branch information
sadlerm4 authored and raboneko committed Oct 8, 2024
1 parent c4324db commit fe083cb
Show file tree
Hide file tree
Showing 4 changed files with 69 additions and 0 deletions.
5 changes: 5 additions & 0 deletions anda/apps/fontviewer/anda.hcl
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
project pkg {
rpm {
spec = "fontviewer.spec"
}
}
12 changes: 12 additions & 0 deletions anda/apps/fontviewer/fontviewer-meson.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff --git a/meson.build b/meson.build
index 4784ac2..2348b13 100644
--- a/meson.build
+++ b/meson.build
@@ -13,4 +13,5 @@ executable(
dependency('cairomm-1.0'),
dependency('freetype2'),
],
-)
\ No newline at end of file
+ install: true
+)
47 changes: 47 additions & 0 deletions anda/apps/fontviewer/fontviewer.spec
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
%global commit dc5cd1490235f8c19424b3345a89727199c86df3
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global commit_date 20241003

Name: fontviewer
Version: %{commit_date}.git~%{shortcommit}
Release: 1%{?dist}
Summary: View and install fonts

License: GPL-2.0
URL: https://github.com/chocolateimage/%{name}
Source0: %{url}/archive/%{commit}.tar.gz
Patch0: fontviewer-meson.patch

BuildRequires: gcc-c++
BuildRequires: meson
BuildRequires: pkgconfig(cairomm-1.0)
BuildRequires: pkgconfig(fontconfig)
BuildRequires: pkgconfig(freetype2)
BuildRequires: pkgconfig(gtk+-3.0)
BuildRequires: pkgconfig(gtkmm-3.0)

Requires: gtk3 fontconfig

Packager: sadlerm <[email protected]>

%description
A platform-agnostic GTK+ 3 alternative to GNOME's Font Viewer

%prep
%autosetup -n %{name}-%{commit} -p1

%build
%meson
%meson_build

%install
%meson_install

install -m 0755 -vd %{buildroot}%{_datadir}/applications
install -m 0755 -vp data/%{name}.desktop %{buildroot}%{_datadir}/applications/

%files
%license LICENSE
%doc README.md
%{_bindir}/%{name}
%{_datadir}/applications/%{name}.desktop
5 changes: 5 additions & 0 deletions anda/apps/fontviewer/update.rhai
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
rpm.global("commit", gh_commit("chocolateimage/fontviewer"));
if rpm.changed() {
rpm.release();
rpm.global("commit_date", date());
}

0 comments on commit fe083cb

Please sign in to comment.