-
-
Notifications
You must be signed in to change notification settings - Fork 23
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
* Create specfile Signed-off-by: sadlerm4 <[email protected]> * Add patch for meson.build Signed-off-by: sadlerm4 <[email protected]> * Create anda.hcl and update.rhai Signed-off-by: sadlerm4 <[email protected]> * Update version and add packager directive --------- Signed-off-by: sadlerm4 <[email protected]> (cherry picked from commit 1a5d368)
- Loading branch information
Showing
4 changed files
with
69 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
project pkg { | ||
rpm { | ||
spec = "fontviewer.spec" | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
diff --git a/meson.build b/meson.build | ||
index 4784ac2..2348b13 100644 | ||
--- a/meson.build | ||
+++ b/meson.build | ||
@@ -13,4 +13,5 @@ executable( | ||
dependency('cairomm-1.0'), | ||
dependency('freetype2'), | ||
], | ||
-) | ||
\ No newline at end of file | ||
+ install: true | ||
+) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,47 @@ | ||
%global commit dc5cd1490235f8c19424b3345a89727199c86df3 | ||
%global shortcommit %(c=%{commit}; echo ${c:0:7}) | ||
%global commit_date 20241003 | ||
|
||
Name: fontviewer | ||
Version: %{commit_date}.git~%{shortcommit} | ||
Release: 1%{?dist} | ||
Summary: View and install fonts | ||
|
||
License: GPL-2.0 | ||
URL: https://github.com/chocolateimage/%{name} | ||
Source0: %{url}/archive/%{commit}.tar.gz | ||
Patch0: fontviewer-meson.patch | ||
|
||
BuildRequires: gcc-c++ | ||
BuildRequires: meson | ||
BuildRequires: pkgconfig(cairomm-1.0) | ||
BuildRequires: pkgconfig(fontconfig) | ||
BuildRequires: pkgconfig(freetype2) | ||
BuildRequires: pkgconfig(gtk+-3.0) | ||
BuildRequires: pkgconfig(gtkmm-3.0) | ||
|
||
Requires: gtk3 fontconfig | ||
|
||
Packager: sadlerm <[email protected]> | ||
|
||
%description | ||
A platform-agnostic GTK+ 3 alternative to GNOME's Font Viewer | ||
|
||
%prep | ||
%autosetup -n %{name}-%{commit} -p1 | ||
|
||
%build | ||
%meson | ||
%meson_build | ||
|
||
%install | ||
%meson_install | ||
|
||
install -m 0755 -vd %{buildroot}%{_datadir}/applications | ||
install -m 0755 -vp data/%{name}.desktop %{buildroot}%{_datadir}/applications/ | ||
|
||
%files | ||
%license LICENSE | ||
%doc README.md | ||
%{_bindir}/%{name} | ||
%{_datadir}/applications/%{name}.desktop |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
rpm.global("commit", gh_commit("chocolateimage/fontviewer")); | ||
if rpm.changed() { | ||
rpm.release(); | ||
rpm.global("commit_date", date()); | ||
} |