-
Notifications
You must be signed in to change notification settings - Fork 4
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
This is a fairly simple configuration of ISSM, but it demonstrates building with Intel compilers and MKL to bring in the PETSc dependency.
- Loading branch information
Showing
1 changed file
with
50 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,50 @@ | ||
# Copyright 2013-2023 Lawrence Livermore National Security, LLC and other | ||
# Spack Project Developers. See the top-level COPYRIGHT file for details. | ||
# | ||
# SPDX-License-Identifier: (Apache-2.0 OR MIT) | ||
|
||
from spack.package import * | ||
|
||
|
||
class Issm(AutotoolsPackage): | ||
"""Ice-sheet and Sea-Level System Model""" | ||
|
||
homepage = "https://issm.jpl.nasa.gov/" | ||
svn = "https://issm.ess.uci.edu/svn/issm/issm/trunk" | ||
|
||
version("develop") | ||
|
||
depends_on("autoconf", type="build") | ||
depends_on("automake", type="build") | ||
depends_on("libtool", type="build") | ||
depends_on("m4", type="build") | ||
|
||
depends_on("mpi") | ||
depends_on("triangle") | ||
depends_on("petsc+metis+mumps+scalapack") | ||
depends_on("m1qn3") | ||
|
||
def autoreconf(self, spec, prefix): | ||
autoreconf("--install", "--verbose", "--force") | ||
|
||
def configure_args(self): | ||
args = [ | ||
"--with-wrappers=no", | ||
"--enable-debugging", | ||
"--enable-development", | ||
"--enable-shared", | ||
"--without-kriging", | ||
] | ||
args.append("--with-triangle-dir={0}".format(self.spec["triangle"].prefix)) | ||
args.append("--with-petsc-dir={0}".format(self.spec["petsc"].prefix)) | ||
args.append("--with-metis-dir={0}".format(self.spec["metis"].prefix)) | ||
args.append("--with-mumps-dir={0}".format(self.spec["mumps"].prefix)) | ||
args.append("--with-m1qn3-dir={0}".format(self.spec["m1qn3"].prefix.lib)) | ||
args.append("--with-mpi-include={0}".format(self.spec["mpi"].prefix.include)) | ||
|
||
args.append("CC=" + self.spec["mpi"].mpicc) | ||
args.append("CXX=" + self.spec["mpi"].mpicxx) | ||
args.append("FC=" + self.spec["mpi"].mpifc) | ||
args.append("F77=" + self.spec["mpi"].mpif77) | ||
|
||
return args |