-
Notifications
You must be signed in to change notification settings - Fork 28
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
* flake.lock: Update Flake lock file updates: • Updated input 'CHaP': 'github:input-output-hk/cardano-haskell-packages/653fe92c94baff7e89a9ff199a7bdcdadbd3fc1b' (2023-11-03) → 'github:input-output-hk/cardano-haskell-packages/53af7297cedefb4bbd463c070b559b6be83f0c2e' (2023-11-10) • Updated input 'hackage-nix': 'github:input-output-hk/hackage.nix/22ab6ca22da8ad7e8fb1318549c63e92ef6b0c2e' (2023-11-04) → 'github:input-output-hk/hackage.nix/d35b4834083dec7af29d5d9a597735f89e9a7280' (2023-11-11) * Revise plutus-ledger-api-1.15.0.0 to add an upper bound on nothunks --------- Co-authored-by: github-actions[bot] <github-actions[bot]@users.noreply.github.com> Co-authored-by: Michael Peyton Jones <[email protected]> Co-authored-by: Michael Peyton Jones <[email protected]>
- Loading branch information
1 parent
5f12e4f
commit 050c27c
Showing
3 changed files
with
216 additions
and
6 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,7 @@ | ||
timestamp = 2023-10-17T01:24:54Z | ||
github = { repo = "input-output-hk/plutus", rev = "7e208c2221a91d7d5949f215ee877a95792bda0c" } | ||
subdir = 'plutus-ledger-api' | ||
|
||
[[revisions]] | ||
number = 1 | ||
timestamp = 2023-11-14T14:12:36Z |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,206 @@ | ||
cabal-version: 3.0 | ||
name: plutus-ledger-api | ||
version: 1.15.0.0 | ||
license: Apache-2.0 | ||
license-files: | ||
LICENSE | ||
NOTICE | ||
|
||
maintainer: [email protected] | ||
author: Michael Peyton Jones, Jann Mueller | ||
synopsis: Interface to the Plutus ledger for the Cardano ledger. | ||
description: | ||
Interface to the Plutus scripting support for the Cardano ledger. | ||
|
||
category: Language | ||
build-type: Simple | ||
extra-doc-files: CHANGELOG.md | ||
|
||
source-repository head | ||
type: git | ||
location: https://github.com/input-output-hk/plutus | ||
|
||
common lang | ||
default-language: Haskell2010 | ||
default-extensions: | ||
DeriveFoldable | ||
DeriveFunctor | ||
DeriveGeneric | ||
DeriveLift | ||
DeriveTraversable | ||
DerivingStrategies | ||
ExplicitForAll | ||
FlexibleContexts | ||
GeneralizedNewtypeDeriving | ||
ImportQualifiedPost | ||
MultiParamTypeClasses | ||
ScopedTypeVariables | ||
StandaloneDeriving | ||
|
||
-- See Plutus Tx readme for why we need the following flags: | ||
-- -fobject-code -fno-ignore-interface-pragmas and -fno-omit-interface-pragmas | ||
ghc-options: | ||
-Wall -Wnoncanonical-monad-instances -Wincomplete-uni-patterns | ||
-Wincomplete-record-updates -Wredundant-constraints -Widentities | ||
-Wunused-packages -Wmissing-deriving-strategies -fobject-code | ||
-fno-ignore-interface-pragmas -fno-omit-interface-pragmas | ||
-fno-strictness | ||
|
||
library | ||
import: lang | ||
hs-source-dirs: src | ||
default-language: Haskell2010 | ||
exposed-modules: | ||
Codec.CBOR.Extras | ||
PlutusLedgerApi.Common | ||
PlutusLedgerApi.Common.Versions | ||
PlutusLedgerApi.V1 | ||
PlutusLedgerApi.V1.Address | ||
PlutusLedgerApi.V1.Bytes | ||
PlutusLedgerApi.V1.Contexts | ||
PlutusLedgerApi.V1.Credential | ||
PlutusLedgerApi.V1.Crypto | ||
PlutusLedgerApi.V1.DCert | ||
PlutusLedgerApi.V1.EvaluationContext | ||
PlutusLedgerApi.V1.Interval | ||
PlutusLedgerApi.V1.ParamName | ||
PlutusLedgerApi.V1.Scripts | ||
PlutusLedgerApi.V1.Time | ||
PlutusLedgerApi.V1.Tx | ||
PlutusLedgerApi.V1.Value | ||
PlutusLedgerApi.V2 | ||
PlutusLedgerApi.V2.Contexts | ||
PlutusLedgerApi.V2.EvaluationContext | ||
PlutusLedgerApi.V2.ParamName | ||
PlutusLedgerApi.V2.Tx | ||
PlutusLedgerApi.V3 | ||
PlutusLedgerApi.V3.Contexts | ||
PlutusLedgerApi.V3.EvaluationContext | ||
PlutusLedgerApi.V3.ParamName | ||
|
||
other-modules: | ||
PlutusLedgerApi.Common.Eval | ||
PlutusLedgerApi.Common.ParamName | ||
PlutusLedgerApi.Common.ProtocolVersions | ||
PlutusLedgerApi.Common.SerialisedScript | ||
Prettyprinter.Extras | ||
|
||
build-depends: | ||
, base >=4.9 && <5 | ||
, base16-bytestring >=1 | ||
, bytestring | ||
, cborg | ||
, containers | ||
, deepseq | ||
, flat ^>=0.6 | ||
, lens | ||
, mtl | ||
, nothunks < 0.1.5 | ||
, plutus-core ^>=1.15 | ||
, plutus-tx ^>=1.15 | ||
, prettyprinter | ||
, serialise | ||
, tagged | ||
, text | ||
|
||
library plutus-ledger-api-testlib | ||
import: lang | ||
visibility: public | ||
hs-source-dirs: testlib | ||
exposed-modules: | ||
PlutusLedgerApi.Test.Common.EvaluationContext | ||
PlutusLedgerApi.Test.EvaluationEvent | ||
PlutusLedgerApi.Test.Examples | ||
PlutusLedgerApi.Test.Scripts | ||
PlutusLedgerApi.Test.V1.EvaluationContext | ||
PlutusLedgerApi.Test.V2.EvaluationContext | ||
PlutusLedgerApi.Test.V3.EvaluationContext | ||
|
||
build-depends: | ||
, barbies | ||
, base >=4.9 && <5 | ||
, base64-bytestring | ||
, bytestring | ||
, containers | ||
, plutus-core ^>=1.15 | ||
, plutus-ledger-api ^>=1.15 | ||
, plutus-tx ^>=1.15 | ||
, prettyprinter | ||
, PyF >=0.11.1.0 | ||
, serialise | ||
, text | ||
|
||
test-suite plutus-ledger-api-test | ||
import: lang | ||
type: exitcode-stdio-1.0 | ||
main-is: Spec.hs | ||
hs-source-dirs: test | ||
other-modules: | ||
Spec.CBOR.DeserialiseFailureInfo | ||
Spec.CostModelParams | ||
Spec.Eval | ||
Spec.Interval | ||
Spec.NoThunks | ||
Spec.Versions | ||
|
||
build-depends: | ||
, base >=4.9 && <5 | ||
, bytestring | ||
, cborg | ||
, containers | ||
, extra | ||
, hedgehog | ||
, mtl | ||
, nothunks | ||
, plutus-core:{plutus-core, plutus-core-testlib} ^>=1.15 | ||
, plutus-ledger-api:{plutus-ledger-api, plutus-ledger-api-testlib} ^>=1.15 | ||
, plutus-tx:plutus-tx-testlib ^>=1.15 | ||
, tasty | ||
, tasty-hedgehog | ||
, tasty-hunit | ||
, tasty-quickcheck | ||
|
||
-- A suite for tests that use the Plutus Tx plugin. We don't merge those into | ||
-- @plutus-ledger-api-test@, because @plutus-ledger-api@ has to be buildable for older versions of | ||
-- GHC (a requirement imposed by @cardano-node@) and while its tests don't have to, we don't want to | ||
-- give up on all @plutus-ledger-api@ tests for older versions of GHC. | ||
test-suite plutus-ledger-api-plugin-test | ||
import: lang | ||
|
||
if impl(ghc <9.0) | ||
buildable: False | ||
|
||
type: exitcode-stdio-1.0 | ||
main-is: Spec.hs | ||
hs-source-dirs: test-plugin | ||
other-modules: Spec.Value | ||
build-depends: | ||
, base >=4.9 && <5 | ||
, containers | ||
, plutus-core:{plutus-core, plutus-core-testlib} ^>=1.15 | ||
, plutus-ledger-api ^>=1.15 | ||
, plutus-tx ^>=1.15 | ||
, plutus-tx-plugin ^>=1.15 | ||
, prettyprinter | ||
, tasty | ||
|
||
-- This is a nightly test, so it is an executable instead of test-suite to avoid | ||
-- running this in CI. | ||
executable evaluation-test | ||
import: lang | ||
main-is: Main.hs | ||
hs-source-dirs: test-onchain-evaluation | ||
ghc-options: -threaded -rtsopts -with-rtsopts=-N | ||
build-depends: | ||
, async | ||
, base >=4.9 && <5 | ||
, extra | ||
, filepath | ||
, mtl | ||
, plutus-core ^>=1.15 | ||
, plutus-ledger-api:{plutus-ledger-api, plutus-ledger-api-testlib} ^>=1.15 | ||
, serialise | ||
, tasty | ||
, tasty-hunit | ||
|
||
default-language: Haskell2010 |
Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.
Oops, something went wrong.