Skip to content

Commit

Permalink
update patchset
Browse files Browse the repository at this point in the history
laffer1 committed Jan 21, 2025

Verified

This commit was created on GitHub.com and signed with GitHub’s verified signature.
1 parent 4e121e4 commit 7960444
Showing 8 changed files with 125 additions and 132 deletions.
16 changes: 5 additions & 11 deletions news/newsfetch/Makefile
Original file line number Diff line number Diff line change
@@ -1,26 +1,20 @@
# New ports collection makefile for: newsfetch
# Date created: 12 September 1997
# Whom: Jun-ichiro itojun Itoh <[email protected]>
#

#

PORTNAME= newsfetch
PORTVERSION= 1.21
PORTREVISION= 2
PORTREVISION= 4
CATEGORIES= news
MASTER_SITES= SUNSITE/system/news/readers

MAINTAINER= [email protected]
COMMENT= Download news articles from NNTP server
LICENSE= other

MAKE_ENV= BINDIR="${PREFIX}/bin" MANDIR="${PREFIX}/man/man"
MAKE_ENV= BINDIR="${PREFIX}/bin" MANDIR="${PREFIX}/share/man/man"

USES= uidfix
USES= dos2unix uidfix
DOS2UNIX_GLOB= *.c
CFLAGS+= -Wno-return-type
PLIST_FILES= bin/newsfetch \
man/man1/newsfetch.1.gz
share/man/man1/newsfetch.1.gz

do-configure:
(cd ${WRKSRC} && ( \
6 changes: 3 additions & 3 deletions news/newsfetch/files/patch-newsfetch.1
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- newsfetch.1.orig Tue Apr 14 20:04:25 1998
+++ newsfetch.1 Fri Jan 26 23:41:22 2001
@@ -5,7 +5,7 @@
--- newsfetch.1.orig 1998-04-14 11:04:25 UTC
+++ newsfetch.1
@@ -5,7 +5,7 @@ newsfetch - Pull news from an NNTP serve
.SH SYNOPSIS
.B newsfetch
.BI
10 changes: 5 additions & 5 deletions news/newsfetch/files/patch-newsfetch.c
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- newsfetch.c.orig Thu Jul 23 18:28:56 1998
+++ newsfetch.c Fri Jan 26 23:41:22 2001
--- newsfetch.c.orig 2016-06-20 15:59:53 UTC
+++ newsfetch.c
@@ -7,6 +7,7 @@


@@ -8,15 +8,15 @@
#include <signal.h>
#include <pwd.h>
#include <sys/types.h>
@@ -28,6 +29,7 @@
@@ -28,6 +29,7 @@ int terminate = 1;
int wait_after_articles = 0, articles_fetched=0, last_than_current;
int wait_for_time = 0, timeout=READ_TIMEOUT, article_fetching=0;
int cleanup=1, max_article, news_target=0, first_article, only_list=0;
+int port = 119;
char group[100], pipe_command[100];
FILE *rcfp, *rctmpfp, *socket_fp[2];
char lockfile[100];
@@ -59,6 +61,16 @@
@@ -59,6 +61,16 @@ if(argc < 2)
getHomedir(homedir);
strcpy(hostname,argv[1]);

@@ -33,7 +33,7 @@
get_commandline(argc, argv, dirname, rcfile,
&cleanup, &wait_after_articles, &wait_for_time,
&command_flag, execute_command,
@@ -75,7 +87,7 @@
@@ -75,7 +87,7 @@ if(argc < 2)
generateProcmailrc(homedir, rcfile, dirname, pipe_command);
}

210 changes: 105 additions & 105 deletions news/newsfetch/files/patch-nntp.c
Original file line number Diff line number Diff line change
@@ -1,106 +1,106 @@
--- nntp.c.orig Thu Jul 23 12:03:11 1998
+++ nntp.c Thu Jan 27 17:19:01 2005
@@ -20,6 +20,7 @@

char *header;
#define MAXBUFSIZE 500
--- nntp.c.orig 2016-06-20 15:59:53 UTC
+++ nntp.c
@@ -20,6 +20,7 @@ extern FILE *rcfp, *rctmpfp, *socket_fp[

char *header;
#define MAXBUFSIZE 500
+#define GROUP_FMT "%99s"
char command_buf[MAXBUFSIZE+1];

readNNTPdata()
@@ -33,7 +34,7 @@
{
/* dummy read to flush input */
readNNTPdata();
- fprintf(socket_fp[0],"MODE READER\n");
+ fprintf(socket_fp[0],"MODE READER\r\n");
readNNTPdata();
return(get_error(command_buf));
}
@@ -140,7 +141,8 @@
else
fprintf(rctmpfp,"%s",command_buf);
}
- items_read=sscanf(command_buf,"%s %d %d", group, &first_article, &max_article);
+ items_read=sscanf(command_buf,GROUP_FMT "%d %d", group, &first_article, &max_article);
+ group[sizeof(group)-1] = '\0';
if(items_read < 2)
return(0);
return(items_read);
@@ -151,7 +153,7 @@
int first_art, last_art, total_art, tmp ;

fprintf(stderr,"%s: ",group);
- fprintf(socket_fp[0],"GROUP %s\n",group);
+ fprintf(socket_fp[0],"GROUP %s\r\n",group);
readNNTPdata();

#ifdef DEBUG
@@ -180,7 +182,7 @@
first_article = last_art - max_article + 1;
}

- fprintf(socket_fp[0],"STAT %d\n",first_article);
+ fprintf(socket_fp[0],"STAT %d\r\n",first_article);
readNNTPdata();

while(!get_error1(command_buf))
@@ -196,7 +198,7 @@
return(0);
}

- fprintf(socket_fp[0],"STAT %d\n",first_article);
+ fprintf(socket_fp[0],"STAT %d\r\n",first_article);
readNNTPdata();
}
fprintf(stderr,"articles %d to %d\n",first_article,last_art);
@@ -256,7 +258,7 @@
fprintf(stderr," %c",0xd);
}

- fprintf(socket_fp[0],"ARTICLE\n");
+ fprintf(socket_fp[0],"ARTICLE\r\n");
readNNTPdata();
if(!get_error(command_buf))
return(0);
@@ -275,7 +277,7 @@
}

/* Make it little fast */
- fprintf(socket_fp[0],"NEXT\n");
+ fprintf(socket_fp[0],"NEXT\r\n");

article_fetching=1;

@@ -329,17 +331,19 @@
char groupname[100];

fprintf(stderr, "\nList of NewsGroups:\n");
- fprintf(socket_fp[0],"LIST\n");
+ fprintf(socket_fp[0],"LIST\r\n");
readNNTPdata();
if(!get_error2(command_buf))
exit(1);
readNNTPdata();
- sscanf(command_buf,"%s",groupname);
+ sscanf(command_buf,GROUP_FMT,groupname);
+ groupname[sizeof(groupname)-1] = '\0';
while(command_buf[0] != '.' || command_buf[1] != 13 )/*|| command_buf[1] != 10)*/
{
fprintf(stderr,"%s\n",groupname);
readNNTPdata();
- sscanf(command_buf,"%s",groupname);
+ sscanf(command_buf,GROUP_FMT,groupname);
+ groupname[sizeof(groupname)-1] = '\0';
}
exit(1);

@@ -348,7 +352,7 @@
sendQuit()
{

- fprintf(socket_fp[0],"QUIT\n");
+ fprintf(socket_fp[0],"QUIT\r\n");
readNNTPdata();
}

char command_buf[MAXBUFSIZE+1];

readNNTPdata()
@@ -33,7 +34,7 @@ setReaderMode()
{
/* dummy read to flush input */
readNNTPdata();
- fprintf(socket_fp[0],"MODE READER\n");
+ fprintf(socket_fp[0],"MODE READER\r\n");
readNNTPdata();
return(get_error(command_buf));
}
@@ -140,7 +141,8 @@ while(comment)
else
fprintf(rctmpfp,"%s",command_buf);
}
- items_read=sscanf(command_buf,"%s %d %d", group, &first_article, &max_article);
+ items_read=sscanf(command_buf,GROUP_FMT "%d %d", group, &first_article, &max_article);
+ group[sizeof(group)-1] = '\0';
if(items_read < 2)
return(0);
return(items_read);
@@ -151,7 +153,7 @@ checkGroup()
int first_art, last_art, total_art, tmp ;

fprintf(stderr,"%s: ",group);
- fprintf(socket_fp[0],"GROUP %s\n",group);
+ fprintf(socket_fp[0],"GROUP %s\r\n",group);
readNNTPdata();

#ifdef DEBUG
@@ -180,7 +182,7 @@ int first_art, last_art, total_art, tmp
first_article = last_art - max_article + 1;
}

- fprintf(socket_fp[0],"STAT %d\n",first_article);
+ fprintf(socket_fp[0],"STAT %d\r\n",first_article);
readNNTPdata();

while(!get_error1(command_buf))
@@ -196,7 +198,7 @@ int first_art, last_art, total_art, tmp
return(0);
}

- fprintf(socket_fp[0],"STAT %d\n",first_article);
+ fprintf(socket_fp[0],"STAT %d\r\n",first_article);
readNNTPdata();
}
fprintf(stderr,"articles %d to %d\n",first_article,last_art);
@@ -256,7 +258,7 @@ int check_header = 1;
fprintf(stderr," %c",0xd);
}

- fprintf(socket_fp[0],"ARTICLE\n");
+ fprintf(socket_fp[0],"ARTICLE\r\n");
readNNTPdata();
if(!get_error(command_buf))
return(0);
@@ -275,7 +277,7 @@ int check_header = 1;
}

/* Make it little fast */
- fprintf(socket_fp[0],"NEXT\n");
+ fprintf(socket_fp[0],"NEXT\r\n");

article_fetching=1;

@@ -329,17 +331,19 @@ getGroupList()
char groupname[100];

fprintf(stderr, "\nList of NewsGroups:\n");
- fprintf(socket_fp[0],"LIST\n");
+ fprintf(socket_fp[0],"LIST\r\n");
readNNTPdata();
if(!get_error2(command_buf))
exit(1);
readNNTPdata();
- sscanf(command_buf,"%s",groupname);
+ sscanf(command_buf,GROUP_FMT,groupname);
+ groupname[sizeof(groupname)-1] = '\0';
while(command_buf[0] != '.' || command_buf[1] != 13 )/*|| command_buf[1] != 10)*/
{
fprintf(stderr,"%s\n",groupname);
readNNTPdata();
- sscanf(command_buf,"%s",groupname);
+ sscanf(command_buf,GROUP_FMT,groupname);
+ groupname[sizeof(groupname)-1] = '\0';
}
exit(1);

@@ -348,7 +352,7 @@ exit(1);
sendQuit()
{

- fprintf(socket_fp[0],"QUIT\n");
+ fprintf(socket_fp[0],"QUIT\r\n");
readNNTPdata();
}

6 changes: 3 additions & 3 deletions news/newsfetch/files/patch-opt.c
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- opt.c.orig Wed Nov 19 19:01:47 2003
+++ opt.c Wed Nov 19 19:01:47 2003
@@ -192,8 +192,8 @@
--- opt.c.orig 2016-06-20 15:59:53 UTC
+++ opt.c
@@ -192,8 +192,8 @@ opt_help(char *prog_name)
{

char *options=
6 changes: 3 additions & 3 deletions news/newsfetch/files/patch-util.c
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- util.c.orig Wed Nov 19 19:01:47 2003
+++ util.c Wed Nov 19 19:01:47 2003
@@ -61,15 +61,15 @@
--- util.c.orig 2016-06-20 15:59:53 UTC
+++ util.c
@@ -61,15 +61,15 @@ generateProcmailrc(char *homedir, char *
FILE *fp, *fp1, *fp2;
char *tmp, buf[200], group[180], filterfile[100], procmailrcfile[100];
int i,j;
1 change: 1 addition & 0 deletions news/p5-News-Newsrc/Makefile
Original file line number Diff line number Diff line change
@@ -7,6 +7,7 @@ PKGNAMEPREFIX= p5-

MAINTAINER= [email protected]
COMMENT= Manage newsrc files
WWW= https://metacpan.org/release/News-Newsrc

LICENSE= artistic gpl
LICENSE_COMB= dual
2 changes: 0 additions & 2 deletions news/p5-News-Newsrc/pkg-descr
Original file line number Diff line number Diff line change
@@ -13,5 +13,3 @@ Methods are provided for
- testing whether articles are marked
- returning lists of newsgroups
- returning lists of articles

WWW: https://metacpan.org/release/News-Newsrc

0 comments on commit 7960444

Please sign in to comment.