increase some asset capacity #191
Annotations
10 errors and 11 warnings
lint:
config/reader_test.go#L25
the line is 123 characters long, which exceeds the maximum of 120 characters. (lll)
|
lint:
config/reader.go#L7
import 'github.com/MixinNetwork/mixin/crypto' is not allowed from list 'Main' (depguard)
|
lint:
config/reader.go#L8
import 'github.com/pelletier/go-toml' is not allowed from list 'Main' (depguard)
|
lint:
config/reader_test.go#L6
import 'github.com/stretchr/testify/require' is not allowed from list 'Main' (depguard)
|
lint:
config/reader.go#L87
Magic number: 1024, in <operation> detected (gomnd)
|
lint:
config/reader.go#L90
Magic number: 3600, in <operation> detected (gomnd)
|
lint:
config/reader.go#L92
return with no blank line before (nlreturn)
|
lint:
config/reader_test.go#L9
Function TestConfig missing the call to method parallel
|
lint:
config/reader_test.go#L13
error-nil: use require.NoError (testifylint)
|
lint:
config/reader_test.go#L20
bool-compare: use require.True (testifylint)
|
lint
The following actions use a deprecated Node.js version and will be forced to run on node20: golangci/golangci-lint-action@v3. For more info: https://github.blog/changelog/2024-03-07-github-actions-all-actions-will-run-on-node20-instead-of-node16-by-default/
|
lint:
config/reader.go#L14
var-naming: const KernelNetworkId should be KernelNetworkID (revive)
|
lint:
crypto/rand.go#L32
increment-decrement: should replace set[b] += 1 with set[b]++ (revive)
|
lint:
crypto/blake2b_test.go#L18
unexported-return: exported func NewBlake2bXOF returns unexported type *crypto.xof, which can be annoying to use (revive)
|
lint:
crypto/rand.go#L10
unexported-return: exported func RandReader returns unexported type *crypto.randReader, which can be annoying to use (revive)
|
lint:
crypto/signature.go#L66
receiver-naming: receiver name publicKey should be consistent with previous receiver name privateKey for Key (revive)
|
lint:
crypto/signature.go#L81
receiver-naming: receiver name publicKey should be consistent with previous receiver name privateKey for Key (revive)
|
lint:
util/base58/base58check_test.go#L61
redefines-builtin-id: redefinition of the built-in function len (revive)
|
lint:
storage/interface.go#L33
var-naming: interface method parameter nodeIdWithNetwork should be nodeIDWithNetwork (revive)
|
lint:
storage/badger_validation.go#L73
increment-decrement: should replace total += 1 with total++ (revive)
|
lint:
storage/badger_work.go#L153
increment-decrement: should replace wm[si] += 1 with wm[si]++ (revive)
|