Skip to content

Commit

Permalink
www-client/cromite: forgot
Browse files Browse the repository at this point in the history
  • Loading branch information
PF4Public committed Nov 24, 2024
1 parent cf632d0 commit cd84cb0
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 1 deletion.
2 changes: 1 addition & 1 deletion www-client/cromite/cromite-131.0.6778.85.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -92,7 +92,7 @@ if [ ! -z "${CHROMIUM_COMMITS[*]}" ]; then
SRC_URI+="https://github.com/google/dawn/commit/${i/-}.patch?full_index=true -> dawn-${i/-}.patch
"
elif [[ ${CHROMIUM_COMMITS[$i]} =~ ink ]]; then
SRC_URI+="https://github.com/google/ink/commit/${i/-}.patch?full_index=true -> ink-${i/-}.patch
SRC_URI+="https://github.com/google/ink/commit/${i/-}.patch?full_index=true -> ink-${i/-}.patch
"
elif [[ ${CHROMIUM_COMMITS[$i]} =~ vulkan-utility-libraries ]]; then
SRC_URI+="https://github.com/KhronosGroup/Vulkan-Utility-Libraries/commit/${i/-}.patch?full_index=true -> vulkan-utility-libraries-${i/-}.patch
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
From 403ee5b14df12c8ee3b3583177bbd30d930e9aaf Mon Sep 17 00:00:00 2001
From: Matt Jolly <[email protected]>
Date: Sat, 12 Oct 2024 13:45:37 +1000
Subject: [PATCH] Convert 'Const AtomicString' to 'const char *'.

I don't know why this is suddenly required?
--- a/third_party/blink/renderer/platform/wtf/text/text_codec_icu.cc
+++ b/third_party/blink/renderer/platform/wtf/text/text_codec_icu.cc
@@ -323,7 +323,10 @@ void TextCodecICU::CreateICUConverter() const {
DCHECK(!converter_icu_);

#if defined(USING_SYSTEM_ICU)
- const char* name = encoding_.GetName();
+ //convert to WTF::String to use existing `const char *` dependent functions
+ WTF::String nameString = encoding_.GetName();
+ std::string nameUtf8 = nameString.Utf8();
+ const char* name = nameUtf8.c_str();
needs_gbk_fallbacks_ =
name[0] == 'G' && name[1] == 'B' && name[2] == 'K' && !name[3];
#endif
@@ -448,7 +451,10 @@ String TextCodecICU::Decode(base::span<const uint8_t> data,
// <http://bugs.webkit.org/show_bug.cgi?id=17014>
// Simplified Chinese pages use the code A3A0 to mean "full-width space", but
// ICU decodes it as U+E5E5.
- if (!strcmp(encoding_.GetName(), "GBK")) {
+ // Convert AtomicString to String
+ WTF::String nameString = encoding_.GetName();
+ std::string nameUtf8 = nameString.Utf8();
+ if (!strcmp(nameUtf8.c_str(), "GBK")) {
if (EqualIgnoringASCIICase(encoding_.GetName(), "gb18030"))
resultString.Replace(0xE5E5, kIdeographicSpaceCharacter);
// Make GBK compliant to the encoding spec and align with GB18030
--
2.46.2

0 comments on commit cd84cb0

Please sign in to comment.