Skip to content

Commit

Permalink
switch to ifx
Browse files Browse the repository at this point in the history
  • Loading branch information
JakeOShannessy committed Apr 16, 2024
1 parent 80bdd41 commit 4f98d0e
Show file tree
Hide file tree
Showing 27 changed files with 1,607 additions and 47 deletions.
7 changes: 6 additions & 1 deletion .github/workflows/fds.yml
Original file line number Diff line number Diff line change
Expand Up @@ -64,7 +64,12 @@ jobs:
run: dnf install -y libxcrypt-compat || true
- name: Install fedora procps
run: dnf install -y procps || true
- run: dnf install -y intel-oneapi-compiler-fortran-2024.0.0-49819 intel-oneapi-mkl-devel-2024.0.0-49656 intel-oneapi-mpi-devel-2021.11.0-49493 openmpi-devel mpich-devel intel-oneapi-compiler-dpcpp-cpp-2024.0.0-49819 intel-oneapi-compiler-dpcpp-cpp-and-cpp-classic-2023.2.1-16
- run: dnf install -y intel-oneapi-compiler-fortran-2024.1.0-963 \
intel-oneapi-mkl-devel-2024.1.0-691 \
intel-oneapi-mpi-devel-2021.12.0-534 \
intel-oneapi-compiler-dpcpp-cpp-2024.1.0-963 \
intel-oneapi-compiler-dpcpp-cpp-and-cpp-classic-2023.2.1-16 \
openmpi-devel mpich-devel
- run: /opt/intel/oneapi/modulefiles-setup.sh
- name: Build RPM
run: |
Expand Down
2 changes: 1 addition & 1 deletion fds/5.5.3.spec
Original file line number Diff line number Diff line change
Expand Up @@ -18,7 +18,7 @@
%global intelmpi_build_command \
dir=$(pwd) \
target=${dir##*/} \
make FCOMPL=mpiifort FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
make FCOMPL=mpiifx FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
%global mpich_build_command \
dir=$(pwd) \
target=${dir##*/} \
Expand Down
2 changes: 1 addition & 1 deletion fds/6.1.2.spec
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@
%global intelmpi_build_command \
dir=$(pwd) \
target=${dir##*/} \
make FCOMPL=mpiifort FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
make FCOMPL=mpiifx FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
%global mpich_build_command \
dir=$(pwd) \
target=${dir##*/} \
Expand Down
2 changes: 1 addition & 1 deletion fds/6.2.0.spec
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@
%global intelmpi_build_command \
dir=$(pwd) \
target=${dir##*/} \
make FCOMPL=mpiifort FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
make FCOMPL=mpiifx FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
%global mpich_build_command \
dir=$(pwd) \
target=${dir##*/} \
Expand Down
2 changes: 1 addition & 1 deletion fds/6.3.0.spec
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@
%global intelmpi_build_command \
dir=$(pwd) \
target=${dir##*/} \
make FCOMPL=mpiifort FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
make FCOMPL=mpiifx FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
%global mpich_build_command \
dir=$(pwd) \
target=${dir##*/} \
Expand Down
2 changes: 1 addition & 1 deletion fds/6.3.1.spec
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@
%global intelmpi_build_command \
dir=$(pwd) \
target=${dir##*/} \
make FCOMPL=mpiifort FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
make FCOMPL=mpiifx FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
%global mpich_build_command \
dir=$(pwd) \
target=${dir##*/} \
Expand Down
2 changes: 1 addition & 1 deletion fds/6.3.2.spec
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@
%global intelmpi_build_command \
dir=$(pwd) \
target=${dir##*/} \
make FCOMPL=mpiifort FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
make FCOMPL=mpiifx FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
%global mpich_build_command \
dir=$(pwd) \
target=${dir##*/} \
Expand Down
2 changes: 1 addition & 1 deletion fds/6.4.0.spec
Original file line number Diff line number Diff line change
Expand Up @@ -13,5 +13,5 @@
%global intelmpi_build_command \
dir=$(pwd) \
target=${dir##*/} \
make FCOMPL=mpiifort FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
make FCOMPL=mpiifx FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
%global mpich_build_command ./make_fds.sh
2 changes: 1 addition & 1 deletion fds/6.5.0.spec
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@
%global intelmpi_build_command \
dir=$(pwd) \
target=${dir##*/} \
make FCOMPL=mpiifort FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
make FCOMPL=mpiifx FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
%global mpich_build_command \
dir=$(pwd) \
target=${dir##*/} \
Expand Down
2 changes: 1 addition & 1 deletion fds/6.5.1.spec
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@
%global intelmpi_build_command \
dir=$(pwd) \
target=${dir##*/} \
make FCOMPL=mpiifort FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
make FCOMPL=mpiifx FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
%global mpich_build_command \
dir=$(pwd) \
target=${dir##*/} \
Expand Down
2 changes: 1 addition & 1 deletion fds/6.5.2.spec
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@
%global intelmpi_build_command \
dir=$(pwd) \
target=${dir##*/} \
make FCOMPL=mpiifort FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
make FCOMPL=mpiifx FOPENMPFLAGS="-qopenmp -qopenmp-link static -liomp5" VPATH="../../FDS_Source" -f ../makefile "$target"
%global mpich_build_command \
dir=$(pwd) \
target=${dir##*/} \
Expand Down
2 changes: 1 addition & 1 deletion fds/6.5.3.spec
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@
%global intelmpi_build_command \
dir=$(pwd) \
target=${dir##*/} \
make MPIFORT=mpiifort VPATH="../../Source" -f ../makefile "$target"
make INTEL_IFORT=ifx MPIFORT=mpiifx VPATH="../../Source" -f ../makefile "$target"
%global mpich_build_command \
dir=$(pwd) \
target=${dir##*/} \
Expand Down
56 changes: 34 additions & 22 deletions fds/backports0.patch
Original file line number Diff line number Diff line change
Expand Up @@ -8,25 +8,37 @@ index 5e449d368..22de03a5d 100755
echo Building $target with Intel MPI and $INTEL_IFORT
-make -j4 VPATH="../../Source" -f ../makefile $target
+make -j4 VPATH="../../Source" INTEL_IFORT=ifx INTEL_MPI_IFORT=mpiifx -f ../makefile $target
diff --git a/Build/impi_intel_linux_openmp/make_fds.sh b/Build/impi_intel_linux_openmp/make_fds.sh
index 5e449d368..22de03a5d 100755
--- a/Build/impi_intel_linux_openmp/make_fds.sh
+++ b/Build/impi_intel_linux_openmp/make_fds.sh
@@ -7,4 +7,4 @@ dir=`pwd`
target=${dir##*/}

echo Building $target with Intel MPI and $INTEL_IFORT
-make -j4 VPATH="../../Source" -f ../makefile $target
+make -j4 VPATH="../../Source" INTEL_IFORT=ifx INTEL_MPI_IFORT=mpiifx -f ../makefile $target
diff --git a/Build/makefile b/Build/makefile
index 481a1f443..5b59b99a8 100644
index 481a1f443..5c887b0f8 100644
--- a/Build/makefile
+++ b/Build/makefile
@@ -14,9 +14,13 @@ VPATH = ../Source
@@ -14,8 +14,14 @@ VPATH = ../Source
# set compiler type

I_IFORT=ifort
+MPI_I_IFORT=mpifort
+
ifdef INTEL_IFORT
I_IFORT=$(INTEL_IFORT)
endif
+ifdef INTEL_MPI_IFORT
+ MPI_I_IFORT=$(INTEL_MPI_IFORT)
- I_IFORT=$(INTEL_IFORT)
+ I_IFORT=$(INTEL_IFORT)
+endif
+
+ifdef INTEL_MPI_IFORT
+ MPI_I_IFORT=$(INTEL_MPI_IFORT)
endif

ifeq ($(shell echo "check_quotes"),"check_quotes")
# windows
@@ -73,8 +77,8 @@ else
@@ -73,8 +79,8 @@ else
ifneq ("$(wildcard ${MKLROOT}/lib/intel64/libmkl_blacs_intelmpi_lp64.a)","")
# Use cluster_sparse_solver with intelmpi blacs
FFLAGSMKL_INTEL = -DWITH_MKL -I"${MKLROOT}/include"
Expand All @@ -37,7 +49,7 @@ index 481a1f443..5b59b99a8 100644
endif
ifneq ("$(wildcard ${MKLROOT}/lib/intel64/libmkl_blacs_openmpi_lp64.a)","")
# Use cluster_sparse_solver with openmpi blacs
@@ -147,7 +151,7 @@ main.obj: FFLAGS += $(FOPENMPFLAGS)
@@ -147,7 +153,7 @@ main.obj: FFLAGS += $(FOPENMPFLAGS)

impi_intel_win : MPILIB = "$(IMPI_RELEASE_ROOT)\impi.lib"
impi_intel_win : MPIINCLUDE = "$(I_MPI_ROOT)\include\mpi"
Expand All @@ -46,7 +58,7 @@ index 481a1f443..5b59b99a8 100644
impi_intel_win : FCOMPL = $(I_IFORT)
impi_intel_win : obj = fds_impi_intel_win
impi_intel_win : setup_win $(objwin_mpi)
@@ -209,29 +213,29 @@ impi_intel_win_openmp_db : setup_win $(objwin_mpi)
@@ -209,29 +215,29 @@ impi_intel_win_openmp_db : setup_win $(objwin_mpi)

impi_intel_linux : FFLAGS = -m64 -fc=$(I_IFORT) -O2 -ipo -no-wrap-margin $(GITINFO) $(FFLAGSMKL_INTEL) -DUSE_IFPORT
impi_intel_linux : LFLAGSMKL = $(LFLAGSMKL_INTEL)
Expand Down Expand Up @@ -82,7 +94,7 @@ index 481a1f443..5b59b99a8 100644
impi_intel_linux_openmp_db : FOPENMPFLAGS = -qopenmp
impi_intel_linux_openmp_db : obj = fds_impi_intel_linux_openmp_db
impi_intel_linux_openmp_db : setup $(obj_mpi)
@@ -239,14 +243,14 @@ impi_intel_linux_openmp_db : setup $(obj_mpi)
@@ -239,14 +245,14 @@ impi_intel_linux_openmp_db : setup $(obj_mpi)

impi_intel_linux_dv : FFLAGS = -m64 -fc=$(I_IFORT) -warn unused -O1 -g -traceback -no-wrap-margin $(GITINFO) $(FFLAGSMKL_INTEL) -DUSE_IFPORT
impi_intel_linux_dv : LFLAGSMKL = $(LFLAGSMKL_INTEL)
Expand All @@ -99,7 +111,7 @@ index 481a1f443..5b59b99a8 100644
impi_intel_linux_openmp_dv : FOPENMPFLAGS = -qopenmp
impi_intel_linux_openmp_dv : obj = fds_impi_intel_linux_openmp_dv
impi_intel_linux_openmp_dv : setup $(obj_mpi)
@@ -257,7 +261,7 @@ impi_intel_linux_openmp_dv : setup $(obj_mpi)
@@ -257,7 +263,7 @@ impi_intel_linux_openmp_dv : setup $(obj_mpi)
ompi_intel_osx : FFLAGS = -m64 -O2 -stand:f18 -no-wrap-margin $(GITINFO) $(FFLAGSMKL_CUSTOM)
ompi_intel_osx : LFLAGSMKL = $(LFLAGSMKL_CUSTOM) $(CLT_VERSION)
ompi_intel_osx : LFLAGS = -static-intel
Expand All @@ -108,7 +120,7 @@ index 481a1f443..5b59b99a8 100644
ompi_intel_osx : obj = fds_ompi_intel_osx
ompi_intel_osx : setup $(obj_mpi)
$(FCOMPL) $(FFLAGS) $(LFLAGS) -o $(obj) $(obj_mpi) $(LFLAGSMKL)
@@ -266,7 +270,7 @@ ompi_intel_osx_openmp : FFLAGS = -m64 -O2 -stand:f18 -no-wrap-margin $(GITINFO)
@@ -266,7 +272,7 @@ ompi_intel_osx_openmp : FFLAGS = -m64 -O2 -stand:f18 -no-wrap-margin $(GITINFO)
ompi_intel_osx_openmp : LFLAGSMKL = $(LFLAGSMKL_CUSTOM_OPENMP) $(CLT_VERSION)
ompi_intel_osx_openmp : LFLAGS = -static-intel
ompi_intel_osx_openmp : FOPENMPFLAGS = -qopenmp -qopenmp-link static
Expand All @@ -117,7 +129,7 @@ index 481a1f443..5b59b99a8 100644
ompi_intel_osx_openmp : obj = fds_ompi_intel_osx_openmp
ompi_intel_osx_openmp : setup $(obj_mpi)
$(FCOMPL) $(FFLAGS) $(LFLAGS) $(FOPENMPFLAGS) -o $(obj) $(obj_mpi) $(LFLAGSMKL)
@@ -274,7 +278,7 @@ ompi_intel_osx_openmp : setup $(obj_mpi)
@@ -274,7 +280,7 @@ ompi_intel_osx_openmp : setup $(obj_mpi)
ompi_intel_osx_db : FFLAGS = -m64 -check all -fp-stack-check -warn unused -O0 -auto -WB -g -traceback -fpe0 -nofltconsistency -stand:f18 -no-wrap-margin $(GITINFO) $(FFLAGSMKL_CUSTOM)
ompi_intel_osx_db : LFLAGSMKL = $(LFLAGSMKL_CUSTOM) $(CLT_VERSION)
ompi_intel_osx_db : LFLAGS = -static-intel
Expand All @@ -126,7 +138,7 @@ index 481a1f443..5b59b99a8 100644
ompi_intel_osx_db : obj = fds_ompi_intel_osx_db
ompi_intel_osx_db : setup $(obj_mpi)
$(FCOMPL) $(FFLAGS) $(LFLAGS) -o $(obj) $(obj_mpi) $(LFLAGSMKL)
@@ -283,7 +287,7 @@ ompi_intel_osx_openmp_db : FFLAGS = -m64 -check all -fp-stack-check -warn unused
@@ -283,7 +289,7 @@ ompi_intel_osx_openmp_db : FFLAGS = -m64 -check all -fp-stack-check -warn unused
ompi_intel_osx_openmp_db : LFLAGSMKL = $(LFLAGSMKL_CUSTOM_OPENMP) $(CLT_VERSION)
ompi_intel_osx_openmp_db : LFLAGS = -static-intel
ompi_intel_osx_openmp_db : FOPENMPFLAGS = -qopenmp -qopenmp-link static
Expand All @@ -135,7 +147,7 @@ index 481a1f443..5b59b99a8 100644
ompi_intel_osx_openmp_db : obj = fds_ompi_intel_osx_openmp_db
ompi_intel_osx_openmp_db : setup $(obj_mpi)
$(FCOMPL) $(FFLAGS) $(LFLAGS) $(FOPENMPFLAGS) -o $(obj) $(obj_mpi) $(LFLAGSMKL)
@@ -291,7 +295,7 @@ ompi_intel_osx_openmp_db : setup $(obj_mpi)
@@ -291,7 +297,7 @@ ompi_intel_osx_openmp_db : setup $(obj_mpi)
ompi_intel_osx_dv : FFLAGS = -m64 -warn unused -O1 -g -traceback -stand:f18 -no-wrap-margin $(GITINFO) $(FFLAGSMKL_CUSTOM)
ompi_intel_osx_dv : LFLAGSMKL = $(LFLAGSMKL_CUSTOM) $(CLT_VERSION)
ompi_intel_osx_dv : LFLAGS = -static-intel
Expand All @@ -144,7 +156,7 @@ index 481a1f443..5b59b99a8 100644
ompi_intel_osx_dv : obj = fds_ompi_intel_osx_dv
ompi_intel_osx_dv : setup $(obj_mpi)
$(FCOMPL) $(FFLAGS) $(LFLAGS) -o $(obj) $(obj_mpi) $(LFLAGSMKL)
@@ -300,7 +304,7 @@ ompi_intel_osx_openmp_dv : FFLAGS = -m64 -warn unused -O1 -g -traceback -stand:f
@@ -300,7 +306,7 @@ ompi_intel_osx_openmp_dv : FFLAGS = -m64 -warn unused -O1 -g -traceback -stand:f
ompi_intel_osx_openmp_dv : LFLAGSMKL = $(LFLAGSMKL_CUSTOM_OPENMP) $(CLT_VERSION)
ompi_intel_osx_openmp_dv : LFLAGS = -static-intel
ompi_intel_osx_openmp_dv : FOPENMPFLAGS = -qopenmp -qopenmp-link static
Expand All @@ -153,7 +165,7 @@ index 481a1f443..5b59b99a8 100644
ompi_intel_osx_openmp_dv : obj = fds_ompi_intel_osx_openmp_dv
ompi_intel_osx_openmp_dv : setup $(obj_mpi)
$(FCOMPL) $(FFLAGS) $(LFLAGS) $(FOPENMPFLAGS) -o $(obj) $(obj_mpi) $(LFLAGSMKL)
@@ -309,7 +313,7 @@ ompi_intel_osx_openmp_dv : setup $(obj_mpi)
@@ -309,7 +315,7 @@ ompi_intel_osx_openmp_dv : setup $(obj_mpi)

ompi_gnu_linux : FFLAGS = -m64 -O2 -std=f2018 -frecursive -ffpe-summary=none -fall-intrinsics $(GITINFOGNU) $(FFLAGSMKL_GNU_OPENMPI) $(GFORTRAN_OPTIONS)
ompi_gnu_linux : LFLAGSMKL = $(LFLAGSMKL_GNU_OPENMPI)
Expand All @@ -162,7 +174,7 @@ index 481a1f443..5b59b99a8 100644
ompi_gnu_linux : FOPENMPFLAGS = -fopenmp
ompi_gnu_linux : obj = fds_ompi_gnu_linux
ompi_gnu_linux : setup $(obj_mpi)
@@ -317,7 +321,7 @@ ompi_gnu_linux : setup $(obj_mpi)
@@ -317,7 +323,7 @@ ompi_gnu_linux : setup $(obj_mpi)

ompi_gnu_linux_db : FFLAGS = -m64 -O0 -std=f2018 -ggdb -Wall -Werror -Wunused-parameter -Wcharacter-truncation -Wno-target-lifetime -fcheck=all -fbacktrace -ffpe-trap=invalid,zero,overflow -frecursive -ffpe-summary=none -fall-intrinsics -fbounds-check $(GITINFOGNU) $(FFLAGSMKL_GNU_OPENMPI) $(GFORTRAN_OPTIONS)
ompi_gnu_linux_db : LFLAGSMKL = $(LFLAGSMKL_GNU_OPENMPI)
Expand All @@ -171,7 +183,7 @@ index 481a1f443..5b59b99a8 100644
ompi_gnu_linux_db : FOPENMPFLAGS = -fopenmp
ompi_gnu_linux_db : obj = fds_ompi_gnu_linux_db
ompi_gnu_linux_db : setup $(obj_mpi)
@@ -325,7 +329,7 @@ ompi_gnu_linux_db : setup $(obj_mpi)
@@ -325,7 +331,7 @@ ompi_gnu_linux_db : setup $(obj_mpi)

ompi_gnu_osx : FFLAGS = -m64 -O2 -std=f2018 -frecursive -ffpe-summary=none -fall-intrinsics $(GITINFOGNU) $(FFLAGSMKL_GNU_CUSTOM) $(GFORTRAN_OPTIONS)
ompi_gnu_osx : LFLAGSMKL = $(LFLAGSMKL_GNU_CUSTOM) $(CLT_VERSION)
Expand All @@ -180,7 +192,7 @@ index 481a1f443..5b59b99a8 100644
ompi_gnu_osx : FOPENMPFLAGS = -fopenmp
ompi_gnu_osx : obj = fds_ompi_gnu_osx
ompi_gnu_osx : setup $(obj_mpi)
@@ -333,7 +337,7 @@ ompi_gnu_osx : setup $(obj_mpi)
@@ -333,7 +339,7 @@ ompi_gnu_osx : setup $(obj_mpi)

ompi_gnu_osx_db : FFLAGS = -m64 -O0 -std=f2018 -ggdb -Wall -Wcharacter-truncation -Wno-target-lifetime -fcheck=all -fbacktrace -ffpe-trap=invalid,zero,overflow -frecursive -ffpe-summary=none -fall-intrinsics $(GITINFOGNU) $(FFLAGSMKL_GNU_CUSTOM) $(GFORTRAN_OPTIONS)
ompi_gnu_osx_db : LFLAGSMKL = $(LFLAGSMKL_GNU_CUSTOM) $(CLT_VERSION)
Expand All @@ -189,7 +201,7 @@ index 481a1f443..5b59b99a8 100644
ompi_gnu_osx_db : FOPENMPFLAGS = -fopenmp
ompi_gnu_osx_db : obj = fds_ompi_gnu_osx_db
ompi_gnu_osx_db : setup $(obj_mpi)
@@ -341,7 +345,7 @@ ompi_gnu_osx_db : setup $(obj_mpi)
@@ -341,7 +347,7 @@ ompi_gnu_osx_db : setup $(obj_mpi)

ompi_gnu_osx_dv : FFLAGS = -m64 -O1 -fbacktrace -std=f2018 -frecursive -ffpe-summary=none -fall-intrinsics $(GITINFOGNU) $(FFLAGSMKL_GNU_CUSTOM) $(GFORTRAN_OPTIONS)
ompi_gnu_osx_dv : LFLAGSMKL = $(LFLAGSMKL_GNU_CUSTOM) $(CLT_VERSION)
Expand Down
Loading

0 comments on commit 4f98d0e

Please sign in to comment.