Skip to content

Commit

Permalink
update modulefile process for intel 2024 compilers
Browse files Browse the repository at this point in the history
auto resolve module deps on older versions
  • Loading branch information
JakeOShannessy committed Dec 10, 2023
1 parent 8e15b86 commit 9c35bbb
Show file tree
Hide file tree
Showing 5 changed files with 31 additions and 20 deletions.
5 changes: 3 additions & 2 deletions .github/workflows/cfast.yml
Original file line number Diff line number Diff line change
Expand Up @@ -11,9 +11,10 @@ jobs:
container:
- "fedora:36"
- "fedora:37"
# - "fedora:38"
- "rockylinux:9"
- "fedora:38"
# - "fedora:39"
- "rockylinux:8"
- "rockylinux:9"
cfast-version:
- "7.0.1"
- "7.1.0"
Expand Down
7 changes: 4 additions & 3 deletions .github/workflows/fds.yml
Original file line number Diff line number Diff line change
Expand Up @@ -11,9 +11,10 @@ jobs:
container:
- "fedora:36"
- "fedora:37"
# - "fedora:38"
- "rockylinux:9"
- "fedora:38"
# - "fedora:39"
- "rockylinux:8"
- "rockylinux:9"
fds-version:
- "5.5.3"
- "6.1.2"
Expand Down Expand Up @@ -63,7 +64,7 @@ jobs:
run: dnf install -y libxcrypt-compat || true
- name: Install fedora procps
run: dnf install -y procps || true
- run: dnf install -y intel-oneapi-compiler-fortran-2023.2.1-16 intel-oneapi-mkl-devel-2023.2.0-49495 intel-oneapi-mpi-devel-2021.10.0-49371 openmpi-devel mpich-devel
- run: dnf install -y intel-oneapi-compiler-fortran-2024.0.0-49819 intel-oneapi-mkl-devel-2024.0.0-49656 intel-oneapi-mpi-devel-2021.11.0-49493 openmpi-devel mpich-devel intel-oneapi-compiler-dpcpp-cpp-2024.0.0-49819 intel-oneapi-compiler-dpcpp-cpp-and-cpp-classic-2023.2.1-16
- run: /opt/intel/oneapi/modulefiles-setup.sh
- name: Build RPM
run: |
Expand Down
5 changes: 3 additions & 2 deletions .github/workflows/smv.yml
Original file line number Diff line number Diff line change
Expand Up @@ -12,8 +12,9 @@ jobs:
- "fedora:36"
- "fedora:37"
- "fedora:38"
# - "rockylinux:8"
# - "rockylinux:9"
# - "fedora:39"
# - "rockylinux:8"
# - "rockylinux:9"
container: ${{ matrix.container }}
steps:
- uses: actions/checkout@v3
Expand Down
2 changes: 1 addition & 1 deletion fds/5.5.3.spec
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@
%{!?build_mpich:%global build_mpich 0}
%{!?build_intelmpi:%global build_intelmpi 1}
%{!?build_docs:%global build_docs 0}
%global old_compilers BuildRequires: intel-oneapi-compiler-dpcpp-cpp-and-cpp-classic-2023.1.0
%global old_compilers BuildRequires: intel-oneapi-compiler-dpcpp-cpp-and-cpp-classic
%global gnu_string mpi_gnu_linux
%global mpich_string mpich_gnu_linux
%global intel_string mpi_intel_linux
Expand Down
32 changes: 20 additions & 12 deletions fds/template.spec
Original file line number Diff line number Diff line change
@@ -1,19 +1,25 @@

%global this_release 3
%global this_release 4

#TODO: this isn't as clean as the openmpi version
%global _intelmpi_load \
export MODULES_AUTO_HANDLING=1; \
. /etc/profile.d/modules.sh; \
module use /opt/intel/oneapi/modulefiles \
module load mpi \
module load compiler \
module use ~/modulefiles; \
module load mpi/latest; \
module load compiler; \
module load ifort; \
module load icc; \
module load mkl;
%global _intelmpi_unload \
export MODULES_AUTO_HANDLING=1; \
. /etc/profile.d/modules.sh; \
module use /opt/intel/oneapi/modulefiles \
module unload mkl \
module unload compiler \
module unload mpi;
module use ~/modulefiles; \
module unload mkl; \
module unload icc; \
module unload ifort; \
module unload compiler; \
module unload mpi/latest;

Name: fds%{?version_suffix}
Version: %{this_version}
Expand Down Expand Up @@ -72,13 +78,13 @@ You will need to load the mpich-%{_arch} module to setup your path properly.
%if %{build_intelmpi}
%package intelmpi
Summary: Fire Dynamics Simulator with Intel MPI
BuildRequires: intel-oneapi-mpi-devel-2021.10.0
BuildRequires: intel-oneapi-mkl-devel-2023.2.0
BuildRequires: intel-oneapi-compiler-fortran-2023.2.1
BuildRequires: intel-oneapi-mpi-devel
BuildRequires: intel-oneapi-mkl-devel
BuildRequires: intel-oneapi-compiler-fortran
%{?old_compilers:%old_compilers}
BuildRequires: make
Requires: intel-oneapi-runtime-libs
Requires: intel-oneapi-mpi-2021.10.0
Requires: intel-oneapi-mpi
Requires: %{name}-common = %{version}-%{release}
%description intelmpi
FDS with IntelMPI
Expand Down Expand Up @@ -215,6 +221,8 @@ install -D %{repo}-%{commit}/%{build_dir}/%{intel_string}%{?arch_suffix}/fds%{?m
%endif

%changelog
* Sun Dec 10 2023 Jake O'Shannessy <[email protected]> - %{version}-4
- Unpin intel package versions
* Mon Jul 17 2023 Jake O'Shannessy <[email protected]> - %{version}-3
- Pin intel package versions
* Tue Nov 15 2022 Jake O'Shannessy <[email protected]> - %{version}-2
Expand Down

0 comments on commit 9c35bbb

Please sign in to comment.