-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-vcs/git-interactive-rebase-tool: new package, add 2.3.0
- Loading branch information
1 parent
dc58e41
commit 2a1512a
Showing
6 changed files
with
487 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Large diffs are not rendered by default.
Oops, something went wrong.
133 changes: 133 additions & 0 deletions
133
...-interactive-rebase-tool/files/git-interactive-rebase-tool-2.3.0-update-libgit2-sys.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,133 @@ | ||
diff --git a/Cargo.lock b/Cargo.lock | ||
index 3757eab..ecb7a1d 100644 | ||
--- a/Cargo.lock | ||
+++ b/Cargo.lock | ||
@@ -50,6 +50,12 @@ version = "1.3.2" | ||
source = "registry+https://github.com/rust-lang/crates.io-index" | ||
checksum = "bef38d45163c2f1dde094a7dfd33ccf595c92905c8f8f4fdc18d06fb1037718a" | ||
|
||
+[[package]] | ||
+name = "bitflags" | ||
+version = "2.4.2" | ||
+source = "registry+https://github.com/rust-lang/crates.io-index" | ||
+checksum = "ed570934406eb16438a4e976b1b4500774099c13b8cb96eec99f620f05090ddf" | ||
+ | ||
[[package]] | ||
name = "bumpalo" | ||
version = "3.13.0" | ||
@@ -132,7 +138,7 @@ version = "0.26.1" | ||
source = "registry+https://github.com/rust-lang/crates.io-index" | ||
checksum = "a84cda67535339806297f1b331d6dd6320470d2a0fe65381e79ee9e156dd3d13" | ||
dependencies = [ | ||
- "bitflags", | ||
+ "bitflags 1.3.2", | ||
"crossterm_winapi", | ||
"libc", | ||
"mio", | ||
@@ -335,7 +341,7 @@ name = "girt-core" | ||
version = "2.3.0" | ||
dependencies = [ | ||
"anyhow", | ||
- "bitflags", | ||
+ "bitflags 1.3.2", | ||
"captur", | ||
"chrono", | ||
"claim", | ||
@@ -394,7 +400,7 @@ name = "girt-input" | ||
version = "2.3.0" | ||
dependencies = [ | ||
"anyhow", | ||
- "bitflags", | ||
+ "bitflags 1.3.2", | ||
"captur", | ||
"crossbeam-channel", | ||
"crossterm", | ||
@@ -445,7 +451,7 @@ name = "girt-view" | ||
version = "2.3.0" | ||
dependencies = [ | ||
"anyhow", | ||
- "bitflags", | ||
+ "bitflags 1.3.2", | ||
"captur", | ||
"claim", | ||
"crossbeam-channel", | ||
@@ -470,11 +476,11 @@ dependencies = [ | ||
|
||
[[package]] | ||
name = "git2" | ||
-version = "0.15.0" | ||
+version = "0.18.2" | ||
source = "registry+https://github.com/rust-lang/crates.io-index" | ||
-checksum = "2994bee4a3a6a51eb90c218523be382fd7ea09b16380b9312e9dbe955ff7c7d1" | ||
+checksum = "1b3ba52851e73b46a4c3df1d89343741112003f0f6f13beb0dfac9e457c3fdcd" | ||
dependencies = [ | ||
- "bitflags", | ||
+ "bitflags 2.4.2", | ||
"libc", | ||
"libgit2-sys", | ||
"log", | ||
@@ -587,9 +593,9 @@ checksum = "b4668fb0ea861c1df094127ac5f1da3409a82116a4ba74fca2e58ef927159bb3" | ||
|
||
[[package]] | ||
name = "libgit2-sys" | ||
-version = "0.14.2+1.5.1" | ||
+version = "0.16.2+1.7.2" | ||
source = "registry+https://github.com/rust-lang/crates.io-index" | ||
-checksum = "7f3d95f6b51075fe9810a7ae22c7095f12b98005ab364d8544797a825ce946a4" | ||
+checksum = "ee4126d8b4ee5c9d9ea891dd875cfdc1e9d0950437179104b183d7d8a74d24e8" | ||
dependencies = [ | ||
"cc", | ||
"libc", | ||
@@ -826,7 +832,7 @@ version = "0.2.13" | ||
source = "registry+https://github.com/rust-lang/crates.io-index" | ||
checksum = "62f25bc4c7e55e0b0b7a1d43fb893f4fa1361d0abe38b9ce4f323c2adfe6ef42" | ||
dependencies = [ | ||
- "bitflags", | ||
+ "bitflags 1.3.2", | ||
] | ||
|
||
[[package]] | ||
@@ -835,7 +841,7 @@ version = "0.3.5" | ||
source = "registry+https://github.com/rust-lang/crates.io-index" | ||
checksum = "567664f262709473930a4bf9e51bf2ebf3348f2e748ccc50dea20646858f8f29" | ||
dependencies = [ | ||
- "bitflags", | ||
+ "bitflags 1.3.2", | ||
] | ||
|
||
[[package]] | ||
@@ -917,7 +923,7 @@ version = "0.37.23" | ||
source = "registry+https://github.com/rust-lang/crates.io-index" | ||
checksum = "4d69718bf81c6127a49dc64e44a742e8bb9213c0ff8869a22c308f84c1d4ab06" | ||
dependencies = [ | ||
- "bitflags", | ||
+ "bitflags 1.3.2", | ||
"errno", | ||
"io-lifetimes", | ||
"libc", | ||
diff --git a/src/git/Cargo.toml b/src/git/Cargo.toml | ||
index b5af456..57ca16f 100644 | ||
--- a/src/git/Cargo.toml | ||
+++ b/src/git/Cargo.toml | ||
@@ -22,7 +22,7 @@ tempfile = "3.6.0" | ||
thiserror = "1.0.43" | ||
|
||
[dependencies.git2] | ||
-version = "=0.15.0" | ||
+version = "0.18.2" | ||
default-features = false | ||
features = [] | ||
|
||
diff --git a/src/git/src/file_mode.rs b/src/git/src/file_mode.rs | ||
index 86d7956..940dbaf 100644 | ||
--- a/src/git/src/file_mode.rs | ||
+++ b/src/git/src/file_mode.rs | ||
@@ -16,7 +16,7 @@ impl FileMode { | ||
pub(crate) const fn from(file_mode: git2::FileMode) -> Self { | ||
match file_mode { | ||
git2::FileMode::Commit | git2::FileMode::Tree | git2::FileMode::Unreadable => Self::Other, | ||
- git2::FileMode::Blob => Self::Normal, | ||
+ git2::FileMode::Blob | git2::FileMode::BlobGroupWritable => Self::Normal, | ||
git2::FileMode::BlobExecutable => Self::Executable, | ||
git2::FileMode::Link => Self::Link, | ||
} |
184 changes: 184 additions & 0 deletions
184
dev-vcs/git-interactive-rebase-tool/git-interactive-rebase-tool-2.3.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="person"> | ||
<name>Benjamin Neff</name> | ||
<email>[email protected]</email> | ||
</maintainer> | ||
<upstream> | ||
<remote-id type="github">MitMaro/git-interactive-rebase-tool</remote-id> | ||
</upstream> | ||
</pkgmetadata> |
Oops, something went wrong.