Vanilla MacOSX on T430, almost perfectly with Sierra 12.6!
Credits to Rehabman
WORKING =)
Intel Hyperthread (8 Threads)
Intel TurboBoost (up to 3.2 Ghz)
Intel SpeedStep
CPU HW Monitor (temps, clock and power)
RAM DDR3 at 1600mhz
Intel HD4000 1536MB
Brightness (FULL Range + Fn Brightness Keys)
Display Port Out FullHD + Audio
Battery Status
WiFi + Bluetooth (using a rebranded Atheros Ar5b195)
Ethernet
Sleep (with both working sleep leds on/off)
Display turns on automatically on wake/instant wake
USB 3.0 Full Speed
Audio ALC269 (Everything works, even after sleep)
Webcam + Mic
Keyboard+ TouchPad
NOT WORKING ...
On Shutdown, need to remove USB 3.0 devices otherwise system will restart (USB 2.0 is ok!)
SSD Trim (disabled. not recommended for OEM SSD’s on MacOSX)
VGA output (apple doesn’t have support)
SD Card Reader
NEW! REBRAND A DUAL BAND ATHEROS TO USE ON T430:
There is an Atheros ID's signature that passes on T430 whitelist. Follow the steps on my another repository:
https://github.com/ThiagoSchetini/AR9285-rebranding
CREATING INSTALLER
-> With Unibeast select Sierra UEFI only without ATI/nVidia (look at tools folder)
-> After creation of USB Installer go to EFI/CLOVER/drivers64UEFI/
Remove everything and put the 4 files this repository
-> Put all the kexts from 10.12 (or about the version you are trying to make) on other
-> Remove all the kexts folders except other
INSTALL MAC OSX
-> You need a mouse and external keyboard pluged (only for the install process)
-> If stucks on boot disable inject intel graphics
SHOW HIDDEN FILES PLEASE!
-> after first boot, on Terminal:
defaults write com.apple.finder AppleShowAllFiles YES
killAll Finder
INSTALL CLOVER (Your EFI Boot)
-> Install “clover.pkg” (look inside tools folder)
Check Install for UEFI Booting Only
Check Install Clover in the ESP
Check Drivers 64 UEFI (IMPORTANT! only OsxAptioFix2Drv-64)
-> Now you can remove your Installer Pen Drive (you have boot)
EFI/CLOVER
-> config.plist: use the one from this repository
take from low-resolution-config.plist folder for 1366x768 display
take from high-resolution-config.plist folder for 1600x900 or + display
-> /drivers64UEFI
use the folder from this repository (with 4 files only!)
-> /kexts
Remove everything except other (leave it empty)
-> /ACPI/patched:
(OPTION 1 Hard One - Recommended) Make your own SSDT and DSDT:
-> First you need the vanilla .aml generated by your UEFI (BIOS)
Enter in the clover boot menu and press F4 and FN+F4
That’s all. It’s gonna be on EFI/CLOVER/ACPI/origin
-> Them disassembly correctly only the DSDT.aml and DSDT’s.aml (0, 1, 2 etc…)
please, don’t open directly on MacIASL!
use iasl on terminal (look at tools folder/iasl howTo.txt)
-> patch your DSDT.dsl with all the code from file “…-dsdt-patch.txt” using MacIASL
it includes only the necessary code to Thinkpad T430
* choose low resolution for 1366 x 762
* choose high resolution for 1600 x 900 or +
-> manually last patch for screen turn on after wake (Warning! It’s a manual change)
on your .dsl find for “Return (WAKI)”
On the last two method calls there is:
\_SB.PCI0.LPC.EC.LED(Zero, 0x80)
\_SB.PCI0.LPC.EC.LED(0x07, 0x00)
change for (carefull with identation, must be perfect):
\_SI._SST (One)
\_GPE._L1D ()
-> Save from MacIASL as binary (.aml) and paste on ACPI/patched inside clover UEFI
-> Generate your own SSDT (Power Management for your processor)
https://www.tonymacx86.com/threads/quick-guide-to-generate-a-ssdt-for-cpu-power-management.177456/
-> Put the SSDT.aml on the same folder of DSDT: ACPI/patched inside clover UEFI
(OPTION 2 Easy One - Not recommended) take my patched files .aml:
->take ONLY the .aml files from “pached ACPI dsl’s” folder
* choose only one SSDT.aml: “i5 3230M” or “i7 3632QM”
* if you have another processor make your own SSDT or leave it empty
-> Put the .aml files on the folder: ACPI/patched inside clover UEFI
KEXTS
-> Make a beckup of AppleBacklight.kext (Brightness)
Why? for future updates you need to reinstall the original and then reinstall the pached
** Warning!, the backlight kext inside kexts folder is patched for T430 brightness full range control
-> Now, install all the kexts from the folder using “Kext Utility.app” (look inside tools folder)
VOODOO EXTRA FILES (for Keyboard)
-> enter inside voodoo's' folder with the terminal
sudo cp org.rehabman.voodoo.driver.Daemon.plist /Library/LaunchDaemons
sudo cp VoodooPS2Daemon /usr/bin
NOW, RESTART AND GET AUDIO WORKING
-> after restart you need to flush the kexts:
sudo touch /System/Library/Extensions && sudo kextcache -u /
-> restart again to see the audio working!
NO AUDIO YET?
-> sudo touch /System/Library/Extensions && sudo kextcache -u /
-> Restart Again!
* If you have problems, try to disable the option No Cache on config.plist and restart again.
HWMONITOR
-> Put the HWMONITOR from tools folder on applications and open it, you should read power, clock, and temps of your CPU
NO HIBERNATE AT ALL
-> Disable Hibernation and related options
sudo pmset -a hibernatemode 0
sudo rm /var/vm/sleepimage
sudo mkdir /var/vm/sleepimage
sudo pmset -a standby 0
sudo pmset -a autopoweroff 0
ABOUT THIS DSDT CODE
-> basically I modified some original patches from Rehabman:
[modified] Lenovo X220
-> added T430 sleep leds
-> cleaned extra code
[modified] Brightness fix (HD3000/HD4000)
-> included FN brightness keys (T430 only)
[usb] USB3_PRW 0x0D (instant wake)
-> to have sleep working (original Rehabman code)
[audio] Audio Layout 28
-> to work with the ALC269 kext (original Rehabman code)
[sys] IRQ Fix
-> to enable audio (original Rehabman code)
[igpu] Low Resolution (or High)
-> to enable HDMI display port audio out
[manual] Code change on .dsl to turn on screen automatically on wake
COMPLETE KEXT FLUSH (recomended after remove a kext)
-> repair permissions:
sudo /usr/libexec/repair_packages --repair --standard-pkgs --volume /
-> rebuild kext cache
sudo rm -r /System/Library/Caches/com.apple.kext.caches
sudo touch /System/Library/Extensions
sudo kextcache -update-volume /
-> rebuild cache short form
sudo touch /System/Library/Extensions && sudo kextcache -u /
GENERATE VANILLA CONFIG.PLIST (if you need)
on /usr/local/bin/clover-genconfig >config.plist
execute and take the xml
AGAIN, HOW TO REBRAND A DUAL BAND ATHEROS TO USE ON T430:
`https://github.com/ThiagoSchetini/AR9285-rebranding`
HOW TO FLASH T430 BIOS (if you want to install an 1300AC WiFi …)
https://github.com/bibanon/Coreboot-ThinkPads/wiki/xx30-BIOS-Whitelist-Removal