Skip to content

Commit

Permalink
doxygen: upgrade 1.9.3 -> 1.12.0
Browse files Browse the repository at this point in the history
ChangeLog:
https://www.doxygen.nl/manual/changelog.html#log_1_12_0

* Refresh patch
* Backport a patch to fix build with clang
* Drop doxygen-native-only-check-python3.patch as the issue can not be
  reproduced.

Signed-off-by: Yi Zhao <[email protected]>
Signed-off-by: Khem Raj <[email protected]>
  • Loading branch information
yizhao1 authored and kraj committed Oct 15, 2024
1 parent d61c2c9 commit 6a08213
Show file tree
Hide file tree
Showing 4 changed files with 64 additions and 244 deletions.
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 24650b0c7db6b213a2eaa5061b75b9f1b43f1ce9 Mon Sep 17 00:00:00 2001
From 2d587d043fc061c53c3d8015501392a804c5f0b4 Mon Sep 17 00:00:00 2001
From: Bartosz Golaszewski <[email protected]>
Date: Fri, 23 Nov 2018 11:44:56 +0100
Subject: [PATCH] build: don't look for Iconv
Expand All @@ -7,31 +7,31 @@ Drop the find_package() for Iconv. CMake is unable to find iconv.h in
native build but all modern systems supply it as part of the standard
C library. We don't need this check in meta-openembedded.

Signed-off-by: Bartosz Golaszewski <[email protected]>
Signed-off-by: Randy MacLeod <[email protected]>

Upstream-Status: Inappropriate
Upstream-Status: Inappropriate [oe-specific]
- upstream doxygen must build on many architectures, this change is
too intrusive for upstream

Signed-off-by: Bartosz Golaszewski <[email protected]>
Signed-off-by: Randy MacLeod <[email protected]>
---
CMakeLists.txt | 4 ----
1 file changed, 4 deletions(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 06b9696f..f30b46b8 100644
index 3adf456..ad73997 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -117,10 +117,6 @@ if (sqlite3)
endif()
@@ -212,10 +212,6 @@ if ((CMAKE_BUILD_TYPE STREQUAL "Debug") OR enable_lex_debug)
set(LEX_FLAGS "${LEX_FLAGS} -d")
endif()

-find_package(Iconv REQUIRED)
-include_directories(${ICONV_INCLUDE_DIR})
-include_directories(${Iconv_INCLUDE_DIRS})
-
-
#set(DOXYDOCS ${PROJECT_SOURCE_DIR}/doc CACHE INTERNAL "Path to doxygen docs")
set(DOXYDOCS ${PROJECT_BINARY_DIR}/doc)
set(ENV{DOXYGEN_DOCDIR} ${DOXYDOCS})
--
2.27.0
2.25.1

Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
From cff64a87dea7596fd506a85521d4df4616dc845f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bernhard=20Rosenkr=C3=A4nzer?= <[email protected]>
Date: Fri, 9 Aug 2024 14:13:34 +0200
Subject: [PATCH] Fix build with clang >= 19.0

Clang >= 19.0 requires a template argument list after the template
keyword for CWG96 compliance, see
https://github.com/llvm/llvm-project/pull/80801

This patch has also been submitted to upstream TinyDeflate as
https://github.com/bisqwit/TinyDeflate/pull/9

Upstream-Status: Backport
[https://github.com/doxygen/doxygen/commit/cff64a87dea7596fd506a85521d4df4616dc845f]

Signed-off-by: Yi Zhao <[email protected]>
---
deps/TinyDeflate/gunzip.hh | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/deps/TinyDeflate/gunzip.hh b/deps/TinyDeflate/gunzip.hh
index 652058ab8..3ba341487 100644
--- a/deps/TinyDeflate/gunzip.hh
+++ b/deps/TinyDeflate/gunzip.hh
@@ -1141,21 +1141,21 @@ namespace gunzip_ns
//fprintf(stderr, "both track flag\n");
SizeTracker<DeflateTrackBothSize> tracker;
return tracker(Gunzip<code & Flag_NoTrackFlagMask>
- (tracker.template ForwardInput(i), tracker.template ForwardOutput(o), tracker.template ForwardWindow(c), std::forward<B>(b)));
+ (tracker.template ForwardInput<I>(i), tracker.template ForwardOutput<O>(o), tracker.template ForwardWindow<C>(c), std::forward<B>(b)));
}
else if constexpr(code & Flag_TrackIn)
{
//fprintf(stderr, "in track flag\n");
SizeTracker<DeflateTrackInSize> tracker;
return tracker(Gunzip<code & Flag_NoTrackFlagMask>
- (tracker.template ForwardInput(i),std::forward<O>(o),std::forward<C>(c),std::forward<B>(b)));
+ (tracker.template ForwardInput<I>(i),std::forward<O>(o),std::forward<C>(c),std::forward<B>(b)));
}
else if constexpr(code & Flag_TrackOut)
{
//fprintf(stderr, "out track flag\n");
SizeTracker<DeflateTrackOutSize> tracker;
return tracker(Gunzip<code & Flag_NoTrackFlagMask>
- (std::forward<I>(i), tracker.template ForwardOutput(o), tracker.template ForwardWindow(c), std::forward<B>(b)));
+ (std::forward<I>(i), tracker.template ForwardOutput<O>(o), tracker.template ForwardWindow<C>(c), std::forward<B>(b)));
}
else
{
--
2.25.1

This file was deleted.

Original file line number Diff line number Diff line change
Expand Up @@ -8,9 +8,9 @@ DEPENDS = "flex-native bison-native"

SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.src.tar.gz \
file://0001-build-don-t-look-for-Iconv.patch \
file://0002-Fix-build-with-clang-19.0.patch \
"
SRC_URI:append:class-native = " file://doxygen-native-only-check-python3.patch"
SRC_URI[sha256sum] = "f352dbc3221af7012b7b00935f2dfdc9fb67a97d43287d2f6c81c50449d254e0"
SRC_URI[sha256sum] = "a3a3dba2018ef409d83d81a2fc42a0d19bdbe087252ef342bf214b51b8b01634"

UPSTREAM_CHECK_URI = "https://github.com/doxygen/doxygen/releases"
UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"
Expand Down

0 comments on commit 6a08213

Please sign in to comment.