Skip to content

Commit

Permalink
alarm/vlc-rpi to 3.0.18-1
Browse files Browse the repository at this point in the history
  • Loading branch information
graysky2 committed Dec 4, 2022
1 parent e581353 commit 8446892
Show file tree
Hide file tree
Showing 10 changed files with 131 additions and 189 deletions.
12 changes: 12 additions & 0 deletions alarm/vlc-rpi/0001-vlc-live-media-2021.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -ru vlc-3.0.13.orig/configure.ac vlc-3.0.13/configure.ac
--- vlc-3.0.13.orig/configure.ac 2021-04-27 15:18:39.000000000 +0200
+++ vlc-3.0.13/configure.ac 2021-05-03 16:26:26.691200904 +0200
@@ -1825,7 +1825,7 @@
AC_MSG_ERROR([Update live555 or pass --disable-live555 to disable RTSP input support.])
])
], [
- other_libs="-lgroupsock -lBasicUsageEnvironment -lUsageEnvironment"
+ other_libs="-lcrypto -lssl -lgroupsock -lBasicUsageEnvironment -lUsageEnvironment"
other_libs_pic="-lgroupsock_pic -lBasicUsageEnvironment_pic -lUsageEnvironment_pic"
AS_IF([test "${SYS}" = "mingw32"], [
# add ws2_32 for closesocket, select, recv
130 changes: 0 additions & 130 deletions alarm/vlc-rpi/0002-caca-fix-to-newer-version.patch

This file was deleted.

108 changes: 108 additions & 0 deletions alarm/vlc-rpi/0002-libplacebo-5.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,108 @@
patch vaguely ported from: https://code.videolan.org/videolan/vlc/-/merge_requests/2233

diff --git a/modules/video_output/opengl/converter.h b/modules/video_output/opengl/converter.h
index 7000e1f..49fa667 100644
--- a/modules/video_output/opengl/converter.h
+++ b/modules/video_output/opengl/converter.h
@@ -26,6 +26,9 @@
#include <vlc_picture_pool.h>
#include <vlc_opengl.h>

+#include <libplacebo/log.h>
+#include <libplacebo/shaders.h>
+
/* if USE_OPENGL_ES2 is defined, OpenGL ES version 2 will be used, otherwise
* normal OpenGL will be used */
#ifdef __APPLE__
@@ -253,10 +256,6 @@ static inline bool HasExtension(const char *apis, const char *api)
return false;
}

-struct pl_context;
-struct pl_shader;
-struct pl_shader_res;
-
/*
* Structure that is filled by "glhw converter" module probe function
* The implementation should initialize every members of the struct that are
@@ -273,7 +272,7 @@ struct opengl_tex_converter_t
vlc_gl_t *gl;

/* libplacebo context, created by the caller (optional) */
- struct pl_context *pl_ctx;
+ pl_log pl_log;

/* Function pointers to OpenGL functions, set by the caller */
const opengl_vtable_t *vt;
@@ -337,7 +336,7 @@ struct opengl_tex_converter_t
bool yuv_color;
GLfloat yuv_coefficients[16];

- struct pl_shader *pl_sh;
+ pl_shader pl_sh;
const struct pl_shader_res *pl_sh_res;

/* Private context */
diff --git a/modules/video_output/opengl/fragment_shaders.c b/modules/video_output/opengl/fragment_shaders.c
index ecf7226..29f4148 100644
--- a/modules/video_output/opengl/fragment_shaders.c
+++ b/modules/video_output/opengl/fragment_shaders.c
@@ -611,7 +611,7 @@ opengl_fragment_shader_init_impl(opengl_tex_converter_t *tc, GLenum tex_target,

#ifdef HAVE_LIBPLACEBO
if (tc->pl_sh) {
- struct pl_shader *sh = tc->pl_sh;
+ pl_shader sh = tc->pl_sh;
struct pl_color_map_params color_params = pl_color_map_default_params;
color_params.intent = var_InheritInteger(tc->gl, "rendering-intent");
color_params.tone_mapping_algo = var_InheritInteger(tc->gl, "tone-mapping");
@@ -634,7 +634,7 @@ opengl_fragment_shader_init_impl(opengl_tex_converter_t *tc, GLenum tex_target,
pl_color_space_from_video_format(&tc->fmt),
dst_space, NULL, false);

- struct pl_shader_obj *dither_state = NULL;
+ pl_shader_obj dither_state = NULL;
int method = var_InheritInteger(tc->gl, "dither-algo");
if (method >= 0) {

diff --git a/modules/video_output/opengl/vout_helper.c b/modules/video_output/opengl/vout_helper.c
index 13d65e0..1ee99af 100644
--- a/modules/video_output/opengl/vout_helper.c
+++ b/modules/video_output/opengl/vout_helper.c
@@ -570,8 +570,7 @@ opengl_deinit_program(vout_display_opengl_t *vgl, struct prgm *prgm)

#ifdef HAVE_LIBPLACEBO
FREENULL(tc->uloc.pl_vars);
- if (tc->pl_ctx)
- pl_context_destroy(&tc->pl_ctx);
+ pl_log_destroy(&tc->pl_log);
#endif

vlc_object_release(tc);
@@ -622,21 +621,21 @@ opengl_init_program(vout_display_opengl_t *vgl, struct prgm *prgm,
// create the main libplacebo context
if (!subpics)
{
- tc->pl_ctx = pl_context_create(PL_API_VER, &(struct pl_context_params) {
+ tc->pl_log = pl_log_create(PL_API_VER, &(struct pl_log_params) {
.log_cb = log_cb,
.log_priv = tc,
.log_level = PL_LOG_INFO,
});
- if (tc->pl_ctx) {
+ if (tc->pl_log) {
# if PL_API_VER >= 20
- tc->pl_sh = pl_shader_alloc(tc->pl_ctx, &(struct pl_shader_params) {
+ tc->pl_sh = pl_shader_alloc(tc->pl_log, &(struct pl_shader_params) {
.glsl.version = tc->glsl_version,
.glsl.gles = tc->is_gles,
});
# elif PL_API_VER >= 6
- tc->pl_sh = pl_shader_alloc(tc->pl_ctx, NULL, 0);
+ tc->pl_sh = pl_shader_alloc(tc->pl_log, NULL, 0);
# else
- tc->pl_sh = pl_shader_alloc(tc->pl_ctx, NULL, 0, 0);
+ tc->pl_sh = pl_shader_alloc(tc->pl_log, NULL, 0, 0);
# endif
}
}
File renamed without changes.
26 changes: 0 additions & 26 deletions alarm/vlc-rpi/0003-vlc-live-media-2021.patch

This file was deleted.

18 changes: 0 additions & 18 deletions alarm/vlc-rpi/0004-add-extern-qualifiers.patch

This file was deleted.

File renamed without changes.
File renamed without changes.
File renamed without changes.
26 changes: 11 additions & 15 deletions alarm/vlc-rpi/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -6,12 +6,12 @@

pkgname=vlc-rpi
_pkgname=vlc
_vlcver=3.0.17.4
_vlcver=3.0.18
# optional fixup version including hyphen
_vlcfixupver=
_commit=b6a28bbbec2b56851085178016c300724d66b41b
pkgver=${_vlcver}${_vlcfixupver//-/.r}
pkgrel=2
pkgrel=1
pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player with hw accel for RPi 3/4/400'
url='https://www.videolan.org/vlc/'
arch=(aarch64)
Expand Down Expand Up @@ -109,25 +109,21 @@ install='vlc.install'
source=(https://download.videolan.org/${_pkgname}/${_vlcver}/${_pkgname}-${_vlcver}${_vlcfixupver}.tar.xz{,.asc}
99-vlc.rules
vlc.config.txt
0001-vlc-dav1d-1.0.patch::https://github.com/videolan/vlc/commit/2202c892c8dc.patch
0002-caca-fix-to-newer-version.patch
0003-vlc-live-media-2021.patch
0001-vlc-live-media-2021.patch
0002-libplacebo-5.patch
# credit to RPi-Distro maintainers for this work
# https://github.com/RPi-Distro/vlc/tree/bullseye-rpt/debian/patches
0004-add-extern-qualifiers.patch
0005-mmal_29.patch
0006-mmal_caca.patch
0007-mmal_chain.patch
0008-mmal_exit_fix.patch
0003-mmal_29.patch
0004-mmal_caca.patch
0005-mmal_chain.patch
0006-mmal_exit_fix.patch
update-vlc-plugin-cache.hook)
sha256sums=('8c5a62d88a4fb45c1b095cf10befef217dfa87aedcec5184b9e7d590b6dd4133'
sha256sums=('57094439c365d8aa8b9b41fa3080cc0eef2befe6025bb5cef722accc625aedec'
'SKIP'
'61125ab0da600d813f1aebd8445fcf03e176389cfb8aa28591f8225a13043089'
'be970a020695fdc4d0f968021f057a1cb625eeb6ee62995560e532d61ffb52dc'
'1078b8dacbf2a2cacb4bf835f3e5817c816926604d8e564610604d92e20e02db'
'a45340d4f4fc371c70ae96e13ee8ced28930e77b1598b2429ac84a4a31029b86'
'08f6a07a149039255d34ff04db08c3de477966118f62339a631b53ffa2dfd85a'
'5f3513dc82f2acfe27cfd13c604c89e3b201f828f5934dde649318c18fd656a7'
'753517a8b88c5950d516f0fe57a3ef169e0665ba7817d4b8d9976c666829a291'
'c47ecb0e8e8c03f8c5451aa12fc2e38e380364c38c411a13aa38b7b41def6989'
'81af488135039377f5460acc9e8ff4679f3e2033a847fac90b95d14412c2a70a'
'53613a6eee1c215a7becd9a8b97d0ed9a034684a586b9437f35f215a5c859d1a'
'a06d62bc579405588f5730a707af602d68f17d764a061f74958135aab34e4d92'
Expand Down

0 comments on commit 8446892

Please sign in to comment.