Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Feat(eos_designs): Add WAN interface configuration under l3_edge.l3_interfaces #3440

Merged
merged 35 commits into from
Jan 5, 2024
Merged
Show file tree
Hide file tree
Changes from 24 commits
Commits
Show all changes
35 commits
Select commit Hold shift + click to select a range
e4cba93
WIP
gmuloc Dec 15, 2023
4711478
WIP: Handle Stun - need to fix l3edge shared_utils
gmuloc Dec 16, 2023
74ed1f3
Feat: Add path-groups
gmuloc Dec 16, 2023
3296485
Fix: Filter properly on path-group name for stun profiles
gmuloc Dec 17, 2023
b9bb353
Feat: Add flow-tracking on WAN interfaces
gmuloc Dec 18, 2023
f12f9fa
Feat(eos_designs): Add support for cv_pathfinder_connected_to_pathfinder
gmuloc Dec 19, 2023
999e637
Refactor: Fix in place modification of l3_edge.l3_interfaces
gmuloc Dec 20, 2023
482b99b
Doc: Update documentation for wan interfaces
gmuloc Dec 20, 2023
fb5f686
Merge branch 'devel' into wan-intf
gmuloc Dec 20, 2023
01213c3
Doc: Add limitation
gmuloc Dec 20, 2023
09599ea
Doc: Fix schema documentation as per PR review
gmuloc Dec 20, 2023
227a669
Refactor: Support dhcp on pathfinder interface when set via wan_path_…
gmuloc Dec 20, 2023
bdbc14e
Refactor: Make Path-group ID mandatory for now
gmuloc Dec 20, 2023
f77afa0
CI: Run da pre-commit
gmuloc Dec 20, 2023
55a631d
Refactor: Add WAN carriers
gmuloc Dec 20, 2023
3ef9ebd
Feat: Add support for multiple interfaces in same path-group in CV Pa…
gmuloc Dec 20, 2023
a43ed77
CI: Run pre-commit
gmuloc Dec 20, 2023
12ef123
Feat: Add support for default route
gmuloc Dec 21, 2023
fcfb56a
Feat: Add stun static peers for the wan_route_servers
gmuloc Dec 21, 2023
05033e5
Refactor: PR comment
gmuloc Dec 21, 2023
b51b5a7
Test: Fix negative unit tests
gmuloc Dec 21, 2023
ae57029
Refactor: DRYing some of the code
gmuloc Dec 21, 2023
6b17b30
Merge branch 'devel' into wan-intf
gmuloc Dec 21, 2023
6e9a713
Test: Maybe fix idemptoency
gmuloc Dec 21, 2023
5c09d54
Merge branch 'devel' into wan-intf
gmuloc Jan 2, 2024
b06c480
Merge branch 'devel' into wan-intf
gmuloc Jan 3, 2024
c7cd289
Refactor: Rename connected_to_pathfinder
gmuloc Jan 3, 2024
066a17d
Doc: Add dem newlines
gmuloc Jan 3, 2024
8fae511
Refactor: Use interface name instead of id for stun server-profiles
gmuloc Jan 3, 2024
26828c2
Refactor: Change orders for stun server-profiles names
gmuloc Jan 3, 2024
e804df3
Refactor: Simon says be idempotent
gmuloc Jan 3, 2024
50a9560
Refactor: Simplify stun server profile names
gmuloc Jan 3, 2024
703afd1
Refactor: Address PR comments
gmuloc Jan 4, 2024
1908e95
Refactor: Address PR comments
gmuloc Jan 5, 2024
39d0803
Doc: Better description for wan_path_groups.ipsec
gmuloc Jan 5, 2024
File filter

Filter by extension

Filter by extension

Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
Original file line number Diff line number Diff line change
Expand Up @@ -4,6 +4,14 @@ type: wan_edge

bgp_as: 65000

wan_carriers:
- name: MPLS
path_group: MPLS

wan_path_groups:
- name: MPLS
id: 42

wan_edge:
defaults:
loopback_ipv4_pool: 192.168.0.0/24
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -4,6 +4,14 @@ type: wan_rr

bgp_as: 65000

wan_carriers:
- name: MPLS
path_group: MPLS

wan_path_groups:
- name: MPLS
id: 42

wan_rr:
defaults:
loopback_ipv4_pool: 192.168.0.0/24
Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,7 @@
---
wan_mode: autovpn
type: wan_edge
fabric_name: fabric_wan_role_overlay_routing_protocol

# Not ibgp
overlay_routing_protocol: none
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -45,6 +45,9 @@ all:
invalid-uplink-port-channel-id-l3leaf-2:
invalid-uplink-port-channel-id-l2leaf-1:
invalid-uplink-port-channel-id-l2leaf-2:
fabric_wan_role_overlay_routing_protocol:
hosts:
invalid-wan-role-overlay-routing-protocol:
EOS_DESIGNS_FAILURES: # Add cases that fail during 'eos_designs_structured_config' phase
hosts:
failure-port-channel:
Expand Down Expand Up @@ -79,7 +82,6 @@ all:
failure-duplicate-evpn-vlan-bundle-name:
ntp-settings-server-vrf-missing-mgmt-ip:
ntp-settings-server-vrf-missing-inband-mgmt-interface:
invalid-wan-role-overlay-routing-protocol:
invalid-wan-role-cv-pathfinder-role-1:
invalid-wan-role-cv-pathfinder-role-2:
source-interfaces-domain-lookup-duplicate-vrf:
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,24 @@ hostname autovpn-edge
!
router path-selection
!
path-group INET id 101
ipsec profile AUTOVPN
!
local interface Ethernet1
stun server-profile autovpn-rr1-INET-0 autovpn-rr2-INET-0
!
peer dynamic
!
peer static router-ip 192.168.31.1
name autovpn-rr1
ipv4 address 10.7.7.7
!
peer static router-ip 192.168.31.2
name autovpn-rr2
ipv4 address 10.8.8.8
!
load-balance policy LBPOLICY
path-group INET
!
policy dps-policy-default
default-match
Expand Down Expand Up @@ -48,6 +65,12 @@ interface Dps1
description DPS Interface
tcp mss ceiling ipv4 1000
!
interface Ethernet1
no shutdown
no switchport
ip address dhcp
dhcp client accept default-route
!
interface Loopback0
description Router_ID
no shutdown
Expand Down Expand Up @@ -100,4 +123,11 @@ management api http-commands
vrf MGMT
no shutdown
!
stun
client
server-profile autovpn-rr1-INET-0
gmuloc marked this conversation as resolved.
Show resolved Hide resolved
ip address 10.7.7.7/31
server-profile autovpn-rr2-INET-0
ip address 10.8.8.8/31
!
end
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,17 @@ hostname autovpn-rr1
router path-selection
peer dynamic source stun
!
path-group INET id 101
ipsec profile AUTOVPN
!
local interface Ethernet1
!
peer static router-ip 192.168.31.2
name autovpn-rr2
ipv4 address 10.8.8.8
!
load-balance policy LBPOLICY
path-group INET
!
policy dps-policy-default
default-match
Expand Down Expand Up @@ -46,6 +56,12 @@ interface Dps1
description DPS Interface
tcp mss ceiling ipv4 1000
!
interface Ethernet1
gmuloc marked this conversation as resolved.
Show resolved Hide resolved
no shutdown
no switchport
ip address dhcp
dhcp client accept default-route
!
interface Loopback0
description Router_ID
no shutdown
Expand Down Expand Up @@ -111,5 +127,6 @@ management api http-commands
!
stun
server
local-interface Ethernet1
!
end
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,17 @@ hostname autovpn-rr2
router path-selection
peer dynamic source stun
!
path-group INET id 101
ipsec profile AUTOVPN
!
local interface Ethernet1
!
peer static router-ip 192.168.31.1
name autovpn-rr1
ipv4 address 10.7.7.7
!
load-balance policy LBPOLICY
path-group INET
!
policy dps-policy-default
default-match
Expand Down Expand Up @@ -46,6 +56,11 @@ interface Dps1
description DPS Interface
tcp mss ceiling ipv4 1000
!
interface Ethernet1
no shutdown
no switchport
ip address 10.8.8.8/31
!
interface Loopback0
description Router_ID
no shutdown
Expand All @@ -60,6 +75,8 @@ interface Vxlan1
ip routing
no ip routing vrf MGMT
!
ip route 0.0.0.0/0 10.8.8.9
!
router bfd
multihop interval 300 min-rx 300 multiplier 3
!
Expand Down Expand Up @@ -111,5 +128,6 @@ management api http-commands
!
stun
server
local-interface Ethernet1
!
end
Original file line number Diff line number Diff line change
Expand Up @@ -19,7 +19,28 @@ hostname cv-pathfinder-edge
!
router path-selection
!
path-group INET id 101
ipsec profile CP-PROFILE
!
local interface Ethernet1
stun server-profile cv-pathfinder-pathfinder-INET-0 cv-pathfinder-pathfinder-INET-1
!
peer dynamic
!
peer static router-ip 192.168.44.1
name cv-pathfinder-pathfinder
ipv4 address 10.7.7.7
ipv4 address 10.9.9.9
!
path-group MPLS id 100
!
local interface Ethernet2
!
peer dynamic
!
load-balance policy LBPOLICY
path-group INET
path-group MPLS
!
router adaptive-virtual-topology
topology role edge
Expand Down Expand Up @@ -74,6 +95,19 @@ interface Dps1
flow tracker hardware WAN-FLOW-TRACKER
tcp mss ceiling ipv4 1000
!
interface Ethernet1
no shutdown
no switchport
flow tracker hardware WAN-FLOW-TRACKER
ip address dhcp
dhcp client accept default-route
!
interface Ethernet2
no shutdown
no switchport
flow tracker hardware WAN-FLOW-TRACKER
ip address 172.15.5.5/31
!
interface Loopback0
description Router_ID
no shutdown
Expand Down Expand Up @@ -131,4 +165,11 @@ management api http-commands
vrf MGMT
no shutdown
!
stun
client
server-profile cv-pathfinder-pathfinder-INET-0
ip address 10.7.7.7/31
server-profile cv-pathfinder-pathfinder-INET-1
ip address 10.9.9.9/31
!
end
Original file line number Diff line number Diff line change
Expand Up @@ -20,7 +20,20 @@ hostname cv-pathfinder-pathfinder
router path-selection
peer dynamic source stun
!
path-group INET id 101
ipsec profile CP-PROFILE
!
local interface Ethernet1
!
local interface Ethernet3
!
path-group MPLS id 100
!
local interface Ethernet2
!
load-balance policy LBPOLICY
path-group INET
path-group MPLS
!
router adaptive-virtual-topology
topology role pathfinder
Expand Down Expand Up @@ -69,6 +82,24 @@ interface Dps1
flow tracker hardware WAN-FLOW-TRACKER
tcp mss ceiling ipv4 1000
!
interface Ethernet1
no shutdown
no switchport
flow tracker hardware WAN-FLOW-TRACKER
ip address 10.7.7.7/31
!
interface Ethernet2
no shutdown
no switchport
flow tracker hardware WAN-FLOW-TRACKER
ip address 172.16.0.1/31
!
interface Ethernet3
no shutdown
no switchport
flow tracker hardware WAN-FLOW-TRACKER
ip address 10.9.9.9/31
!
interface Loopback0
description Router_ID
no shutdown
Expand All @@ -83,6 +114,8 @@ interface Vxlan1
ip routing
no ip routing vrf MGMT
!
ip route 0.0.0.0/0 10.7.7.6
!
router bfd
multihop interval 300 min-rx 300 multiplier 3
!
Expand Down Expand Up @@ -132,5 +165,8 @@ management api http-commands
!
stun
server
local-interface Ethernet1
local-interface Ethernet2
local-interface Ethernet3
!
end
Original file line number Diff line number Diff line change
Expand Up @@ -20,7 +20,21 @@ hostname cv-pathfinder-pathfinder1
router path-selection
peer dynamic source stun
!
path-group INET id 101
ipsec profile CP-PROFILE
!
local interface Ethernet1
!
peer static router-ip 6.6.6.6
name cv-pathfinder-pathfinder3
ipv4 address 10.50.50.50
!
peer static router-ip 192.168.44.3
name cv-pathfinder-pathfinder2
ipv4 address 10.9.9.9
!
load-balance policy LBPOLICY
path-group INET
!
router adaptive-virtual-topology
topology role pathfinder
Expand Down Expand Up @@ -69,6 +83,12 @@ interface Dps1
flow tracker hardware WAN-FLOW-TRACKER
tcp mss ceiling ipv4 1000
!
interface Ethernet1
no shutdown
no switchport
flow tracker hardware WAN-FLOW-TRACKER
ip address 10.8.8.8/31
!
interface Loopback0
description Router_ID
no shutdown
Expand Down Expand Up @@ -147,5 +167,6 @@ management api http-commands
!
stun
server
local-interface Ethernet1
!
end
Loading
Loading