Skip to content

Commit

Permalink
rename pkg since rpi was not allowed on PyPI
Browse files Browse the repository at this point in the history
  • Loading branch information
wim glenn committed Apr 28, 2024
1 parent 922dd21 commit c3bc360
Show file tree
Hide file tree
Showing 3 changed files with 6 additions and 6 deletions.
2 changes: 1 addition & 1 deletion .github/workflows/main.yml
Original file line number Diff line number Diff line change
Expand Up @@ -24,7 +24,7 @@ jobs:
with:
python-version: "${{ matrix.python-version }}"
- name: "Install"
run: "pip install --editable . pytest pytest-cov"
run: "pip install --editable . pytest pytest-cov covdefaults"
- name: "Run tests for ${{ matrix.python-version }} on ${{ matrix.os }}"
run: pytest --cov=reorder_python_imports
- name: Upload coverage to Codecov
Expand Down
6 changes: 3 additions & 3 deletions README.md
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
rpi
===
reorder-python-imports-black
============================

Fork of [reorder-python-imports](https://github.com/asottile/reorder-python-imports) for interoperability with [black](https://github.com/psf/black).

```
pip install rpi
pip install reorder-python-imports-black
```

Black wants a newline between the module docstring and the imports, upstream `reorder-python-imports` does not.
Expand Down
4 changes: 2 additions & 2 deletions pyproject.toml
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ requires = [
build-backend = "setuptools.build_meta"

[project]
name = "rpi"
name = "reorder-python-imports-black"
version = "3.12.0"
description = "Tool for reordering python imports"
authors = [
Expand All @@ -29,7 +29,7 @@ text = "MIT"

[project.urls]
Upstream = "https://github.com/asottile/reorder-python-imports"
Homepage = "https://github.com/wimglenn/rpi"
Homepage = "https://github.com/wimglenn/reorder-python-imports-black"

[project.scripts]
reorder-python-imports = "reorder_python_imports:main"
Expand Down

0 comments on commit c3bc360

Please sign in to comment.