add tx cases for convert subnet tx #5380
Annotations
5 errors and 8 warnings
golangci-lint:
cmd/blockchaincmd/add_validator.go#L1
: # github.com/ava-labs/avalanche-cli/cmd/blockchaincmd [github.com/ava-labs/avalanche-cli/cmd/blockchaincmd.test]
|
golangci-lint:
cmd/blockchaincmd/stats_test.go#L63
cannot use iClient (variable of type *mocks.InfoClient) as info.Client value in argument to buildCurrentValidatorStats: *mocks.InfoClient does not implement info.Client (wrong type for method Uptime)
|
golangci-lint:
pkg/subnet/public.go#L130
commentFormatting: put a space between `//` and comment text (gocritic)
|
golangci-lint:
pkg/subnet/public.go#L151
commentFormatting: put a space between `//` and comment text (gocritic)
|
golangci-lint
issues found
|
The following actions use a deprecated Node.js version and will be forced to run on node20: actions/setup-go@v3, actions/checkout@v3, golangci/golangci-lint-action@v3. For more info: https://github.blog/changelog/2024-03-07-github-actions-all-actions-will-run-on-node20-instead-of-node16-by-default/
|
golangci-lint:
pkg/subnet/public.go#L126
unused-receiver: method receiver 'd' is not referenced in method's body, consider removing or renaming it as _ (revive)
|
golangci-lint:
pkg/subnet/public.go#L144
unused-receiver: method receiver 'd' is not referenced in method's body, consider removing or renaming it as _ (revive)
|
golangci-lint:
pkg/subnet/public.go#L127
unused-parameter: parameter 'message' seems to be unused, consider removing or renaming it as _ (revive)
|
golangci-lint:
pkg/subnet/public.go#L145
unused-parameter: parameter 'balance' seems to be unused, consider removing or renaming it as _ (revive)
|
golangci-lint:
pkg/subnet/public.go#L146
unused-parameter: parameter 'signer' seems to be unused, consider removing or renaming it as _ (revive)
|
golangci-lint:
pkg/subnet/public.go#L147
unused-parameter: parameter 'changeOwner' seems to be unused, consider removing or renaming it as _ (revive)
|
golangci-lint:
pkg/subnet/public.go#L148
unused-parameter: parameter 'message' seems to be unused, consider removing or renaming it as _ (revive)
|
Loading