Skip to content

Commit

Permalink
amazon-s3-gst-plugin: upgrade
Browse files Browse the repository at this point in the history
  • Loading branch information
thomas-roos committed Jul 17, 2023
1 parent 956e1ab commit 2b834db
Show file tree
Hide file tree
Showing 2 changed files with 14 additions and 13 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@ SRC_URI = "\
file://fix-linking-of-aws-crt-cpp.patch \
file://run-ptest \
"
SRCREV = "b8ecca63791e6a4f9559b47d32132144d2d191ab"
SRCREV = "e9a3609d4402709e0fb855717ac7fa2df2ef2802"

# this project do not use version tags, use latest commit
UPSTREAM_CHECK_COMMITS = "1"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -2,24 +2,16 @@ Index: git/meson.build
===================================================================
--- git.orig/meson.build
+++ git/meson.build
@@ -17,6 +17,9 @@ gst_base_dep = dependency('gstreamer-bas
@@ -19,6 +19,9 @@ gst_base_dep = dependency('gstreamer-bas
fallback : ['gstreamer', 'gst_base_dep'])
gst_check_dep = dependency('gstreamer-check-1.0', version : gst_req,
fallback : ['gstreamer', 'gst_check_dep'])
+cpp = meson.get_compiler('cpp')
+aws_c_common_dep = cpp.find_library('aws-c-common', required: true)
+aws_crt_cpp_dep=cpp.find_library('aws-crt-cpp', required:true)
aws_cpp_sdk_s3_dep = dependency('aws-cpp-sdk-s3', version : aws_cpp_sdk_req)
aws_cpp_sdk_sts_dep = dependency('aws-cpp-sdk-sts', version : aws_cpp_sdk_req)

@@ -32,4 +35,5 @@ configure_file(output : 'config.h', conf

subdir('src')
subdir('tests')
-subdir('pkgconfig')
\ No newline at end of file
+subdir('pkgconfig')
+
# use static linker args on macos as the dylibs don't include the crt symbols
aws_cpp_sdk_s3_dep = dependency('aws-cpp-sdk-s3', version : aws_cpp_sdk_req, static : is_macos)
aws_cpp_sdk_sts_dep = dependency('aws-cpp-sdk-sts', version : aws_cpp_sdk_req, static : is_macos)
Index: git/src/meson.build
===================================================================
--- git.orig/src/meson.build
Expand All @@ -42,3 +34,12 @@ Index: git/src/meson.build
include_directories : [configinc],
install : true,
install_dir : plugins_install_dir,
@@ -45,7 +45,7 @@ gst_s3_elements = library('gsts3elements

s3elements_dep = declare_dependency(link_with : gst_s3_elements,
include_directories : [include_directories('.')],
- dependencies : [gst_dep, gst_base_dep, aws_cpp_sdk_s3_dep, aws_cpp_sdk_sts_dep]
+ dependencies : [gst_dep, gst_base_dep, aws_cpp_sdk_s3_dep, aws_cpp_sdk_sts_dep, aws_c_common_dep, aws_crt_cpp_dep]
)

install_headers(gst_s3_public_headers, subdir : 'gstreamer-1.0/gst/aws')

0 comments on commit 2b834db

Please sign in to comment.