-
Notifications
You must be signed in to change notification settings - Fork 85
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
amazon-kvs-producer-sdk-cpp: fix globalThreadSleep link error
awslabs/amazon-kinesis-video-streams-producer-sdk-cpp#1197 set default PACKAGECONFIG to build gstreamer
- Loading branch information
1 parent
e1b1a08
commit 9f290af
Showing
2 changed files
with
17 additions
and
3 deletions.
There are no files selected for viewing
15 changes: 15 additions & 0 deletions
15
...k/amazon-kvs-producer-sdk/amazon-kvs-producer-sdk-cpp/global-thread-sleep-linkerror.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
Upstream-Status: Submitted [https://github.com/awslabs/amazon-kinesis-video-streams-producer-sdk-cpp/issues/1197] | ||
|
||
Index: git/CMakeLists.txt | ||
=================================================================== | ||
--- git.orig/CMakeLists.txt | ||
+++ git/CMakeLists.txt | ||
@@ -221,7 +221,7 @@ if(BUILD_GSTREAMER_PLUGIN) | ||
target_link_libraries(gstkvssink PRIVATE ${GST_APP_LIBRARIES} KinesisVideoProducer) | ||
|
||
add_executable(kvssink_gstreamer_sample samples/kvssink_gstreamer_sample.cpp) | ||
- target_link_libraries(kvssink_gstreamer_sample ${GST_APP_LIBRARIES} KinesisVideoProducer) | ||
+ target_link_libraries(kvssink_gstreamer_sample ${GST_APP_LIBRARIES} KinesisVideoProducer kvspic) | ||
|
||
add_executable(kvs_gstreamer_sample samples/kvs_gstreamer_sample.cpp) | ||
target_link_libraries(kvs_gstreamer_sample ${GST_APP_LIBRARIES} KinesisVideoProducer kvspic) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters