Skip to content

Commit

Permalink
amazon-kvs-producer-pic, amazon-kvs-producer-sdk-c, amazon-kvs-produc…
Browse files Browse the repository at this point in the history
…er-sdk-c: upgrade

amazon-kvs-producer-sdk-c: 1.5.0 -> 1.5.2
amazon-kvs-producer-pic: git -> 1.1.0
  • Loading branch information
thomas-roos committed Jul 25, 2024
1 parent b288fb9 commit e668955
Show file tree
Hide file tree
Showing 4 changed files with 18 additions and 16 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -17,8 +17,8 @@ UPSTREAM_VERSION_UNKNOWN = "1"
# set to match only git_invalid_tag_regex because UPSTREAM_VERSION_UNKNOWN seems to be broken for git
UPSTREAM_CHECK_GITTAGREGEX = "git_invalid_tag_regex"
# this SRCREV commit id should not different than this:
# https://github.com/awslabs/amazon-kinesis-video-streams-producer-c/blob/80c74ac9200b58427a8fcb7782a03b1774020983/CMake/Dependencies/libkvspic-CMakeLists.txt#L10
SRCREV = "d08be2e16303507d21b4cb376aecda98271687ad"
# https://github.com/awslabs/amazon-kinesis-video-streams-producer-c/blob/master/CMake/Dependencies/libkvspic-CMakeLists.txt
SRCREV = "65e38dac9b30523d43a57bc009d679e627b58d9a"

S = "${WORKDIR}/git"

Expand All @@ -35,6 +35,9 @@ PACKAGECONFIG[with-tests] = "-DBUILD_TEST=ON,-DBUILD_TEST=OFF,gtest"

CFLAGS:append = " -Wl,-Bsymbolic"

# fix error: implicit declaration of function pthread_getname_np
CFLAGS:append = " -D_GNU_SOURCE"

EXTRA_OECMAKE += "\
-DBUILD_DEPENDENCIES=OFF \
-DCODE_COVERAGE=OFF \
Expand All @@ -46,7 +49,6 @@ EXTRA_OECMAKE += "\
-DCOMPILER_WARNINGS=ON \
-DALIGNED_MEMORY_MODEL=OFF \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=$D/usr \
"

FILES:${PN} += "\
Expand All @@ -67,7 +69,7 @@ RDEPENDS:${PN}-ptest += "\
do_install_ptest () {
install -d ${D}${PTEST_PATH}/tests
install -m 0755 ${WORKDIR}/ptest_result.py ${D}${PTEST_PATH}/
cp -r ${B}/kvspic_test ${D}${PTEST_PATH}/tests/
cp -r ${B}/tst/kvspic_test ${D}${PTEST_PATH}/tests/
}

BBCLASSEXTEND = "native nativesdk"
BBCLASSEXTEND = "native nativesdk"
Original file line number Diff line number Diff line change
Expand Up @@ -23,13 +23,11 @@ SRC_URI = "\
UPSTREAM_VERSION_UNKNOWN = "1"
# set to match only git_invalid_tag_regex because UPSTREAM_VERSION_UNKNOWN seems to be broken for git
UPSTREAM_CHECK_GITTAGREGEX = "git_invalid_tag_regex"
# this SRCREV commit id should not different to this specified here:
# https://github.com/awslabs/amazon-kinesis-video-streams-producer-sdk-cpp/blob/70f74f14cf27b09f71dc1889f36eb6e04cdd90a8/CMake/Dependencies/libkvscproducer-CMakeLists.txt#L10
SRCREV = "7d1b76f53680c1e23afb6f35f0cca97ccdb35e3f"
SRCREV = "3e519b7670e39031375d227f983ad2cde888078e"

S = "${WORKDIR}/git"

inherit cmake pkgconfig
inherit cmake pkgconfig

# ptest are disabled, cause running tests require a certificate

Expand All @@ -43,11 +41,15 @@ PACKAGECONFIG[static] = "-DBUILD_SHARED_LIBS=OFF,-DBUILD_SHARED_LIBS=ON -DBUILD_
PACKAGECONFIG[with-tests] = "-DBUILD_TEST=ON,-DBUILD_TEST=OFF,gtest"

FILES:${PN} += "\
${libdir}/libcproducer.so \
${libdir}/pkgconfig/*.pc \
"

FILES:${PN}-dev += "${includedir}/com/amazonaws/kinesis/video/*"
FILES:${PN}-dev += "\
${includedir}/com/amazonaws/kinesis/video/* \
${libdir}/libkvsCommonLws.so \
${libdir}/libkvsCommonCurl.so \
${libdir}/libcproducer.so \
"

RDEPENDS:${PN} = ""
CFLAGS:append = " -Wl,-Bsymbolic"
Expand All @@ -64,7 +66,6 @@ EXTRA_OECMAKE += "\
-DDEBUG_HEAP=OFF \
-DALIGNED_MEMORY_MODEL=OFF \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=$D/usr \
"

# Notify that libraries are not versioned
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@ From: rpcme <[email protected]>
Date: Sun, 16 Jan 2022 06:00:06 -0500
Subject: [PATCH] add support for amazon kvs producer sdk cpp

Upstream-Status: Unknown
Upstream-Status: Submitted [author]

---
CMakeLists.txt | 3 +++
Expand All @@ -24,9 +24,9 @@ index ec001a7..470e069 100644
@@ -101,6 +102,8 @@ endif()
fetch_repo(kvscproducer)
add_subdirectory(${DEPENDENCY_DOWNLOAD_PATH}/libkvscproducer/kvscproducer-src EXCLUDE_FROM_ALL)

+endif()
+
############# find dependent libraries ############

find_package(Threads)
Original file line number Diff line number Diff line change
Expand Up @@ -60,7 +60,6 @@ EXTRA_OECMAKE += "\
-DBUILD_TEST=OFF \
-DBUILD_SHARED_LIBS=ON \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=$D/usr \
"

do_install() {
Expand Down

0 comments on commit e668955

Please sign in to comment.