Skip to content

Commit

Permalink
amazon-kvs-producer-sdk-cpp: fix globalThreadSleep link error
Browse files Browse the repository at this point in the history
awslabs/amazon-kinesis-video-streams-producer-sdk-cpp#1197

set default PACKAGECONFIG to build gstreamer
  • Loading branch information
thomas-roos committed Jul 26, 2024
1 parent e1b1a08 commit fe39a4c
Show file tree
Hide file tree
Showing 2 changed files with 17 additions and 3 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
Upstream-Status: Submitted [https://github.com/awslabs/amazon-kinesis-video-streams-producer-sdk-cpp/issues/1197]

Index: git/CMakeLists.txt
===================================================================
--- git.orig/CMakeLists.txt
+++ git/CMakeLists.txt
@@ -221,7 +221,7 @@ if(BUILD_GSTREAMER_PLUGIN)
target_link_libraries(gstkvssink PRIVATE ${GST_APP_LIBRARIES} KinesisVideoProducer)

add_executable(kvssink_gstreamer_sample samples/kvssink_gstreamer_sample.cpp)
- target_link_libraries(kvssink_gstreamer_sample ${GST_APP_LIBRARIES} KinesisVideoProducer)
+ target_link_libraries(kvssink_gstreamer_sample ${GST_APP_LIBRARIES} KinesisVideoProducer kvspic)

add_executable(kvs_gstreamer_sample samples/kvs_gstreamer_sample.cpp)
target_link_libraries(kvs_gstreamer_sample ${GST_APP_LIBRARIES} KinesisVideoProducer kvspic)
Original file line number Diff line number Diff line change
Expand Up @@ -16,6 +16,7 @@ BRANCH ?= "master"
# nooelint: oelint.file.patchsignedoff
SRC_URI = "git://github.com/awslabs/amazon-kinesis-video-streams-producer-sdk-cpp.git;protocol=https;branch=${BRANCH} \
file://amazon-kvs-producer-sdk-cpp-deps.patch \
file://global-thread-sleep-linkerror.patch \
"

SRCREV = "8e59b313950d4dbb1ecfb88e2108df87e3331c4e"
Expand All @@ -24,9 +25,7 @@ S = "${WORKDIR}/git"

inherit cmake pkgconfig

PACKAGECONFIG ??= "\
${@bb.utils.contains('PTEST_ENABLED', '1', 'gstreamer', '', d)} \
"
PACKAGECONFIG ??= "gstreamer"

PACKAGECONFIG[gstreamer] = "-DBUILD_GSTREAMER_PLUGIN=ON,-DBUILD_GSTREAMER_PLUGIN=OFF,curl log4cplus openssl gstreamer1.0 gstreamer1.0-plugins-base"

Expand Down

0 comments on commit fe39a4c

Please sign in to comment.