Skip to content

Commit

Permalink
Bullseye support
Browse files Browse the repository at this point in the history
This upgrades the required packages to work on bullseye.

Notable changes:

* Upgraded electrs doesn't need patches anymore, uses system rocksdb
* Thunderhub uses system libvips instead of vendored
* All Rust software rebuilt because of library differences
* All nodejs software reqbuilt because of library differences

Note: upgrade is tested manually.
  • Loading branch information
Kixunil committed Jul 8, 2023
1 parent 56b3b63 commit 9441cbf
Show file tree
Hide file tree
Showing 20 changed files with 52 additions and 190 deletions.
4 changes: 2 additions & 2 deletions .github/workflows/ci.yml
Original file line number Diff line number Diff line change
Expand Up @@ -3,9 +3,9 @@ name: CADR CI
on:
workflow_dispatch:
push:
branches: [ master ]
branches: [ master, bullseye ]
pull_request:
branches: [ master ]
branches: [ master, bullseye ]

env:
USER_NAME: user
Expand Down
4 changes: 2 additions & 2 deletions Dockerfile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
FROM debian:buster
FROM debian:bullseye

LABEL repository="https://github.com/debian-cryptoanarchy/cryptoanarchy-deb-repo-builder"

Expand All @@ -10,7 +10,7 @@ COPY tests/data/microsoft_key.gpg /tmp/
COPY tests/data/microsoft_apt.list /tmp/

RUN apt-get update && apt-get dist-upgrade && \
apt-get install apt-utils && \
apt-get install apt-utils ca-certificates && \
apt-get install wget cargo npm git apt-transport-https \
ruby-mustache dirmngr sudo libvips-dev ca-certificates gpg \
systemd systemd-sysv net-tools netcat xxd && \
Expand Down
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -29,7 +29,7 @@ endif

.DELETE_ON_ERROR:

SOURCES=bitcoin bitcoin-rpc-proxy electrs electrum lnd nbxplorer btcpayserver ridetheln selfhost tor-extras thunderhub btc-rpc-explorer lndconnect lnpbp-testkit selfhost-dashboard remir bitcoin-whitepaper btc-transmuter
SOURCES=bitcoin bitcoin-rpc-proxy electrs electrum lnd nbxplorer btcpayserver ridetheln selfhost tor-extras thunderhub btc-rpc-explorer lndconnect lnpbp-testkit selfhost-dashboard bitcoin-whitepaper btc-transmuter

include common_vars.mk

Expand Down
17 changes: 2 additions & 15 deletions build_rules/electrs.yaml
Original file line number Diff line number Diff line change
Expand Up @@ -7,18 +7,5 @@ git_tag: v$(ELECTRS_VERSION)
fingerprint: 15C8C3574AE4F1E25F3F35C587CAE5FA46917CBB
verify_tag: true
build_system: cargo
#cargo_env: ROCKSDB_INCLUDE_DIR=/usr/include ROCKSDB_LIB_DIR=/usr/lib SNAPPY_LIB_DIR=/usr/lib LZ4_LIB_DIR=/usr/lib ZSTD_LIB_DIR=/usr/lib Z_LIB_DIR=/usr/lib BZ2_LIB_DIR=/usr/lib
#cargo_args: --no-default-features

copy_assets:
- from: electrs/patches/series
to: debian/patches/series
- from: electrs/patches/update-bitcoin-lib.diff
to: debian/patches/update-bitcoin-lib.diff
- from: electrs/patches/update-rocksdb.diff
to: debian/patches/update-rocksdb.diff
- from: electrs/patches/msrv.diff
to: debian/patches/msrv.diff

dirs:
- dir: debian/patches
cargo_env: ROCKSDB_INCLUDE_DIR=/usr/include ROCKSDB_LIB_DIR=/usr/lib
cargo_args: --no-default-features --features=metrics,metrics_process
18 changes: 0 additions & 18 deletions electrs/patches/msrv.diff

This file was deleted.

3 changes: 0 additions & 3 deletions electrs/patches/series

This file was deleted.

98 changes: 0 additions & 98 deletions electrs/patches/update-bitcoin-lib.diff

This file was deleted.

47 changes: 0 additions & 47 deletions electrs/patches/update-rocksdb.diff

This file was deleted.

6 changes: 6 additions & 0 deletions pkg_specs/btc-rpc-explorer.changelog
Original file line number Diff line number Diff line change
@@ -1,3 +1,9 @@
btc-rpc-explorer (3.1.1-2) bullseye; urgency=medium

* Bullseye build

-- Martin Habovstiak <[email protected]> Sat, 1 Oct 2022 13:51:05 +0100

btc-rpc-explorer (3.1.1-1) buster; urgency=medium

* Updated upstream version
Expand Down
6 changes: 6 additions & 0 deletions pkg_specs/btc-rpc-proxy.changelog
Original file line number Diff line number Diff line change
@@ -1,3 +1,9 @@
btc-rpc-proxy (0.3.0-6) bullseye; urgency=medium

* Bullseye build

-- Martin Habovstiak <[email protected]> Sat, 15 Oct 2022 18:43:07 +0100

btc-rpc-proxy (0.3.0-5) buster; urgency=medium

* Added getzmqnotifications to allowed public calls
Expand Down
6 changes: 6 additions & 0 deletions pkg_specs/electrs.changelog
Original file line number Diff line number Diff line change
@@ -1,3 +1,9 @@
electrs (0.9.9-1) bullseye; urgency=medium

* Updated and adapted upstream version

-- Martin Habovstiak <[email protected]> Tue, 23 Aug 2022 18:52:42 +0100

electrs (0.9.3-2) buster; urgency=high

* Fix setting log filters
Expand Down
2 changes: 1 addition & 1 deletion pkg_specs/electrs.sss
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
name = "electrs"
section = "net"
variants = ["mainnet", "regtest"]
build_depends = ["cargo:native (>= 0.34.0)", "cmake (>= 3.13.4)", "clang:native (>= 1:7.0)", "llvm-dev:native", "gcc-arm-linux-gnueabihf [armhf]", "gcc-aarch64-linux-gnu [arm64]", "librocksdb-dev", "libc6-dev", "libstdc++-8-dev"]
build_depends = ["cargo:native (>= 0.34.0)", "cmake (>= 3.13.4)", "clang:native (>= 1:7.0)", "llvm-dev:native", "gcc-arm-linux-gnueabihf [armhf]", "gcc-aarch64-linux-gnu [arm64]", "librocksdb-dev", "libc6-dev", "libstdc++-10-dev"]
packages = ["electrs", "electrs-@variant", "electrs-both"]
4 changes: 4 additions & 0 deletions pkg_specs/[email protected]
Original file line number Diff line number Diff line change
Expand Up @@ -40,3 +40,7 @@ constant = "LND"
type = "string"
template = "https://127.0.0.1:{lnd-system-@variant/rest_port}"
structure = ["Settings", "lnServerUrl"]

run_as_user = "root"
register_cmd = ["bash", "-c", "echo -e '[Unit]\nAfter=lnd-system-{variant}\nRequires=lnd-system-{variant}' > /etc/systemd/system/ridetheln-system.d/bridge-lnd-system-{variant}.conf"]
unregister_cmd = ["rm", "-f", "/etc/systemd/system/ridetheln-system.d/bridge-lnd-system-{variant}.conf"]
1 change: 1 addition & 0 deletions pkg_specs/ridetheln-system.sps
Original file line number Diff line number Diff line change
Expand Up @@ -14,6 +14,7 @@ add_links = [
]
extra_service_config = """
Restart=always
TimeoutStartSec=300
Environment=RTL_CONFIG_PATH=/var/lib/ridetheln-system
"""

Expand Down
6 changes: 6 additions & 0 deletions pkg_specs/ridetheln.changelog
Original file line number Diff line number Diff line change
@@ -1,3 +1,9 @@
ridetheln (0.10.1-4) bullseye; urgency=medium

* Bullseye build

-- Martin Habovstiak <[email protected]> Sat, 1 Oct 2022 13:51:05 +0100

ridetheln (0.10.1-3) buster; urgency=medium

* Improved sandboxing of service
Expand Down
6 changes: 6 additions & 0 deletions pkg_specs/selfhost-dashboard.changelog
Original file line number Diff line number Diff line change
@@ -1,3 +1,9 @@
selfhost-dashboard (0.2.1-2) bullseye; urgency=medium

* Bullseye build

-- Martin Habovstiak <[email protected]> Sat, 1 Oct 2022 13:51:05 +0100

selfhost-dashboard (0.2.1-1) buster; urgency=medium

* Updated upstream version
Expand Down
6 changes: 6 additions & 0 deletions pkg_specs/thunderhub.changelog
Original file line number Diff line number Diff line change
@@ -1,3 +1,9 @@
thunderhub (0.11.2-3) bullseye; urgency=critical

* Bullseye build

-- Martin Habovstiak <[email protected]> Sat, 1 Oct 2022 13:51:05 +0100

thunderhub (0.11.2-2) buster; urgency=critical

* Improved sandboxing of service
Expand Down
2 changes: 1 addition & 1 deletion tests/data/beta_apt.list
Original file line number Diff line number Diff line change
@@ -1 +1 @@
deb https://deb.ln-ask.me/beta buster common local desktop
deb https://deb.ln-ask.me/beta bullseye common local desktop
2 changes: 1 addition & 1 deletion tests/data/experimental_apt.list
Original file line number Diff line number Diff line change
@@ -1 +1 @@
deb https://deb.ln-ask.me/experimental buster common local desktop
deb https://deb.ln-ask.me/experimental bullseye common local desktop
2 changes: 1 addition & 1 deletion tests/data/microsoft_apt.list
Original file line number Diff line number Diff line change
@@ -1 +1 @@
deb [arch=amd64,arm64,armhf] https://packages.microsoft.com/debian/10/prod buster main
deb [arch=amd64,arm64,armhf] https://packages.microsoft.com/debian/11/prod bullseye main

0 comments on commit 9441cbf

Please sign in to comment.