Skip to content

Commit

Permalink
Added blackboard related files
Browse files Browse the repository at this point in the history
  • Loading branch information
shdrmr committed Apr 28, 2020
1 parent cb0d3c3 commit 4e565df
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 4 deletions.
33 changes: 33 additions & 0 deletions recipes-core/elkpi-blackboard/elkpi-blackboard_git.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
SUMMARY = "Install Elk BlackBoard related files in the system"
HOMEPAGE = "https://github.com/elk-audio/elk-examples"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-3.0;md5=c79ff39f19dfec6d293b95dea7b07891"

SRC_URI = "git://github.com/elk-audio/elk-examples;protocol=https;nobranch=1"

SRCREV = "85271f84e0dcbb984ee7b73e6e103d16568366a4"

S = "${WORKDIR}/git/blackboard/common-files"

SENSEI_CONFIG_DIR = "${datadir}/sensei"
FONTS_DIR = "${datadir}/fonts/ttf"
ELK_UI_DIR = "${libdir}/python3.7/site-packages/elk_ui"

do_install() {
install -d ${D}${SENSEI_CONFIG_DIR}
install -d ${D}${FONTS_DIR}
install -d ${D}${ELK_UI_DIR}

install -m 0644 sensei_config.json ${D}${SENSEI_CONFIG_DIR}/blackboard.json
install -m 0644 LiberationMono-Regular.ttf ${D}${FONTS_DIR}/
install -m 0644 elk_ui.py ${D}${ELK_UI_DIR}/
}

FILES_${PN} += "\
${SENSEI_CONFIG_DIR} \
${SENSEI_CONFIG_DIR}/* \
${FONTS_DIR} \
${FONTS_DIR}/* \
${ELK_UI_DIR} \
${ELK_UI_DIR}/* \
"
12 changes: 8 additions & 4 deletions recipes-core/elkpi-systemd-services/files/sensei.service
Original file line number Diff line number Diff line change
@@ -1,14 +1,18 @@
[Unit]
Description=sensei starting service
After=sushi.service
ConditionPathExists=/dev/rtdm/audio_rtdm
After=load-drivers.service
ConditionPathExists=/dev/rtdm/shiftreg_rtdm

[Service]
Type=simple
RemainAfterExit=yes
WorkingDirectory=/udata/
ExecStart=/usr/bin/sensei -f # need to specify config file here
Environment=LD_LIBRARY_PATH=/usr/xenomai/lib

# You can use your custom sensei config file by editing the following line
ExecStart=/usr/bin/sensei -f /usr/share/sensei/blackboard.json

User=mind

[Install]
WantedBy=multi-user.target
WantedBy=multi-user.target

0 comments on commit 4e565df

Please sign in to comment.