Skip to content

Commit

Permalink
sci-libs/proj: add patch to install geotiff files
Browse files Browse the repository at this point in the history
This patch is a backport of an upstream patch that will be
applied in version 9.4.0 scheduled for March 01, 2024.

Upstream: OSGeo/PROJ#3970
Closes: https://bugs.gentoo.org/917393
Signed-off-by: Marco Genasci <[email protected]>
  • Loading branch information
fedeliallalinea committed Dec 12, 2023
1 parent 1447417 commit 04e5bec
Show file tree
Hide file tree
Showing 3 changed files with 41 additions and 0 deletions.
33 changes: 33 additions & 0 deletions sci-libs/proj/files/proj-geotiff.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
https://bugs.gentoo.org/917393
https://github.com/OSGeo/PROJ/pull/3970

From afccfb609db16524b602216d9dc2b55c154403bb Mon Sep 17 00:00:00 2001
From: Marco Genasci <[email protected]>
Date: Sun, 26 Nov 2023 08:40:45 +0100
Subject: [PATCH] Database: added ability to install *.tif if present in data

---
data/CMakeLists.txt | 3 +++
1 file changed, 3 insertions(+)

diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index 4cb89e7849..85ed6ba8d4 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -38,6 +38,8 @@ set(GRIDSHIFT_FILES ${GSB_FILES} ${GTX_FILES})

file(GLOB SCHEMA_FILES *.json)

+file(GLOB GEOTIFF_FILES *.tif)
+
set(ALL_SQL_IN "${CMAKE_CURRENT_BINARY_DIR}/all.sql.in")
set(PROJ_DB "${CMAKE_CURRENT_BINARY_DIR}/proj.db")
include(sql_filelist.cmake)
@@ -107,6 +109,7 @@ set(ALL_DATA_FILE
${GRIDSHIFT_FILES}
${PROJ_DB}
${SCHEMA_FILES}
+ ${GEOTIFF_FILES}
)
install(
FILES ${ALL_DATA_FILE}
Original file line number Diff line number Diff line change
Expand Up @@ -31,6 +31,10 @@ DEPEND="
test? ( dev-cpp/gtest )
"

PATCHES=(
"${FILESDIR}"/${PN}-geotiff.patch
)

src_unpack() {
unpack ${P}.tar.gz

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -31,6 +31,10 @@ DEPEND="
test? ( dev-cpp/gtest )
"

PATCHES=(
"${FILESDIR}"/${PN}-geotiff.patch
)

src_unpack() {
unpack ${P}.tar.gz

Expand Down

0 comments on commit 04e5bec

Please sign in to comment.