Skip to content

Commit

Permalink
initial commit
Browse files Browse the repository at this point in the history
  • Loading branch information
greyltc committed Mar 22, 2015
1 parent 4fe8292 commit a382711
Show file tree
Hide file tree
Showing 28 changed files with 724 additions and 0 deletions.
19 changes: 19 additions & 0 deletions android-google-play-services/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
pkgname=android-google-play-services
pkgver=r23
_build=7095000
pkgrel=3
pkgdesc='Google Play Services client library and sample code'
arch=('any')
url="https://developers.google.com/android/google-play-services/"
license=('custom')
options=('!strip')
source=("http://dl.google.com/android/repository/google_play_services_${_build}_${pkgver}.zip" "source.properties")
sha1sums=('987520c73e66d58fe3811f542366369ddd79e733'
'764a1d373c96c226782b4023da85c3734481f38f')

package() {
mkdir -p "${pkgdir}/opt/android-sdk/extras/google/"
cp -dpr --no-preserve=ownership "${srcdir}/google-play-services" "${pkgdir}/opt/android-sdk/extras/google/google_play_services"
chmod -R ugo+rX "${pkgdir}/opt"
install -Dm644 "${srcdir}/source.properties" "${pkgdir}/opt/android-sdk/extras/google/google_play_services/source.properties"
}
12 changes: 12 additions & 0 deletions android-google-play-services/source.properties

Large diffs are not rendered by default.

29 changes: 29 additions & 0 deletions cufflinks/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
# Maintainer: Thiago Yukio Kikuchi Oliveira <[email protected]>

pkgname=cufflinks
pkgver=2.2.1
pkgrel=1
pkgdesc="Cufflinks assembles transcripts, estimates their abundances, and tests for differential expression and regulation in RNA-Seq samples.."
arch=("x86_64")
url="http://cufflinks.cbcb.umd.edu"
license=('Artistic')
depends=('boost' 'eigen3' 'python2' 'samtools' 'perl')
source=(http://cufflinks.cbcb.umd.edu/downloads/$pkgname-$pkgver.tar.gz)
md5sums=('9a5ba7a7710cd864932cf205c17851f0')

build() {
cd $srcdir/$pkgname-$pkgver
# cufflinks use python2 but archlinux uses python3 as default python
perl -i -pne '$_ =~ s/python/python2/ if $_ =~ /^#!\/usr/' src/cuffmerge

export EIGEN_CPPFLAGS="-I/usr/include/eigen3"
export LDFLAGS="-L/usr/lib -lboost_system"
./configure --prefix=/usr
make

}

package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
}
35 changes: 35 additions & 0 deletions python2-macs2/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# $Id$
# Maintainer: Grey Christoforo <grey at christoforo dot net>

pkgbase=python2-macs2
pkgname=('python2-macs2')
_pkgname=MACS2
pkgver=2.1.0.20140616
pkgrel=1
pkgdesc="MACS -- Model-based Analysis of ChIP-Seq"
arch=('i686' 'x86_64')
url="https://github.com/taoliu/MACS/"
license=('Artistic')
depends=('python2-numpy')
source=(https://pypi.python.org/packages/source/M/${_pkgname}/${_pkgname}-${pkgver}.tar.gz)
md5sums=('ad105b9ad25bc2eedc78c38d54cf76e8')

prepare() {
cp -r "${_pkgname}-${pkgver}" "${_pkgname}-${pkgver}-py2"
# change python to python2
find "${_pkgname}-${pkgver}-py2" -name '*.py' -type f -exec \
sed -i 's|env python|env python2|' {} \;
}

build() {
cd "${srcdir}/${_pkgname}-${pkgver}-py2"
python2 setup.py build
}

package_python2-macs2() {
depends=('python2-numpy')

cd "${srcdir}/${_pkgname}-${pkgver}-py2"
python2 setup.py install --root="${pkgdir}"
install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
32 changes: 32 additions & 0 deletions rsem/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Maintainer: Grey Christoforo <grey at christoforo dot net>

pkgname=rsem
_pkgname=RSEM
pkgver=1.2.19
pkgrel=1
pkgdesc="accurate quantification of gene and isoform expression from RNA-Seq data"
arch=('i686' 'x86_64')
url="http://deweylab.biostat.wisc.edu/rsem/"
install=${pkgname}.install
license=GNU
depends=('perl' 'r')
optdepends=('bowtie2')
source=(https://github.com/bli25wisc/${_pkgname}/archive/v${pkgver}.tar.gz)
md5sums=('69667ee47337617847dc97da2765fd08')

build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
make
}

package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
mkdir -p "${pkgdir}/usr/bin/${pkgname}"
mv `find . -maxdepth 1 -type f -perm -u+x` "${pkgdir}/usr/bin/${pkgname}/."
mv WHAT_IS_NEW "${pkgdir}/usr/bin/${pkgname}/."

mkdir -p "$pkgdir/etc/profile.d"
echo "export PATH=/usr/bin/${pkgname}:"'$PATH' > "$pkgdir/etc/profile.d/${pkgname}.sh"
}

# vim:set ts=2 sw=2 et:
7 changes: 7 additions & 0 deletions rsem/rsem.install
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
post_install() {
echo
echo "To use rsem, log out and log back in, or run"
echo "source /etc/profile"
echo "To enable it immediately"
echo
}
24 changes: 24 additions & 0 deletions ruby-daemons/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
# Generated by gem2arch (https://github.com/anatol/gem2arch)
# Maintainer: Anatol Pomozov <[email protected]>
# Contributor: eagletmt <[email protected]>

_gemname=daemons
pkgname=ruby-$_gemname
pkgver=1.1.9
pkgrel=1
pkgdesc='A toolkit to create and control daemons in different ways'
arch=(any)
url='http://daemons.rubyforge.org'
license=(MIT)
depends=(ruby)
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
sha1sums=('e73ba58fe9e948f7edc5017f91f53b8f0a955a37')

package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
26 changes: 26 additions & 0 deletions ruby-diff-lcs/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
# Generated by gem2arch (https://github.com/anatol/gem2arch)
# Maintainer: Sirat18 <[email protected]>
# Contributor: Anatol Pomozov <[email protected]>
# Contributor: Alfredo Palhares <[email protected]>
# Contributor: mtorromeo

_gemname=diff-lcs
pkgname=ruby-$_gemname
pkgver=1.2.5
pkgrel=3
pkgdesc='Diff::LCS computes the difference between two Enumerable sequences using the McIlroy-Hunt longest common subsequence (LCS) algorithm'
arch=(any)
url='https://github.com/halostatue/diff-lcs'
license=(MIT 'Perl Artistic v2' 'GNU GPL v2')
depends=(ruby)
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
sha1sums=('5f71a45f13780701f3a42297adc0269d0799e1d5')

package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/License.rdoc" "$pkgdir/usr/share/licenses/$pkgname/License.rdoc"
}
23 changes: 23 additions & 0 deletions ruby-eventmachine/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
# Generated by gem2arch (https://github.com/anatol/gem2arch)
# Maintainer:

_gemname=eventmachine
pkgname=ruby-$_gemname
pkgver=1.0.7
pkgrel=1
pkgdesc='Ruby/EventMachine library'
arch=(i686 x86_64)
url='http://rubyeventmachine.com'
license=(Ruby GPL)
depends=(ruby)
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
sha1sums=('4e6fe81a3e424e8d6f53d4774364fa0d47da27fb')

package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
23 changes: 23 additions & 0 deletions ruby-grit/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
# Generated by gem2arch (https://github.com/anatol/gem2arch)
# Maintainer: Anatol Pomozov <[email protected]>

_gemname=grit
pkgname=ruby-$_gemname
pkgver=2.5.0
pkgrel=1
pkgdesc='Ruby Git bindings.'
arch=(any)
url='http://github.com/mojombo/grit'
license=(MIT)
depends=(ruby ruby-posix-spawn ruby-mime-types-1 ruby-diff-lcs)
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
sha1sums=('0581087581cd522a697616b835b4d57f90a90ca6')

package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
28 changes: 28 additions & 0 deletions ruby-nokogiri/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Generated by gem2arch (https://github.com/anatol/gem2arch)
# Maintainer: Anatol Pomozov <[email protected]>
# Contributor: eagletmt <[email protected]>

_gemname=nokogiri
pkgname="ruby-${_gemname}"
pkgver=1.6.6.2
pkgrel=1
pkgdesc='HTML, XML, SAX, and Reader parser'
arch=('any')
url='http://nokogiri.org'
license=('MIT')
depends=('libxml2' 'libxslt' 'ruby' 'ruby-mini_portile')
options=('!emptydirs')
source=("https://rubygems.org/downloads/${_gemname}-${pkgver}.gem")
noextract=("${_gemname}-${pkgver}.gem")
sha512sums=('bb0422878e690648ab154c7d1ab0bd4fd9ec0875b2f0be0292ba9cb5541ea33b770794a7ba411e603a06472af4f9a3337ec8ff5d74debd826fc63f1d3ab1d5f1')

package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
# TODO: in the future releases of nokogiri we can use -- --use-system-libraries
# see https://github.com/sparklemotion/nokogiri/blob/master/ext/nokogiri/extconf.rb
NOKOGIRI_USE_SYSTEM_LIBRARIES=1 gem install --ignore-dependencies --no-user-install -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" "${_gemname}-${pkgver}.gem"
rm "${pkgdir}/${_gemdir}/cache/${_gemname}-${pkgver}.gem"

rm -rf "${pkgdir}/${_gemdir}/gems/${_gemname}-${pkgver}/ports"
rm -rf "${pkgdir}/${_gemdir}/gems/${_gemname}-${pkgver}/ext"
}
24 changes: 24 additions & 0 deletions ruby-rack-protection/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
# Generated by gem2arch (https://github.com/anatol/gem2arch)
# Maintainer: Anatol Pomozov <[email protected]>
# Contributor: Alexsandr Pavlov <kidoz at mail dot ru>

_gemname=rack-protection
pkgname=ruby-$_gemname
pkgver=1.5.3
pkgrel=1
pkgdesc='You should use protection!'
arch=(any)
url='https://github.com/rkh/rack-protection'
license=(MIT)
depends=(ruby ruby-rack)
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
sha1sums=('1c28529c1d7376c61faed80f3d3297905a14c2b3')

package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/License" "$pkgdir/usr/share/licenses/$pkgname/License"
}
23 changes: 23 additions & 0 deletions ruby-rack-ssl/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
# Generated by gem2arch (https://github.com/anatol/gem2arch)
# Maintainer: Anatol Pomozov <[email protected]>

_gemname=rack-ssl
pkgname=ruby-$_gemname
pkgver=1.4.1
pkgrel=1
pkgdesc='Force SSL/TLS in your app.'
arch=(any)
url='https://github.com/josh/rack-ssl'
license=(MIT)
depends=(ruby ruby-rack)
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
sha1sums=('87f2fb53c6882436b8d522288993d658dc7025ce')

package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
23 changes: 23 additions & 0 deletions ruby-sinatra/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
# Generated by gem2arch (https://github.com/anatol/gem2arch)
# Maintainer: Anatol Pomozov <[email protected]>

_gemname=sinatra
pkgname=ruby-$_gemname
pkgver=1.4.5
pkgrel=1
pkgdesc='Classy web-development dressed in a DSL'
arch=(any)
url='http://www.sinatrarb.com/'
license=(MIT)
depends=(ruby ruby-rack ruby-tilt-1 ruby-rack-protection)
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
sha1sums=('97e695f50c078ea57424dd8a48424269e6afdacb')

package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
24 changes: 24 additions & 0 deletions ruby-thin/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
# Generated by gem2arch (https://github.com/anatol/gem2arch)
# Maintainer: Anatol Pomozov <[email protected]>

_gemname=thin
pkgname=ruby-$_gemname
pkgver=1.6.3
pkgrel=1
pkgdesc='A thin and fast web server'
arch=(i686 x86_64)
url='http://code.macournoyer.com/thin/'
license=(Ruby)
depends=(ruby ruby-rack ruby-eventmachine ruby-daemons)
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
sha1sums=('ad99e77149b922c3f067b0140438c044d24115f1')

package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"

rm -rf "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/ext"
}
25 changes: 25 additions & 0 deletions ruby-tilt-1/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
# Generated by gem2arch (https://github.com/anatol/gem2arch)
# Maintainer: Anatol Pomozov <[email protected]>

_gemname=tilt
pkgname=ruby-$_gemname-1
pkgver=1.4.1
pkgrel=1
pkgdesc='Generic interface to multiple Ruby template engines'
arch=(any)
url='https://github.com/rtomayko/tilt/'
license=(MIT)
depends=(ruby)
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
sha1sums=('a63b374ab06aeb6f567bd24e61434e386cce0811')

package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/COPYING" "$pkgdir/usr/share/licenses/$pkgname/COPYING"

rm -rf "$pkgdir/usr/bin/"
}
Loading

0 comments on commit a382711

Please sign in to comment.