forked from linux-automation/meta-lxatac
-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
meta-lxatac-software: gitlab-runner: add recipe
To configure a runner you have to into the CI/CD setting of your GitLab repository, and add a new project runner. After configuring a few aspects of the runner you are presented with a token to use on the TAC: root@lxatac:~ gitlab-runner register --url https://gitlab.com --token glrt-01234567899876543210 Signed-off-by: Leonard Göhrs <[email protected]>
- Loading branch information
Showing
5 changed files
with
47 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
11 changes: 11 additions & 0 deletions
11
meta-lxatac-software/recipes-devtools/gitlab-runner/files/gitlab-runner.service
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
[Unit] | ||
Description=Schedule GitLab actions to run on this TAC | ||
ConditionPathExists=/etc/gitlab-runner/config.toml | ||
|
||
[Service] | ||
Type=simple | ||
ExecStart=/usr/bin/gitlab-runner run | ||
WorkingDirectory=/srv | ||
|
||
[Install] | ||
WantedBy=multi-user.target |
30 changes: 30 additions & 0 deletions
30
meta-lxatac-software/recipes-devtools/gitlab-runner/gitlab-runner.inc
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,30 @@ | ||
SUMMARY = "GitLab Runner" | ||
DESCRIPTION = "The Runner for GitLab Pipelines" | ||
|
||
LICENSE = "MIT" | ||
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" | ||
|
||
SRC_URI:append = " file://gitlab-runner.service " | ||
|
||
GO_IMPORT = "gitlab.com/gitlab-org/gitlab-runner" | ||
GO_INSTALL = "${GO_IMPORT}" | ||
|
||
RDEPENDS:gitlab-runner-dev = "bash" | ||
|
||
inherit go-mod | ||
inherit systemd | ||
|
||
SYSTEMD_SERVICE:${PN} = "gitlab-runner.service" | ||
|
||
# This is required because the go build system fetches dependecies in the | ||
# compile stage. | ||
do_compile[network] = "1" | ||
|
||
# This is required to prevent build failures due to | ||
# "duplicated definition of symbol" errors. | ||
GO_LINKSHARED = "" | ||
|
||
do_install:append() { | ||
install -d ${D}${systemd_system_unitdir} | ||
install -m 0644 ${WORKDIR}/gitlab-runner.service ${D}${systemd_system_unitdir}/ | ||
} |
4 changes: 4 additions & 0 deletions
4
meta-lxatac-software/recipes-devtools/gitlab-runner/gitlab-runner_16.6.1.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,4 @@ | ||
require gitlab-runner.inc | ||
|
||
SRC_URI = "git://gitlab.com/gitlab-org/gitlab-runner.git;branch=16-6-stable;protocol=https" | ||
SRCREV = "f5da3c5adf55e55004e0dae2a2e1476f8407c087" |