forked from linux-automation/meta-lxatac
-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
meta-lxatac-bsp: barebox: update to 2024.09.0
Signed-off-by: Leonard Göhrs <[email protected]>
- Loading branch information
Showing
18 changed files
with
111 additions
and
137 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -21,7 +21,7 @@ Signed-off-by: Ahmad Fatoum <[email protected]> | |
2 files changed, 34 insertions(+), 18 deletions(-) | ||
|
||
diff --git a/drivers/of/of_path.c b/drivers/of/of_path.c | ||
index 12a2dfce553e..522109c17b55 100644 | ||
index 42efb1ad1dbf..a1a47cad0c20 100644 | ||
--- a/drivers/of/of_path.c | ||
+++ b/drivers/of/of_path.c | ||
@@ -254,7 +254,11 @@ struct device_node *of_find_node_by_devpath(struct device_node *root, const char | ||
|
@@ -95,10 +95,10 @@ index 12a2dfce553e..522109c17b55 100644 | |
} | ||
|
||
diff --git a/include/of.h b/include/of.h | ||
index 19b8e7c038a4..51ad5773007b 100644 | ||
index 55f2c0cbdedf..187a55439a8a 100644 | ||
--- a/include/of.h | ||
+++ b/include/of.h | ||
@@ -336,7 +336,8 @@ int of_add_memory(struct device_node *node, bool dump); | ||
@@ -350,7 +350,8 @@ int of_add_memory(struct device_node *node, bool dump); | ||
int of_add_memory_bank(struct device_node *node, bool dump, int r, | ||
u64 base, u64 size); | ||
struct device *of_find_device_by_node_path(const char *path); | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -11,7 +11,7 @@ Signed-off-by: Ahmad Fatoum <[email protected]> | |
1 file changed, 1 insertion(+) | ||
|
||
diff --git a/Makefile b/Makefile | ||
index a539e57bc8a7..36145fc89eac 100644 | ||
index 403ab3fd48dd..29d94792ffae 100644 | ||
--- a/Makefile | ||
+++ b/Makefile | ||
@@ -445,6 +445,7 @@ LINUXINCLUDE := -Iinclude \ | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -19,10 +19,10 @@ Signed-off-by: Ahmad Fatoum <[email protected]> | |
1 file changed, 20 insertions(+) | ||
|
||
diff --git a/include/net.h b/include/net.h | ||
index ffc1093ae6e7..a569fdcf470f 100644 | ||
index a04ed5b0ab92..8a943e1bb1b2 100644 | ||
--- a/include/net.h | ||
+++ b/include/net.h | ||
@@ -520,6 +520,26 @@ static inline void eth_addr_add(u8 *addr, long offset) | ||
@@ -516,6 +516,26 @@ static inline void eth_addr_add(u8 *addr, long offset) | ||
u64_to_ether_addr(u, addr); | ||
} | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -13,10 +13,10 @@ Signed-off-by: Ahmad Fatoum <[email protected]> | |
2 files changed, 24 insertions(+) | ||
|
||
diff --git a/common/Kconfig b/common/Kconfig | ||
index d16c8696dad4..e25131b74198 100644 | ||
index 4500feb66c92..06ff53e9dd95 100644 | ||
--- a/common/Kconfig | ||
+++ b/common/Kconfig | ||
@@ -1089,6 +1089,14 @@ config MACHINE_ID | ||
@@ -1169,6 +1169,14 @@ config MACHINE_ID | ||
Note: if no hashable information is available no machine id will be passed | ||
to the kernel. | ||
|
||
|
@@ -32,12 +32,12 @@ index d16c8696dad4..e25131b74198 100644 | |
bool "inform devicetree-enabled kernel of used watchdog" | ||
depends on WATCHDOG && OFTREE && FLEXIBLE_BOOTARGS | ||
diff --git a/common/misc.c b/common/misc.c | ||
index e266f0951ee9..36dfd6f34873 100644 | ||
index 7e19797c2f99..1154ae9e21cd 100644 | ||
--- a/common/misc.c | ||
+++ b/common/misc.c | ||
@@ -146,6 +146,18 @@ static char *hostname; | ||
static char *serial_number; | ||
static char *of_machine_compatible; | ||
@@ -210,6 +210,18 @@ bool barebox_hostname_is_valid(const char *s) | ||
return true; | ||
} | ||
|
||
+static void linux_bootargs_set_hostname(void) | ||
+{ | ||
|
@@ -54,16 +54,16 @@ index e266f0951ee9..36dfd6f34873 100644 | |
/* | ||
* The hostname is supposed to be the shortname of a board. It should | ||
* contain only lowercase letters, numbers, '-', '_'. No whitespaces | ||
@@ -157,6 +169,8 @@ void barebox_set_hostname(const char *__hostname) | ||
@@ -225,6 +237,8 @@ void barebox_set_hostname(const char *__hostname) | ||
pr_warn("Hostname is not valid, please fix it\n"); | ||
|
||
free(hostname); | ||
hostname = xstrdup(__hostname); | ||
+ | ||
+ linux_bootargs_set_hostname(); | ||
} | ||
|
||
const char *barebox_get_hostname(void) | ||
@@ -181,6 +195,8 @@ void barebox_set_serial_number(const char *__serial_number) | ||
@@ -249,6 +263,8 @@ void barebox_set_serial_number(const char *__serial_number) | ||
|
||
free(serial_number); | ||
serial_number = xstrdup(__serial_number); | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -14,10 +14,10 @@ Signed-off-by: Ahmad Fatoum <[email protected]> | |
2 files changed, 31 insertions(+), 10 deletions(-) | ||
|
||
diff --git a/include/net.h b/include/net.h | ||
index a569fdcf470f..d11b7b8f1e0d 100644 | ||
index 8a943e1bb1b2..5171c6485d26 100644 | ||
--- a/include/net.h | ||
+++ b/include/net.h | ||
@@ -130,6 +130,18 @@ static inline void of_eth_register_ethaddr(struct device_node *node, | ||
@@ -128,6 +128,18 @@ static inline void of_eth_register_ethaddr(struct device_node *node, | ||
void eth_register_ethaddr(int ethid, const char *ethaddr); | ||
void of_eth_register_ethaddr(struct device_node *node, const char *ethaddr); | ||
#endif | ||
|
@@ -37,7 +37,7 @@ index a569fdcf470f..d11b7b8f1e0d 100644 | |
* Ethernet header | ||
*/ | ||
diff --git a/net/eth.c b/net/eth.c | ||
index 28961e868b7a..8097fb949412 100644 | ||
index 7229530c055b..a1d6860be830 100644 | ||
--- a/net/eth.c | ||
+++ b/net/eth.c | ||
@@ -319,19 +319,11 @@ static int eth_param_set_ethaddr(struct param_d *param, void *priv) | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -24,12 +24,12 @@ Signed-off-by: Ahmad Fatoum <[email protected]> | |
2 files changed, 11 insertions(+), 9 deletions(-) | ||
|
||
diff --git a/include/net.h b/include/net.h | ||
index d11b7b8f1e0d..0ec2519e2eff 100644 | ||
index 5171c6485d26..cbb26169f288 100644 | ||
--- a/include/net.h | ||
+++ b/include/net.h | ||
@@ -627,6 +627,15 @@ void ifdown_all(void); | ||
@@ -633,4 +633,13 @@ void ifdown_all(void); | ||
|
||
extern struct list_head netdev_list; | ||
extern struct class eth_class; | ||
|
||
+struct eth_ethaddr { | ||
+ struct list_head list; | ||
|
@@ -40,16 +40,14 @@ index d11b7b8f1e0d..0ec2519e2eff 100644 | |
+ | ||
+extern struct list_head ethaddr_list; | ||
+ | ||
#define for_each_netdev(netdev) list_for_each_entry(netdev, &netdev_list, list) | ||
|
||
#endif /* __NET_H__ */ | ||
diff --git a/net/eth.c b/net/eth.c | ||
index 8097fb949412..ebeeb620d567 100644 | ||
index a1d6860be830..3714dde44026 100644 | ||
--- a/net/eth.c | ||
+++ b/net/eth.c | ||
@@ -23,14 +23,7 @@ | ||
|
||
LIST_HEAD(netdev_list); | ||
DEFINE_DEV_CLASS(eth_class, "eth"); | ||
|
||
-struct eth_ethaddr { | ||
- struct list_head list; | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -15,10 +15,10 @@ Signed-off-by: Ahmad Fatoum <[email protected]> | |
2 files changed, 19 insertions(+) | ||
|
||
diff --git a/include/net.h b/include/net.h | ||
index 0ec2519e2eff..728684b56646 100644 | ||
index cbb26169f288..b210996d2ae8 100644 | ||
--- a/include/net.h | ||
+++ b/include/net.h | ||
@@ -370,6 +370,8 @@ IPaddr_t getenv_ip(const char *name); | ||
@@ -366,6 +366,8 @@ IPaddr_t getenv_ip(const char *name); | ||
int setenv_ip(const char *name, IPaddr_t ip); | ||
|
||
int string_to_ethaddr(const char *str, u8 enetaddr[6]); | ||
|
Oops, something went wrong.