Skip to content

Commit

Permalink
net-dialup/xl2tpd: -r3 for c23 patch.
Browse files Browse the repository at this point in the history
Upstream: xelerance/xl2tpd#269

Closes: https://bugs.gentoo.org/944070
Signed-off-by: Jaco Kroon <[email protected]>
  • Loading branch information
jkroonza committed Nov 20, 2024
1 parent 4a95491 commit 51fb355
Show file tree
Hide file tree
Showing 2 changed files with 107 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
From 07f0a12f1f3c10f5be31e4474bcb5422d0d5e9b3 Mon Sep 17 00:00:00 2001
From: Jaco Kroon <[email protected]>
Date: Thu, 21 Nov 2024 00:12:29 +0200
Subject: [PATCH] Fix compiling with C23.

https://bugs.gentoo.org/944070
Signed-off-by: Jaco Kroon <[email protected]>
---
xl2tpd.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/xl2tpd.c b/xl2tpd.c
index 791d5a4..4bf15fd 100644
--- a/xl2tpd.c
+++ b/xl2tpd.c
@@ -74,7 +74,7 @@ static int control_handle_lac_hangup(FILE* resf, char* bufp);
static int control_handle_lac_disconnect(FILE* resf, char* bufp);
static int control_handle_lac_add_modify(FILE* resf, char* bufp);
static int control_handle_lac_remove(FILE* resf, char* bufp);
-static int control_handle_lac_status();
+static int control_handle_lac_status(FILE* resf, char* bufp);
static int control_handle_lns_remove(FILE* resf, char* bufp);

static struct control_requests_handler control_handlers[] = {
@@ -1549,7 +1549,8 @@ static int control_handle_lac_remove(FILE* resf, char* bufp){
return 1;
}

-static int control_handle_lac_status(){
+static int control_handle_lac_status(FILE*, char*)
+{
show_status ();
return 1;
}
--
2.44.2

70 changes: 70 additions & 0 deletions net-dialup/xl2tpd/xl2tpd-1.3.18-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit systemd toolchain-funcs tmpfiles

DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
HOMEPAGE="https://github.com/xelerance/xl2tpd"
SRC_URI="https://github.com/xelerance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~x86"
IUSE="+kernel"

DEPEND="
net-libs/libpcap
>=sys-kernel/linux-headers-2.6"

RDEPEND="
${DEPEND}
net-dialup/ppp"

DOCS=( CREDITS README.md BUGS CHANGES TODO doc/README.patents )

PATCHES=(
"${FILESDIR}/xl2tpd-1.3.18-r1-close-calls-when-pppd-terminates.patch"
"${FILESDIR}/xl2tpd-1.3.18-r2-Pass-remotenumber-to-pppd.patch"
"${FILESDIR}/xl2tpd-1.3.18-r3-Fix-compiling-with-C23.patch"
)

src_prepare() {
default
sed -e 's:/var/run/:/run/:' -i \
file.h \
l2tp.h \
xl2tpd-control.c \
doc/l2tp-secrets.5 \
doc/xl2tpd.8 \
doc/xl2tpd.conf.5 \
|| die "Error updating /var/run to /run"
}

src_compile() {
tc-export CC
local OSFLAGS="-DLINUX"
use kernel && OSFLAGS+=" -DUSE_KERNEL"
emake OSFLAGS="${OSFLAGS}"
}

src_install() {
emake PREFIX=/usr DESTDIR="${D}" install

newinitd "${FILESDIR}"/xl2tpd-init-r1 xl2tpd

systemd_dounit "${FILESDIR}"/xl2tpd.service
dotmpfiles "${FILESDIR}"/xl2tpd.conf

einstalldocs

insinto /etc/xl2tpd
newins doc/l2tpd.conf.sample xl2tpd.conf
insopts -m 0600
newins doc/l2tp-secrets.sample l2tp-secrets
}

pkg_postinst() {
tmpfiles_process xl2tpd.conf
}

0 comments on commit 51fb355

Please sign in to comment.