Skip to content

Commit

Permalink
Release 1.6.0. (aurora-is-near#235)
Browse files Browse the repository at this point in the history
* ERC-20: forbid using invalid NEP141 AccountID for mapping (aurora-is-near#179)
* Timestamp should be in milliseconds for Ethereum compatibility (aurora-is-near#208)
* feat(engine): Blockhash definition (aurora-is-near#213)
* Update etc/state-migration-test/Cargo.lock (aurora-is-near#211)
* Include cost of access list in intrinsic gas (aurora-is-near#219)
* Bump tar from 4.4.13 to 4.4.15 in /etc/eth-contracts (aurora-is-near#217)
* Feat(engine): Relayer payment (aurora-is-near#215)
* Scheduled lint is supposed to run nightly clippy (aurora-is-near#214)
* Return actual status of a transaction (aurora-is-near#218)
* Added parser for Integer types (aurora-is-near#183)
* Update to latest nightly (aurora-is-near#221)
* Fix(engine): do not panic when user has insufficient balance to cover gas (aurora-is-near#223)
* Update lock files (aurora-is-near#224)
* Method to fix balance of aurora account on testnet (aurora-is-near#225)
* Use math api host functions on mainnet (aurora-is-near#228)
* NEP-141 compliance correctness (aurora-is-near#202)
* Adapt workflows to dockerized runners (aurora-is-near#231)
* Move block height to the end of hashed data. (aurora-is-near#233)
* Ensure solidity artifacts are always recompiled (aurora-is-near#234)
* Prevent test binary from deploying (aurora-is-near#237)
* Add removal of eth-contracts to `make clean`
* Remove deploy_code feature gate

Co-authored-by: Dmitry Strokov <[email protected]>
Co-authored-by: Evgeny Ukhanov <[email protected]>
Co-authored-by: Joshua J. Bouw <[email protected]>
Co-authored-by: Kirill <[email protected]>
Co-authored-by: Michael Birch <[email protected]>
Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
  • Loading branch information
7 people authored Aug 14, 2021
1 parent 65a1d11 commit bb21459
Show file tree
Hide file tree
Showing 39 changed files with 1,117 additions and 257 deletions.
2 changes: 0 additions & 2 deletions .github/workflows/builds.yml
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,6 @@ jobs:
steps:
- name: Clone the repository
uses: actions/checkout@v2
- run: echo "$HOME/.cargo/bin" >> $GITHUB_PATH
- run: make release
- run: ls -lH mainnet-release.wasm
- name: Upload the mainnet-release.wasm artifact
Expand All @@ -34,7 +33,6 @@ jobs:
steps:
- name: Clone the repository
uses: actions/checkout@v2
- run: echo "$HOME/.cargo/bin" >> $GITHUB_PATH
- run: make debug
- run: ls -lH mainnet-debug.wasm
- name: Upload the mainnet-debug.wasm artifact
Expand Down
12 changes: 9 additions & 3 deletions .github/workflows/lints.yml
Original file line number Diff line number Diff line change
@@ -1,6 +1,14 @@
# See: https://github.com/actions-rs/example/blob/master/.github/workflows/nightly_lints.yml
---
on: [push, pull_request]
on:
push:
branches:
- master
- develop
pull_request:
branches:
- "*"

name: Lints
jobs:
fmt:
Expand All @@ -9,7 +17,6 @@ jobs:
steps:
- name: Clone the repository
uses: actions/checkout@v2
- run: echo "$HOME/.cargo/bin" >> $GITHUB_PATH
- name: Run cargo fmt
run: cargo fmt --all -- --check
clippy:
Expand All @@ -18,7 +25,6 @@ jobs:
steps:
- name: Clone the repository
uses: actions/checkout@v2
- run: echo "$HOME/.cargo/bin" >> $GITHUB_PATH
- run: make etc/eth-contracts/res/EvmErc20.bin
- name: Run Contract cargo clippy
run: cargo clippy --no-default-features --features=contract -- -D warnings
Expand Down
5 changes: 3 additions & 2 deletions .github/workflows/scheduled_lints.yml
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,8 @@ jobs:
steps:
- name: Clone the repository
uses: actions/checkout@v2
- run: echo "$HOME/.cargo/bin" >> $GITHUB_PATH
- run: make etc/eth-contracts/res/EvmErc20.bin
- name: Update toolchain
run: rustup update nightly
- name: Run cargo clippy
run: cargo clippy --no-default-features --features=mainnet -- -D warnings
run: cargo +nightly clippy --no-default-features --features=mainnet -- -D warnings
42 changes: 28 additions & 14 deletions .github/workflows/tests.yml
Original file line number Diff line number Diff line change
@@ -1,5 +1,13 @@
---
on: [push, pull_request]
on:
push:
branches:
- master
- develop
pull_request:
branches:
- "*"

name: Tests
jobs:
test:
Expand All @@ -11,27 +19,33 @@ jobs:
steps:
- name: Clone the repository
uses: actions/checkout@v2
- run: echo "$HOME/.cargo/bin" >> $GITHUB_PATH
- name: Cache lookup for target dir
run: cache-util -restore -path target -key aurora-engine-target@${{ matrix.net }}net@${{ hashFiles('**/Cargo.lock') }}
- run: make ${{ matrix.net }}net-test-build
- name: Run ${{ matrix.net }}net cargo test
run: cargo test --locked --verbose --features ${{ matrix.net }}net-test
- name: Caching target dir
run: cache-util -save -move -path target -key aurora-engine-target@${{ matrix.net }}net@${{ hashFiles('**/Cargo.lock') }}
- name: Restore cache
run: |
cache-util restore cargo_git cargo_registry sccache yarn_cache
cache-util restore aurora-engine-target@${{ matrix.net }}net@${{ hashFiles('**/Cargo.lock') }}:target
- run: make test-${{ matrix.net }}net
# - run: rm -rf target/solidity_build/
- name: Save cache
run: |
cache-util save cargo_git cargo_registry sccache yarn_cache
cache-util msave aurora-engine-target@${{ matrix.net }}net@${{ hashFiles('**/Cargo.lock') }}:target
bully-build:
name: Bully build
runs-on: self-hosted
steps:
- name: Clone the repository
uses: actions/checkout@v2
- run: echo "$HOME/.cargo/bin" >> $GITHUB_PATH
- name: Cache lookup for target dir
run: cache-util -restore -path target -key aurora-engine-target@bully@${{ hashFiles('**/Cargo.lock') }}
- name: Restore cache
run: |
cache-util restore cargo_git cargo_registry sccache yarn_cache
cache-util restore aurora-engine-target@bully@${{ hashFiles('**/Cargo.lock') }}:target
- run: make mainnet-debug evm-bully=yes
- run: ls -lH mainnet-debug.wasm
- name: Cache target dir
run: cache-util -save -move -path target -key aurora-engine-target@bully@${{ hashFiles('**/Cargo.lock') }}
# - run: rm -rf target/solidity_build/
- name: Save cache
run: |
cache-util save cargo_git cargo_registry sccache yarn_cache
cache-util msave aurora-engine-target@bully@${{ hashFiles('**/Cargo.lock') }}:target
env:
CARGO_TERM_COLOR: always
CARGO_INCREMENTAL: 0
Expand Down
2 changes: 1 addition & 1 deletion .gitignore
Original file line number Diff line number Diff line change
Expand Up @@ -18,7 +18,7 @@
artifacts/
cache/
node_modules/
res/
etc/eth-contracts/res/

# Other
etc/state-migration-test/target/
Expand Down
3 changes: 3 additions & 0 deletions CHANGES.md
Original file line number Diff line number Diff line change
Expand Up @@ -5,6 +5,8 @@ All notable changes to this project will be documented in this file.
The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).

## [1.6.0] - 2021-08-13

## [1.5.0] - 2021-07-30

## [1.4.3] - 2021-07-08
Expand All @@ -23,6 +25,7 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0

## [1.0.0] - 2021-05-12

[1.6.0]: https://github.com/aurora-is-near/aurora-engine/compare/1.5.0...1.6.0
[1.5.0]: https://github.com/aurora-is-near/aurora-engine/compare/1.4.3...1.5.0
[1.4.3]: https://github.com/aurora-is-near/aurora-engine/compare/1.4.2...1.4.3
[1.4.2]: https://github.com/aurora-is-near/aurora-engine/compare/1.4.1...1.4.2
Expand Down
29 changes: 14 additions & 15 deletions Cargo.lock

Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.

6 changes: 3 additions & 3 deletions Cargo.toml
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = "aurora-engine"
version = "1.5.0"
version = "1.6.0"
authors = ["NEAR <[email protected]>"]
edition = "2018"
description = ""
Expand Down Expand Up @@ -45,6 +45,7 @@ lto = true
opt-level = 3

[dependencies]
base64 = { version = "0.13.0", default-features = false, features = ["alloc"] }
blake2 = { git = "https://github.com/near/near-blake2.git", version = "0.9.1", default-features = false }
borsh = { version = "0.8.2", default-features = false }
bn = { package = "aurora-bn", git = "https://github.com/aurora-is-near/aurora-bn.git", default-features = false }
Expand All @@ -62,7 +63,7 @@ logos = { version = "0.12", default-features = false, features = ["export_derive
ethabi = { git = "https://github.com/darwinia-network/ethabi", branch = "xavier-no-std", default-features = false }
hex = { version = "0.4", default-features = false, features = ["alloc"] }
byte-slice-cast = { version = "1.0", default-features = false }
rjson = { version = "0.3.1", default-features = false }
rjson = { git = "https://github.com/aurora-is-near/rjson", rev = "cc3da949", default-features = false, features = ["integer"] }

[dev-dependencies]
bstr = "0.2"
Expand All @@ -80,7 +81,6 @@ rand = "0.7.3"
criterion = "0.3.4"
git2 = "0.13"
lazy-static-include = "3.1.1"
base64 = "0.13.0"

[features]
default = ["sha2", "std"]
Expand Down
16 changes: 13 additions & 3 deletions Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -68,13 +68,22 @@ target/wasm32-unknown-unknown/debug/aurora_engine.wasm: Cargo.toml Cargo.lock $(
test: test-mainnet

mainnet-test-build: FEATURES=mainnet,integration-test,meta-call
mainnet-test-build: mainnet-release.wasm
mainnet-test-build: mainnet-test.wasm

betanet-test-build: FEATURES=betanet,integration-test,meta-call
betanet-test-build: betanet-release.wasm
betanet-test-build: betanet-test.wasm

testnet-test-build: FEATURES=testnet,integration-test,meta-call
testnet-test-build: testnet-release.wasm
testnet-test-build: testnet-test.wasm

mainnet-test.wasm: target/wasm32-unknown-unknown/release/aurora_engine.wasm
cp $< $@

testnet-test.wasm: target/wasm32-unknown-unknown/release/aurora_engine.wasm
cp $< $@

betanet-test.wasm: target/wasm32-unknown-unknown/release/aurora_engine.wasm
cp $< $@

test-mainnet: mainnet-test-build
$(CARGO) test --features mainnet-test
Expand Down Expand Up @@ -104,6 +113,7 @@ format:

clean:
@rm -Rf *.wasm
@rm -Rf etc/eth-contracts/res
cargo clean

.PHONY: release mainnet testnet betanet compile-release test-build deploy check check-format check-clippy test test-sol format clean debug mainnet-debug testnet-debug betanet-debug compile-debug mainnet-test-build testnet-test-build betanet-test-build target/wasm32-unknown-unknown/release/aurora_engine.wasm target/wasm32-unknown-unknown/debug/aurora_engine.wasm
Expand Down
2 changes: 1 addition & 1 deletion VERSION
Original file line number Diff line number Diff line change
@@ -1 +1 @@
1.5.0
1.6.0
6 changes: 3 additions & 3 deletions etc/eth-contracts/yarn.lock
Original file line number Diff line number Diff line change
Expand Up @@ -9657,9 +9657,9 @@ tar-stream@^1.5.2:
xtend "^4.0.0"

tar@^4.0.2:
version "4.4.13"
resolved "https://registry.yarnpkg.com/tar/-/tar-4.4.13.tgz#43b364bc52888d555298637b10d60790254ab525"
integrity sha512-w2VwSrBoHa5BsSyH+KxEqeQBAllHhccyMFVHtGtdMpF4W7IRWfZjFiQceJPChOeTsSDVUpER2T8FA93pr0L+QA==
version "4.4.15"
resolved "https://registry.yarnpkg.com/tar/-/tar-4.4.15.tgz#3caced4f39ebd46ddda4d6203d48493a919697f8"
integrity sha512-ItbufpujXkry7bHH9NpQyTXPbJ72iTlXgkBAYsAjDXk3Ds8t/3NfO5P4xZGy7u+sYuQUbimgzswX4uQIEeNVOA==
dependencies:
chownr "^1.1.1"
fs-minipass "^1.2.5"
Expand Down
14 changes: 10 additions & 4 deletions etc/state-migration-test/Cargo.lock

Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.

2 changes: 1 addition & 1 deletion rust-toolchain
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
[toolchain]
channel = "nightly-2021-03-25"
channel = "nightly-2021-08-01"
components = []
targets = ["wasm32-unknown-unknown"]
Loading

0 comments on commit bb21459

Please sign in to comment.