haskell.nix
is an experimental new builder for Haskell packages.
It works by automatically translating your Cabal or Stack project and its dependencies into Nix code. Most of your dependencies are already translated, so you generally won’t have too much generated code.
For the documentation, see https://input-output-hk.github.io/haskell.nix/.
This will download and build nix-tools
.
nix build -f https://github.com/input-output-hk/haskell.nix/archive/master.tar.gz nix-tools -o nt
./nt/bin/stack-to-nix
The haskell.nix
repository contains the runtime system for building
Haskell packages in Nix. It depends on other repos, which are:
- nix-tools — provides the programs for generating Nix expressions from Haskell projects.
- hackage.nix — the latest contents of the Hackage databases, converted to Nix expressions.
- stackage.nix — all of the Stackage snapshots, converted to Nix expressions.
Join the #haskell.nix channel on irc.freenode.net to get help or discuss
the development of haskell.nix
and nix-tools
.