Skip to content

v1.0.0-rc.2

Compare
Choose a tag to compare
@Dirbaio Dirbaio released this 14 Dec 13:47
· 110 commits to master since this release
a8c72e9
  • Minor document fixes.
  • Add #[inline] hints to most of embedded-hal functions.
  • pwm: rename get_max_duty_cycle to max_duty_cycle.
  • delay: Rename DelayUs to DelayNs
  • delay: Add DelayNs::delay_ns()
  • delay: Add default impls of delay_ms and delay_us based on delay_ns.
  • delay: Make the default impl of delay_ms more efficient, it now does less calls to the underlying delay_ns (previously delay_us).
  • spi: Rename Operation::DelayUs to Operation::DelayNs, with nanosecond precision.