Skip to content

Commit

Permalink
Add so file build (#12)
Browse files Browse the repository at this point in the history
  • Loading branch information
Hidenori Matsubayashi authored Jul 20, 2021
1 parent b214ea6 commit ed202e3
Show file tree
Hide file tree
Showing 6 changed files with 73 additions and 3 deletions.
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
SUMMARY = "Flutter embedding for embedded Linux with DRM-EGLStream backend"
SUMMARY = "Flutter embedding for eLinux with DRM-EGLStream backend"
DESCRIPTION = "Build the flutter-drm-eglstream-backend project"

require repository.inc
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
SUMMARY = "Flutter embedding for eLinux with DRM-EGLStream backend (.so)"
DESCRIPTION = "Build .so file of the Flutter embedding for eLinux with DRM-EGLStream"

require repository.inc
require dependency.inc

DEPENDS += "libdrm \
virtual/mesa \
libinput \
udev \
systemd"

EXTRA_OECMAKE = "-DBUILD_ELINUX_SO=ON \
-DBACKEND_TYPE=DRM-EGLSTREAM \
-DCMAKE_BUILD_TYPE=Release \
-DENABLE_ELINUX_EMBEDDER_LOG=ON \
-DFLUTTER_RELEASE=ON"

do_install() {
install -d ${D}${libdir}
install -m 0755 ${WORKDIR}/build/libflutter_elinux_eglstream.so ${D}${bindir}
}

require tasks.inc
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
SUMMARY = "Flutter embedding for embedded Linux with DRM-GBM backend"
SUMMARY = "Flutter embedding for eLinux with DRM-GBM backend"
DESCRIPTION = "Build the flutter-drm-gbm-backend project"

require repository.inc
Expand Down
24 changes: 24 additions & 0 deletions recipes-graphics/flutter-embedded-linux/flutter-drm-gbm-so.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
SUMMARY = "Flutter embedding for eLinux with DRM-GBM backend (.so)"
DESCRIPTION = "Build .so file of the Flutter embedding for eLinux with DRM-GBM"

require repository.inc
require dependency.inc

DEPENDS += "libdrm \
virtual/mesa \
libinput \
udev \
systemd"

EXTRA_OECMAKE = "-DBUILD_ELINUX_SO=ON \
-DBACKEND_TYPE=DRM-GBM \
-DCMAKE_BUILD_TYPE=Release \
-DENABLE_ELINUX_EMBEDDER_LOG=ON \
-DFLUTTER_RELEASE=ON"

do_install() {
install -d ${D}${libdir}
install -m 0755 ${WORKDIR}/build/libflutter_elinux_gbm.so ${D}${bindir}
}

require tasks.inc
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
SUMMARY = "Flutter embedding for embedded Linux with Wayland backend"
SUMMARY = "Flutter embedding for eLinux with Wayland backend"
DESCRIPTION = "Build the flutter-wayland-client project"

require repository.inc
Expand Down
22 changes: 22 additions & 0 deletions recipes-graphics/flutter-embedded-linux/flutter-wayland-so.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
SUMMARY = "Flutter embedding for eLinux with Wayland backend (.so)"
DESCRIPTION = "Build .so file of the Flutter embedding for eLinux with Wayland"

require repository.inc
require dependency.inc

DEPENDS += "wayland \
wayland-protocols \
wayland-native"

EXTRA_OECMAKE = "-DBUILD_ELINUX_SO=ON \
-DBACKEND_TYPE=WAYLAND \
-DCMAKE_BUILD_TYPE=Release \
-DENABLE_ELINUX_EMBEDDER_LOG=ON \
-DFLUTTER_RELEASE=ON"

do_install() {
install -d ${D}${libdir}
install -m 0755 ${WORKDIR}/build/libflutter_elinux_wayland.so ${D}${bindir}
}

require tasks.inc

0 comments on commit ed202e3

Please sign in to comment.