-
Notifications
You must be signed in to change notification settings - Fork 22
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Hidenori Matsubayashi
authored
Jul 20, 2021
1 parent
b214ea6
commit ed202e3
Showing
6 changed files
with
73 additions
and
3 deletions.
There are no files selected for viewing
2 changes: 1 addition & 1 deletion
2
recipes-graphics/flutter-embedded-linux/flutter-drm-eglstream-backend.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
24 changes: 24 additions & 0 deletions
24
recipes-graphics/flutter-embedded-linux/flutter-drm-eglstream-so.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,24 @@ | ||
SUMMARY = "Flutter embedding for eLinux with DRM-EGLStream backend (.so)" | ||
DESCRIPTION = "Build .so file of the Flutter embedding for eLinux with DRM-EGLStream" | ||
|
||
require repository.inc | ||
require dependency.inc | ||
|
||
DEPENDS += "libdrm \ | ||
virtual/mesa \ | ||
libinput \ | ||
udev \ | ||
systemd" | ||
|
||
EXTRA_OECMAKE = "-DBUILD_ELINUX_SO=ON \ | ||
-DBACKEND_TYPE=DRM-EGLSTREAM \ | ||
-DCMAKE_BUILD_TYPE=Release \ | ||
-DENABLE_ELINUX_EMBEDDER_LOG=ON \ | ||
-DFLUTTER_RELEASE=ON" | ||
|
||
do_install() { | ||
install -d ${D}${libdir} | ||
install -m 0755 ${WORKDIR}/build/libflutter_elinux_eglstream.so ${D}${bindir} | ||
} | ||
|
||
require tasks.inc |
2 changes: 1 addition & 1 deletion
2
recipes-graphics/flutter-embedded-linux/flutter-drm-gbm-backend.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
24 changes: 24 additions & 0 deletions
24
recipes-graphics/flutter-embedded-linux/flutter-drm-gbm-so.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,24 @@ | ||
SUMMARY = "Flutter embedding for eLinux with DRM-GBM backend (.so)" | ||
DESCRIPTION = "Build .so file of the Flutter embedding for eLinux with DRM-GBM" | ||
|
||
require repository.inc | ||
require dependency.inc | ||
|
||
DEPENDS += "libdrm \ | ||
virtual/mesa \ | ||
libinput \ | ||
udev \ | ||
systemd" | ||
|
||
EXTRA_OECMAKE = "-DBUILD_ELINUX_SO=ON \ | ||
-DBACKEND_TYPE=DRM-GBM \ | ||
-DCMAKE_BUILD_TYPE=Release \ | ||
-DENABLE_ELINUX_EMBEDDER_LOG=ON \ | ||
-DFLUTTER_RELEASE=ON" | ||
|
||
do_install() { | ||
install -d ${D}${libdir} | ||
install -m 0755 ${WORKDIR}/build/libflutter_elinux_gbm.so ${D}${bindir} | ||
} | ||
|
||
require tasks.inc |
2 changes: 1 addition & 1 deletion
2
recipes-graphics/flutter-embedded-linux/flutter-wayland-client.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
22 changes: 22 additions & 0 deletions
22
recipes-graphics/flutter-embedded-linux/flutter-wayland-so.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
SUMMARY = "Flutter embedding for eLinux with Wayland backend (.so)" | ||
DESCRIPTION = "Build .so file of the Flutter embedding for eLinux with Wayland" | ||
|
||
require repository.inc | ||
require dependency.inc | ||
|
||
DEPENDS += "wayland \ | ||
wayland-protocols \ | ||
wayland-native" | ||
|
||
EXTRA_OECMAKE = "-DBUILD_ELINUX_SO=ON \ | ||
-DBACKEND_TYPE=WAYLAND \ | ||
-DCMAKE_BUILD_TYPE=Release \ | ||
-DENABLE_ELINUX_EMBEDDER_LOG=ON \ | ||
-DFLUTTER_RELEASE=ON" | ||
|
||
do_install() { | ||
install -d ${D}${libdir} | ||
install -m 0755 ${WORKDIR}/build/libflutter_elinux_wayland.so ${D}${bindir} | ||
} | ||
|
||
require tasks.inc |