Skip to content

Commit

Permalink
feat(release): Manually fix release
Browse files Browse the repository at this point in the history
  • Loading branch information
simplynutty committed Mar 29, 2022
1 parent 1b20159 commit dd987a9
Show file tree
Hide file tree
Showing 72 changed files with 13,152 additions and 12,972 deletions.
34 changes: 14 additions & 20 deletions .travis.yml
Original file line number Diff line number Diff line change
@@ -1,8 +1,20 @@
sudo: false
language: node_js
after_success:
- npx codecov
branches:
only:
- /.*/
cache:
directories:
- node_modules
deploy:
- provider: script
cleanup: false
script: npx semantic-release
on:
branch: master
dist: xenial
language: node_js
os: linux
notifications:
email: false
script:
Expand All @@ -11,21 +23,3 @@ script:
- npm run test:ci
- npm run build
- npm run catalog-build
after_success:
- npx codecov
deploy:
- provider: script
skip_cleanup: true
script:
- npx semantic-release
- provider: pages
skip-cleanup: true
github-token: $GITHUB_TOKEN
keep-history: true
local-dir: catalog/build
target-branch: gh-pages
on:
branch: master
branches:
only:
- master
4 changes: 2 additions & 2 deletions README.md
Original file line number Diff line number Diff line change
Expand Up @@ -69,8 +69,8 @@ A documentation of each component and living styleguide will be available on the

MIT

[build-badge]: https://travis-ci.org/ticketmaster/aurora.svg?branch=master
[build]: https://travis-ci.org/ticketmaster/aurora
[build-badge]: https://app.travis-ci.com/ticketmaster/aurora.svg?branch=master
[build]: https://app.travis-ci.com/ticketmaster/aurora
[coverage-badge]: https://img.shields.io/codecov/c/github/ticketmaster/aurora.svg
[coverage]: https://codecov.io/github/ticketmaster/aurora
[version-badge]: https://img.shields.io/npm/v/@ticketmaster/aurora.svg
Expand Down
58 changes: 58 additions & 0 deletions asset-manifest.json
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
{
"catalog.js": "static/catalog.4dcdcad6.js",
"catalog.js.map": "static/catalog.4dcdcad6.js.map",
"manifest.js": "static/manifest.b12794b5.js",
"manifest.js.map": "static/manifest.b12794b5.js.map",
"static/0.9cebb3db.chunk.js": "static/0.9cebb3db.chunk.js",
"static/0.9cebb3db.chunk.js.map": "static/0.9cebb3db.chunk.js.map",
"static/1.8dbc5780.chunk.js": "static/1.8dbc5780.chunk.js",
"static/1.8dbc5780.chunk.js.map": "static/1.8dbc5780.chunk.js.map",
"static/10.10c278c4.chunk.js": "static/10.10c278c4.chunk.js",
"static/10.10c278c4.chunk.js.map": "static/10.10c278c4.chunk.js.map",
"static/11.00506fb5.chunk.js": "static/11.00506fb5.chunk.js",
"static/11.00506fb5.chunk.js.map": "static/11.00506fb5.chunk.js.map",
"static/12.0c0221ca.chunk.js": "static/12.0c0221ca.chunk.js",
"static/12.0c0221ca.chunk.js.map": "static/12.0c0221ca.chunk.js.map",
"static/13.9fe3cf1e.chunk.js": "static/13.9fe3cf1e.chunk.js",
"static/13.9fe3cf1e.chunk.js.map": "static/13.9fe3cf1e.chunk.js.map",
"static/14.7c75c674.chunk.js": "static/14.7c75c674.chunk.js",
"static/14.7c75c674.chunk.js.map": "static/14.7c75c674.chunk.js.map",
"static/15.8f2463f6.chunk.js": "static/15.8f2463f6.chunk.js",
"static/15.8f2463f6.chunk.js.map": "static/15.8f2463f6.chunk.js.map",
"static/16.3fc2db4f.chunk.js": "static/16.3fc2db4f.chunk.js",
"static/16.3fc2db4f.chunk.js.map": "static/16.3fc2db4f.chunk.js.map",
"static/17.a3b19461.chunk.js": "static/17.a3b19461.chunk.js",
"static/17.a3b19461.chunk.js.map": "static/17.a3b19461.chunk.js.map",
"static/18.bfa64c95.chunk.js": "static/18.bfa64c95.chunk.js",
"static/18.bfa64c95.chunk.js.map": "static/18.bfa64c95.chunk.js.map",
"static/19.b6d00849.chunk.js": "static/19.b6d00849.chunk.js",
"static/19.b6d00849.chunk.js.map": "static/19.b6d00849.chunk.js.map",
"static/2.98ea35f1.chunk.js": "static/2.98ea35f1.chunk.js",
"static/2.98ea35f1.chunk.js.map": "static/2.98ea35f1.chunk.js.map",
"static/20.97a4c0c3.chunk.js": "static/20.97a4c0c3.chunk.js",
"static/20.97a4c0c3.chunk.js.map": "static/20.97a4c0c3.chunk.js.map",
"static/21.30b83b87.chunk.js": "static/21.30b83b87.chunk.js",
"static/21.30b83b87.chunk.js.map": "static/21.30b83b87.chunk.js.map",
"static/22.657eab55.chunk.js": "static/22.657eab55.chunk.js",
"static/22.657eab55.chunk.js.map": "static/22.657eab55.chunk.js.map",
"static/23.f1f2684a.chunk.js": "static/23.f1f2684a.chunk.js",
"static/23.f1f2684a.chunk.js.map": "static/23.f1f2684a.chunk.js.map",
"static/24.cb9a5d68.chunk.js": "static/24.cb9a5d68.chunk.js",
"static/24.cb9a5d68.chunk.js.map": "static/24.cb9a5d68.chunk.js.map",
"static/3.f91f409b.chunk.js": "static/3.f91f409b.chunk.js",
"static/3.f91f409b.chunk.js.map": "static/3.f91f409b.chunk.js.map",
"static/4.9a3856cd.chunk.js": "static/4.9a3856cd.chunk.js",
"static/4.9a3856cd.chunk.js.map": "static/4.9a3856cd.chunk.js.map",
"static/5.6acafeaf.chunk.js": "static/5.6acafeaf.chunk.js",
"static/5.6acafeaf.chunk.js.map": "static/5.6acafeaf.chunk.js.map",
"static/6.8b217a73.chunk.js": "static/6.8b217a73.chunk.js",
"static/6.8b217a73.chunk.js.map": "static/6.8b217a73.chunk.js.map",
"static/7.ad11479c.chunk.js": "static/7.ad11479c.chunk.js",
"static/7.ad11479c.chunk.js.map": "static/7.ad11479c.chunk.js.map",
"static/8.736b3a5f.chunk.js": "static/8.736b3a5f.chunk.js",
"static/8.736b3a5f.chunk.js.map": "static/8.736b3a5f.chunk.js.map",
"static/9.ffb0cd29.chunk.js": "static/9.ffb0cd29.chunk.js",
"static/9.ffb0cd29.chunk.js.map": "static/9.ffb0cd29.chunk.js.map",
"vendor.js": "static/vendor.2e50417c.js",
"vendor.js.map": "static/vendor.2e50417c.js.map"
}
2 changes: 1 addition & 1 deletion catalog/pages/header/index.md
Original file line number Diff line number Diff line change
Expand Up @@ -221,7 +221,7 @@ responsive: true
<LazyHeaderWithImageExample
withUnderlay={true}
backgroundImage="https://beta.tmol.co/s3images/City/losangeles_889.jpg"
backgroundImageProps={{ deg: { small: "40deg", medium: "39deg", large: "25deg" }, stops: [themes.tm.primary.base, themes.tm.accent01.base ], style: { backgroundPosition: "center" } }}
backgroundImageProps=/\{\{/ deg: { small: "40deg", medium: "39deg", large: "25deg" }, stops: [themes.tm.primary.base, themes.tm.accent01.base ], style: { backgroundPosition: "center" } /\}\}/
height={350}
width={650}
>
Expand Down
2 changes: 2 additions & 0 deletions codecov.yml
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
codecov:
token: b38ccfc1-e63d-489f-afb8-c67ae7bcc034
Binary file added favicon.png
Loading
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
Binary file added fonts/TMSans-Black.woff2
Binary file not shown.
Binary file added fonts/TMSans-Bold.woff2
Binary file not shown.
Binary file added fonts/TMSans-Italic.woff2
Binary file not shown.
Binary file added fonts/TMSans-Light.woff2
Binary file not shown.
Binary file added fonts/TMSans-Regular.woff2
Binary file not shown.
Binary file added fonts/TMSans-SemiBold.woff2
Binary file not shown.
1 change: 1 addition & 0 deletions index.html
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
<!doctype html><html><head><meta charset="utf-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width,initial-scale=1,shrink-to-fit=no"><link rel="shortcut icon" href="/aurora/favicon.png"><style>@font-face{font-family:'TM Sans';src:url(/aurora/fonts/TMSans-Light.woff2) format('woff2');font-weight:300}@font-face{font-family:'TM Sans';src:url(/aurora/fonts/TMSans-Regular.woff2) format('woff2');font-weight:400}@font-face{font-family:'TM Sans';src:url(/aurora/fonts/TMSans-SemiBold.woff2) format('woff2');font-weight:600}@font-face{font-family:'TM Sans';src:url(/aurora/fonts/TMSans-Bold.woff2) format('woff2');font-weight:700}@font-face{font-family:'TM Sans';src:url(/aurora/fonts/TMSans-Black.woff2) format('woff2');font-weight:900}@font-face{font-family:'TM Sans';src:url(/aurora/fonts/TMSans-Italic.woff2) format('woff2');font-style:italic}body,button,input,select,textarea{font-family:TM Sans,Helvetica Neue,Helvetica,Arial,sans-serif;-webkit-font-smoothing:antialiased;line-height:1.4;letter-spacing:.3px}*,:after,:before{box-sizing:border-box}</style><title>Ticketmaster Aurora</title></head><body><div id="modal-root"></div><div id="catalog"></div><script type="text/javascript" src="/aurora/static/manifest.b12794b5.js"></script><script type="text/javascript" src="/aurora/static/vendor.2e50417c.js"></script><script type="text/javascript" src="/aurora/static/catalog.4dcdcad6.js"></script></body></html>
2 changes: 1 addition & 1 deletion package.json
Original file line number Diff line number Diff line change
Expand Up @@ -29,7 +29,7 @@
"test": "NODE_ENV=test jest",
"test:watch": "NODE_ENV=test jest --watch --no-cache",
"test:cover": "NODE_ENV=test jest --coverage",
"test:ci": "NODE_ENV=test jest --changedSince=master --runInBand",
"test:ci": "NODE_ENV=test jest --runInBand",
"add-icons": "pixo $* --out-dir src/components/Icons",
"tsc:declaration": "tsc -p tsconfig.declaration.json",
"posttsc:declaration": "node -e 'require(\"./scripts/declarejs\").generateStubTypings()'"
Expand Down
18 changes: 9 additions & 9 deletions src/components/Banner/__tests__/__snapshots__/index.spec.js.snap
Original file line number Diff line number Diff line change
Expand Up @@ -107,7 +107,7 @@ exports[`<Banner /> renders correctly when open 1`] = `
This is your primary message text.
</span>
<div
style="transition: max-height 0.3s cubic-bezier(0.455, 0.03, 0.515, 0.955) 0s; max-height: 0px;"
style="max-height: 0px;"
>
<div
class="c4 text text--dark text--primary c5"
Expand Down Expand Up @@ -253,7 +253,7 @@ exports[`<Banner /> renders correctly when variant is set 1`] = `
This is your primary message text.
</span>
<div
style="transition: max-height 0.3s cubic-bezier(0.455, 0.03, 0.515, 0.955) 0s; max-height: 0px;"
style="max-height: 0px;"
>
<div
class="c4 text text--dark text--primary c5"
Expand Down Expand Up @@ -434,7 +434,7 @@ exports[`<Banner /> renders correctly with close button 1`] = `
This is your primary message text.
</span>
<div
style="transition: max-height 0.3s cubic-bezier(0.455, 0.03, 0.515, 0.955) 0s; max-height: 0px;"
style="max-height: 0px;"
>
<div
class="c4 text text--dark text--primary c5"
Expand Down Expand Up @@ -611,7 +611,7 @@ exports[`<Banner /> renders correctly with close button hidden 1`] = `
This is your primary message text.
</span>
<div
style="transition: max-height 0.3s cubic-bezier(0.455, 0.03, 0.515, 0.955) 0s; max-height: 0px;"
style="max-height: 0px;"
>
<div
class="c4 text text--dark text--primary c5"
Expand Down Expand Up @@ -729,7 +729,7 @@ exports[`<Banner /> renders correctly with content 1`] = `
This is your primary message text.
</span>
<div
style="transition: max-height 0.3s cubic-bezier(0.455, 0.03, 0.515, 0.955) 0s; max-height: 0px;"
style="max-height: 0px;"
>
<div
class="c4 text text--dark text--primary c5"
Expand Down Expand Up @@ -869,7 +869,7 @@ exports[`<Banner /> renders correctly with custom icon 1`] = `
This is your primary message text.
</span>
<div
style="transition: max-height 0.3s cubic-bezier(0.455, 0.03, 0.515, 0.955) 0s; max-height: 0px;"
style="max-height: 0px;"
>
<div
class="c4 text text--dark text--primary c5"
Expand Down Expand Up @@ -1061,7 +1061,7 @@ exports[`<Banner /> renders correctly with custom title for the close button 1`]
test link text
</span>
<div
style="transition: max-height 0.3s cubic-bezier(0.455, 0.03, 0.515, 0.955) 0s; max-height: 0px;"
style="max-height: 0px;"
>
<div
class="c5 text text--dark text--primary c6"
Expand Down Expand Up @@ -1279,7 +1279,7 @@ exports[`<Banner /> renders correctly with expand/collapse button 1`] = `
collapsedText
</span>
<div
style="transition: max-height 0.3s cubic-bezier(0.455, 0.03, 0.515, 0.955) 0s; max-height: 0px;"
style="max-height: 0px;"
>
<div
class="c5 text text--dark text--primary c6"
Expand Down Expand Up @@ -1500,7 +1500,7 @@ exports[`<Banner /> renders correctly with link 1`] = `
test link text
</span>
<div
style="transition: max-height 0.3s cubic-bezier(0.455, 0.03, 0.515, 0.955) 0s; max-height: 0px;"
style="max-height: 0px;"
>
<div
class="c5 text text--dark text--primary c6"
Expand Down
2 changes: 2 additions & 0 deletions static/0.9cebb3db.chunk.js

Large diffs are not rendered by default.

1 change: 1 addition & 0 deletions static/0.9cebb3db.chunk.js.map

Large diffs are not rendered by default.

2 changes: 2 additions & 0 deletions static/1.8dbc5780.chunk.js

Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.

Loading

0 comments on commit dd987a9

Please sign in to comment.