Skip to content

Commit

Permalink
Merge truenas/13.1-stable' into 2024Q1 ports tree
Browse files Browse the repository at this point in the history
  • Loading branch information
anodos325 committed Mar 7, 2024
2 parents bdc8edf + 0778977 commit 506521d
Show file tree
Hide file tree
Showing 250 changed files with 66,949 additions and 559 deletions.
21 changes: 21 additions & 0 deletions Jenkinsfile
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
node('FreeNAS-ISO') {
stage('Checkout') {
checkout scm
}
withEnv(['GH_ORG=freenas','GH_REPO=ports']) {
stage('ixbuild') {
echo 'Starting iXBuild Framework pipeline'
try {
sh '/ixbuild/jenkins.sh freenas freenas-pipeline'
} catch (exc) {
echo 'Saving failed artifacts...'
archiveArtifacts artifacts: 'artifacts/**', fingerprint: true
throw exc
}
}
stage('artifact') {
archiveArtifacts artifacts: 'artifacts/**', fingerprint: true
junit 'results/**'
}
}
}
3 changes: 0 additions & 3 deletions MOVED
Original file line number Diff line number Diff line change
Expand Up @@ -1669,7 +1669,6 @@ audio/aacplusenc||2022-09-30|Has expired: Legacy audio format, superseded by HE-
net/libmms||2022-09-30|Has expired: Obsolete, Microsoft deprecated MMS protocol in favour of RTSP in 2003
audio/mctoolame-decoder||2022-09-30|Has expired: Legacy and obscure audio format that never gained any traction
audio/mctoolame-encoder||2022-09-30|Has expired: Legacy and obscure audio format that never gained any traction
www/py-ws4py||2022-09-30|Has expired: Upstream abandoned
databases/py-bsddb3|databases/py-berkeleydb|2022-09-30|Has expired: Requires upstream EOLd db5. Use py-berkeleydb
graphics/megapov|graphics/povray37|2022-10-01|Has expired: Abandoned upstream. graphics/povray37 is the recommended replacement
x11-toolkits/gstreamer1-plugins-gtk4||2022-10-01|No consumers left and deprecated in favor gtk4 plugin from multimedia/gstreamer1-plugins-rust >= 0.8.0
Expand Down Expand Up @@ -1920,7 +1919,6 @@ devel/rubygem-octicons|misc/rubygem-octicons|2023-03-16|Remove duplicate port
multimedia/libquicktime-lame||2023-03-18|Abandoned upstream and fails to build with newer versions of FFmpeg, consider using multimedia/ffmpeg
multimedia/libquicktime||2023-03-18|Abandoned upstream and fails to build with newer versions of FFmpeg, consider using multimedia/ffmpeg
devel/p5-Net-ZooKeeper||2023-03-19|Has expired: Broken since 2020
devel/libhyve-remote||2023-03-19|Has expired: Broken since 2020
chinese/brise||2023-03-19|Has expired: Broken since 2020
cad/NASTRAN-95||2023-03-19|Has expired: Broken since 2020
lang/dlv||2023-03-19|Has expired: Broken since 2020
Expand Down Expand Up @@ -2847,7 +2845,6 @@ www/py-dj41-django-debug-toolbar|www/py-dj42-django-debug-toolbar|2023-12-31|Has
www/kf5-kdewebkit||2023-12-31|Has expired: Depends on deprecated www/qt5-webkit
www/py-dj41-django-auth-ldap|www/py-dj42-django-auth-ldap|2023-12-31|Has expired: Extended support of Django 4.1 ends December 2023, upgrade to the Django 4.2+ version of this port. See https://www.djangoproject.com/download/
sysutils/kfloppy||2023-12-31|Has expired: No longer part of KDE Gear since 23.08
net/wireguard||2023-12-31|Has expired: Only useful for FreeBSD 12 which is EoL soon
net/wireguard-kmod||2023-12-31|Has expired: Only useful for FreeBSD 12 which is EoL soon
www/py-dj41-django-js-asset|www/py-dj42-django-js-asset|2023-12-31|Has expired: Extended support of Django 4.1 ends December 2023, upgrade to the Django 4.2+ version of this port. See https://www.djangoproject.com/download/
www/py-dj41-django-timezone-field|www/py-dj42-django-timezone-field|2023-12-31|Has expired: Extended support of Django 4.1 ends December 2023, upgrade to the Django 4.2+ version of this port. See https://www.djangoproject.com/download/
Expand Down
5 changes: 3 additions & 2 deletions Mk/Uses/waf.mk
Original file line number Diff line number Diff line change
Expand Up @@ -30,14 +30,15 @@ ALL_TARGET= #
HAS_CONFIGURE= yes
MAKE_ARGS+= --verbose
WAF_CMD?= ./waf
WAF_ENV?= ""

CONFIGURE_TARGET?= configure
ALL_TARGET?= build
INSTALL_TARGET?= install
TEST_TARGET?= test

CONFIGURE_CMD= ${PYTHON_CMD} ${WAF_CMD} ${CONFIGURE_TARGET}
MAKE_CMD= ${PYTHON_CMD} ${WAF_CMD}
CONFIGURE_CMD= ${WAF_ENV} ${PYTHON_CMD} ${WAF_CMD} ${CONFIGURE_TARGET}
MAKE_CMD= ${WAF_ENV} ${PYTHON_CMD} ${WAF_CMD}
CONFIGURE_ARGS+= --prefix=${PREFIX} \
${_MAKE_JOBS}

Expand Down
25 changes: 13 additions & 12 deletions databases/rrdtool/Makefile
Original file line number Diff line number Diff line change
@@ -1,26 +1,20 @@
# Created by: Dmitry Sivachenko <[email protected]>

PORTNAME= rrdtool
DISTVERSION= 1.8.0
PORTREVISION= 3
CATEGORIES= databases graphics
MASTER_SITES= https://github.com/oetiker/rrdtool-1.x/releases/download/v${DISTVERSION}/
MASTER_SITES= http://oss.oetiker.ch/rrdtool/pub/

MAINTAINER= eduardo@FreeBSD.org
MAINTAINER= ports@FreeBSD.org
COMMENT= Round Robin Database Tools
WWW= https://oss.oetiker.ch/rrdtool/

LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE

USES= cpe gmake gnome libtool pathfix pkgconfig shebangfix
CPE_VENDOR= rrdtool_project
USE_GNOME= glib20 libxml2
USE_LDCONFIG= yes
USE_RC_SUBR= rrdcached
SHEBANG_FILES= examples/rrdcached/rrdcached-size.pl examples/stripes.py
GNU_CONFIGURE= yes
CONFLICTS= rrdtool12

CONFIGURE_ARGS= --disable-tcl
CONFIGURE_ENV= RRDDOCDIR=${DOCSDIR:Q}
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
# Some symbols in the linker version script librrd.sym are undefined when the
# CACHE option is off. Suppress errors with lld >= 17 due to these undefined
Expand Down Expand Up @@ -75,9 +69,16 @@ RUBY_USES= ruby
RUBY_CONFIGURE_ENABLE= ruby

post-extract:
@${REINPLACE_CMD} -E 's|(^rrdcached_LDADD = librrd_th.la)|\1 $$\(ALL_LIBS\)|' \
${WRKSRC}/src/Makefile.in

@${REINPLACE_CMD} -E 's|(^rrdtool_LDADD = librrd.la)|\1 $$\(ALL_LIBS\)|' \
${WRKSRC}/src/Makefile.in

post-extract-EXAMPLES-off:
@${REINPLACE_CMD} -e '/^SUBDIRS = /s| examples | |' \
${WRKSRC}/Makefile.in

post-install-EXAMPLES-on:
.if !defined(BATCH)
@${ECHO_MSG} ""
Expand Down
6 changes: 3 additions & 3 deletions databases/rrdtool/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1659536807
SHA256 (rrdtool-1.8.0.tar.gz) = bd37614137d7a8dc523359648eb2a81631a34fd91a82ed5581916a52c08433f4
SIZE (rrdtool-1.8.0.tar.gz) = 2955398
TIMESTAMP = 1562346918
SHA256 (rrdtool-1.7.2.tar.gz) = a199faeb7eff7cafc46fac253e682d833d08932f3db93a550a4a5af180ca58db
SIZE (rrdtool-1.7.2.tar.gz) = 2883737
80 changes: 0 additions & 80 deletions databases/rrdtool/files/extra-patch-locktimeout

This file was deleted.

35 changes: 35 additions & 0 deletions databases/rrdtool/files/patch-8829fa7.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
From 8829fa758f3e585f20094cff69b32489f4cce3e7 Mon Sep 17 00:00:00 2001
From: Niclas Zeising
Date: Sun, 14 Jun 2020 11:31:33 +0200
Subject: [PATCH] rrd_open: Ignore EINVAL from posix_fallocate()

ZFS on FreeBSD (at least) does not support posix_fallocate(),
returning EINVAL instead. Ignore this error and continue normally.
Without this change, it is not possible to resize rrd files on ZFS.

This fixes #1082

Signed-off-by: Niclas Zeising
---
src/rrd_open.c | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/src/rrd_open.c b/src/rrd_open.c
index d8005fe4..00dfb8ca 100644
--- src/rrd_open.c
+++ src/rrd_open.c
@@ -363,7 +363,13 @@ rrd_file_t *rrd_open(
*/
int fret =
posix_fallocate(rrd_simple_file->fd, 0, newfile_size);
- if (fret) {
+ /* ZFS (on FreeBSD) does not support posix_fallocate(), always returning
+ * EINVAL. Ignore this error and continue anyway.
+ * Without this, resize isn't possible on ZFS filesystems.
+ */
+ if (fret == EINVAL) {
+ /* DO NOTHING */
+ } else if (fret) {
rrd_set_error("posix_fallocate '%s': %s", file_name,
rrd_strerror(fret));
goto out_close;
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- bindings/Makefile.in.orig 2022-03-14 14:29:39 UTC
--- bindings/Makefile.in.orig 2016-01-27 17:19:31 UTC
+++ bindings/Makefile.in
@@ -727,11 +727,11 @@ all-local: @COMP_PERL@ @COMP_RUBY@ @COMP_PYTHON@
@@ -711,15 +711,15 @@ all-local: @COMP_PERL@ @COMP_RUBY@ @COM
install-data-local:
$(AM_V_GEN)test -f ${builddir}/perl-piped/Makefile \
&& ( cd ${builddir}/perl-piped \
Expand All @@ -14,3 +14,8 @@
|| true
$(AM_V_GEN)test -f ${builddir}/ruby/Makefile \
&& ( cd ${builddir}/ruby \
- && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) install ) \
+ && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) install ) \
|| true
$(AM_V_GEN)test -d ${builddir}/python/build \
&& ( cd ${builddir}/python \
14 changes: 14 additions & 0 deletions databases/rrdtool/files/patch-bindings_python_setup.py
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
--- bindings/python/setup.py.orig 2017-03-10 18:03:11 UTC
+++ bindings/python/setup.py
@@ -1,10 +1,7 @@
#!/usr/bin/env python
import os
-try:
- from setuptools import setup, Extension
-except ImportError:
- sys.exit('The setup requires setuptools.')
+from distutils.core import setup, Extension

TOP_SRCDIR = os.environ.get('ABS_TOP_SRCDIR', '../..')
TOP_BUILDDIR = os.environ.get('ABS_TOP_BUILDDIR', '../..')
33 changes: 22 additions & 11 deletions databases/rrdtool/files/patch-configure
Original file line number Diff line number Diff line change
@@ -1,15 +1,27 @@
--- configure.orig 2022-03-14 14:29:38 UTC
--- configure.orig 2017-05-16 11:55:23 UTC
+++ configure
@@ -22491,7 +22491,7 @@ fi
if test "${enable_ruby_site_install+set}" = set; then :
enableval=$enable_ruby_site_install; RUBY_MAKE_OPTIONS=
else
- RUBY_MAKE_OPTIONS="sitedir=$langpref/lib/ruby"
+ RUBY_MAKE_OPTIONS="PREFIX=$langpref INSTALL_BASE= LIB=$langpref/lib/ruby"
fi
@@ -13698,7 +13698,7 @@ fi


if test "x$GCC" = "xyes"; then
- for flag in -fno-strict-aliasing -Wall -std=gnu99 -pedantic -Wundef -Wshadow -Wpointer-arith -Wcast-align -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -Wold-style-definition -W; do
+ for flag in -fno-strict-aliasing -Wall -std=gnu99 -pedantic -Wundef -Wshadow -Wpointer-arith -Wcast-align -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -Wold-style-definition; do
oCFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $flag"
cachename=rd_cv_gcc_flag_`echo $flag|sed 's/[^A-Za-z]/_/g'`
@@ -22422,9 +22422,9 @@ $as_echo "$am_cv_python_pyexecdir" >&6; }
$as_echo_n "checking for headers required to compile python extensions... " >&6; }
py_prefix=`$PYTHON -c "import sys; print(sys.prefix)"`
py_exec_prefix=`$PYTHON -c "import sys; print(sys.exec_prefix)"`
-PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
+PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION} -I${py_prefix}/include/python${PYTHON_VERSION}m"
if test "$py_prefix" != "$py_exec_prefix"; then
- PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
+ PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION} -I${py_exec_prefix}/include/python${PYTHON_VERSION}m"
fi

@@ -28807,19 +28807,6 @@ $as_echo_n "checking in... " >&6; }
save_CPPFLAGS="$CPPFLAGS"
@@ -27780,18 +27780,6 @@ $as_echo_n "checking in... " >&6; }
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: and out again" >&5
$as_echo "and out again" >&6; }

Expand All @@ -25,7 +37,6 @@
-sleep 1
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: just kidding ;-)" >&5
-$as_echo " just kidding ;-)" >&6; }
-echo
echo
echo "----------------------------------------------------------------"
echo "Config is DONE!"
echo
14 changes: 14 additions & 0 deletions databases/rrdtool/files/patch-doc-Makefile.in
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
--- doc/Makefile.in.orig 2016-01-27 10:49:53 UTC
+++ doc/Makefile.in
@@ -377,9 +377,9 @@ CLEANFILES = $(GENERATED_EXTRADIST) pod2

# what should go into the distribution
EXTRA_DIST = $(GENERATED_EXTRADIST) $(POD) $(POD3) rrdtool-dump.dtd rrdtool-xport.dtd rrdgraph_libdbi.pod rrdlua.pod
-idocdir = $(RRDDOCDIR)/txt
+idocdir = $(datadir)/doc/rrdtool/txt
idoc_DATA = $(POD) $(TXT)
-ihtmldir = $(RRDDOCDIR)/html
+ihtmldir = $(datadir)/doc/rrdtool/html
ihtml_DATA = $(HTML)
imandir = $(mandir)/man1
iman_DATA = $(MAN)
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- examples/Makefile.in.orig 2022-03-14 14:29:40 UTC
--- examples/Makefile.in.orig 2016-01-27 10:49:53 UTC
+++ examples/Makefile.in
@@ -431,7 +431,7 @@ top_builddir = @top_builddir@
@@ -420,7 +420,7 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
SUBDIRS = rrdcached
EXTRA_DIST = cgi-demo.cgi.in stripes.py
Expand Down
4 changes: 2 additions & 2 deletions databases/rrdtool/files/patch-examples_rrdcached_Makefile.in
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- examples/rrdcached/Makefile.in.orig 2022-03-14 14:29:40 UTC
--- examples/rrdcached/Makefile.in.orig 2016-01-27 10:49:53 UTC
+++ examples/rrdcached/Makefile.in
@@ -368,7 +368,7 @@ target_vendor = @target_vendor@
@@ -356,7 +356,7 @@ target_vendor = @target_vendor@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
Expand Down
10 changes: 10 additions & 0 deletions databases/rrdtool/files/patch-src_rrd__daemon.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
--- src/rrd_daemon.c.orig
+++ src/rrd_daemon.c
@@ -1659,6 +1659,7 @@
rrd_file = rrd_open(file, &rrd, RRD_READONLY | RRD_LOCK);
if (!rrd_file)
{
+ unlink(file);
rrd_free(&rrd);
free (ci);
RRDD_LOG (LOG_ERR, "handle_request_update: Could not read RRD file.");
25 changes: 25 additions & 0 deletions databases/rrdtool/files/patch-src_rrd__graph__helper.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
Backport of:

commit 254e4e44cd7828fba8f5bb18a7a29668221e0af5
Author: John W. O'Brien <[email protected]>
Date: Sat Mar 14 08:49:47 2020 -0400

Fix double meaning of time 0 as uninitialized value

Treat "VRULE:0#..." as "VRULE:1#..." because elsewhere xrule==0 is
used to mean xrule has not been set, which can lead to an array
bounds violation.

--- src/rrd_graph_helper.c.orig 2020-03-14 17:06:47 UTC
+++ src/rrd_graph_helper.c
@@ -776,6 +776,10 @@ static graph_desc_t* newGraphDescription(image_desc_t
}
if (gf==GF_VRULE){
gdp->xrule=val;
+ if (gdp->xrule == 0) {
+ /* distinguish from uninitialized */
+ gdp->xrule++;
+ }
}
else {
gdp->yrule=val;
Loading

0 comments on commit 506521d

Please sign in to comment.