-
Notifications
You must be signed in to change notification settings - Fork 31
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge truenas/13.1-stable' into 2024Q1 ports tree
- Loading branch information
Showing
250 changed files
with
66,949 additions
and
559 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
node('FreeNAS-ISO') { | ||
stage('Checkout') { | ||
checkout scm | ||
} | ||
withEnv(['GH_ORG=freenas','GH_REPO=ports']) { | ||
stage('ixbuild') { | ||
echo 'Starting iXBuild Framework pipeline' | ||
try { | ||
sh '/ixbuild/jenkins.sh freenas freenas-pipeline' | ||
} catch (exc) { | ||
echo 'Saving failed artifacts...' | ||
archiveArtifacts artifacts: 'artifacts/**', fingerprint: true | ||
throw exc | ||
} | ||
} | ||
stage('artifact') { | ||
archiveArtifacts artifacts: 'artifacts/**', fingerprint: true | ||
junit 'results/**' | ||
} | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,26 +1,20 @@ | ||
# Created by: Dmitry Sivachenko <[email protected]> | ||
|
||
PORTNAME= rrdtool | ||
DISTVERSION= 1.8.0 | ||
PORTREVISION= 3 | ||
CATEGORIES= databases graphics | ||
MASTER_SITES= https://github.com/oetiker/rrdtool-1.x/releases/download/v${DISTVERSION}/ | ||
MASTER_SITES= http://oss.oetiker.ch/rrdtool/pub/ | ||
|
||
MAINTAINER= eduardo@FreeBSD.org | ||
MAINTAINER= ports@FreeBSD.org | ||
COMMENT= Round Robin Database Tools | ||
WWW= https://oss.oetiker.ch/rrdtool/ | ||
|
||
LICENSE= GPLv2 | ||
LICENSE_FILE= ${WRKSRC}/LICENSE | ||
|
||
USES= cpe gmake gnome libtool pathfix pkgconfig shebangfix | ||
CPE_VENDOR= rrdtool_project | ||
USE_GNOME= glib20 libxml2 | ||
USE_LDCONFIG= yes | ||
USE_RC_SUBR= rrdcached | ||
SHEBANG_FILES= examples/rrdcached/rrdcached-size.pl examples/stripes.py | ||
GNU_CONFIGURE= yes | ||
CONFLICTS= rrdtool12 | ||
|
||
CONFIGURE_ARGS= --disable-tcl | ||
CONFIGURE_ENV= RRDDOCDIR=${DOCSDIR:Q} | ||
INSTALL_TARGET= install-strip | ||
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 | ||
# Some symbols in the linker version script librrd.sym are undefined when the | ||
# CACHE option is off. Suppress errors with lld >= 17 due to these undefined | ||
|
@@ -75,9 +69,16 @@ RUBY_USES= ruby | |
RUBY_CONFIGURE_ENABLE= ruby | ||
|
||
post-extract: | ||
@${REINPLACE_CMD} -E 's|(^rrdcached_LDADD = librrd_th.la)|\1 $$\(ALL_LIBS\)|' \ | ||
${WRKSRC}/src/Makefile.in | ||
|
||
@${REINPLACE_CMD} -E 's|(^rrdtool_LDADD = librrd.la)|\1 $$\(ALL_LIBS\)|' \ | ||
${WRKSRC}/src/Makefile.in | ||
|
||
post-extract-EXAMPLES-off: | ||
@${REINPLACE_CMD} -e '/^SUBDIRS = /s| examples | |' \ | ||
${WRKSRC}/Makefile.in | ||
|
||
post-install-EXAMPLES-on: | ||
.if !defined(BATCH) | ||
@${ECHO_MSG} "" | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1659536807 | ||
SHA256 (rrdtool-1.8.0.tar.gz) = bd37614137d7a8dc523359648eb2a81631a34fd91a82ed5581916a52c08433f4 | ||
SIZE (rrdtool-1.8.0.tar.gz) = 2955398 | ||
TIMESTAMP = 1562346918 | ||
SHA256 (rrdtool-1.7.2.tar.gz) = a199faeb7eff7cafc46fac253e682d833d08932f3db93a550a4a5af180ca58db | ||
SIZE (rrdtool-1.7.2.tar.gz) = 2883737 |
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
From 8829fa758f3e585f20094cff69b32489f4cce3e7 Mon Sep 17 00:00:00 2001 | ||
From: Niclas Zeising | ||
Date: Sun, 14 Jun 2020 11:31:33 +0200 | ||
Subject: [PATCH] rrd_open: Ignore EINVAL from posix_fallocate() | ||
|
||
ZFS on FreeBSD (at least) does not support posix_fallocate(), | ||
returning EINVAL instead. Ignore this error and continue normally. | ||
Without this change, it is not possible to resize rrd files on ZFS. | ||
|
||
This fixes #1082 | ||
|
||
Signed-off-by: Niclas Zeising | ||
--- | ||
src/rrd_open.c | 8 +++++++- | ||
1 file changed, 7 insertions(+), 1 deletion(-) | ||
|
||
diff --git a/src/rrd_open.c b/src/rrd_open.c | ||
index d8005fe4..00dfb8ca 100644 | ||
--- src/rrd_open.c | ||
+++ src/rrd_open.c | ||
@@ -363,7 +363,13 @@ rrd_file_t *rrd_open( | ||
*/ | ||
int fret = | ||
posix_fallocate(rrd_simple_file->fd, 0, newfile_size); | ||
- if (fret) { | ||
+ /* ZFS (on FreeBSD) does not support posix_fallocate(), always returning | ||
+ * EINVAL. Ignore this error and continue anyway. | ||
+ * Without this, resize isn't possible on ZFS filesystems. | ||
+ */ | ||
+ if (fret == EINVAL) { | ||
+ /* DO NOTHING */ | ||
+ } else if (fret) { | ||
rrd_set_error("posix_fallocate '%s': %s", file_name, | ||
rrd_strerror(fret)); | ||
goto out_close; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,14 @@ | ||
--- bindings/python/setup.py.orig 2017-03-10 18:03:11 UTC | ||
+++ bindings/python/setup.py | ||
@@ -1,10 +1,7 @@ | ||
#!/usr/bin/env python | ||
import os | ||
-try: | ||
- from setuptools import setup, Extension | ||
-except ImportError: | ||
- sys.exit('The setup requires setuptools.') | ||
+from distutils.core import setup, Extension | ||
|
||
TOP_SRCDIR = os.environ.get('ABS_TOP_SRCDIR', '../..') | ||
TOP_BUILDDIR = os.environ.get('ABS_TOP_BUILDDIR', '../..') |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,14 @@ | ||
--- doc/Makefile.in.orig 2016-01-27 10:49:53 UTC | ||
+++ doc/Makefile.in | ||
@@ -377,9 +377,9 @@ CLEANFILES = $(GENERATED_EXTRADIST) pod2 | ||
|
||
# what should go into the distribution | ||
EXTRA_DIST = $(GENERATED_EXTRADIST) $(POD) $(POD3) rrdtool-dump.dtd rrdtool-xport.dtd rrdgraph_libdbi.pod rrdlua.pod | ||
-idocdir = $(RRDDOCDIR)/txt | ||
+idocdir = $(datadir)/doc/rrdtool/txt | ||
idoc_DATA = $(POD) $(TXT) | ||
-ihtmldir = $(RRDDOCDIR)/html | ||
+ihtmldir = $(datadir)/doc/rrdtool/html | ||
ihtml_DATA = $(HTML) | ||
imandir = $(mandir)/man1 | ||
iman_DATA = $(MAN) |
4 changes: 2 additions & 2 deletions
4
.../rrdtool/files/patch-examples_Makefile.in → .../rrdtool/files/patch-examples-Makefile.in
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,10 @@ | ||
--- src/rrd_daemon.c.orig | ||
+++ src/rrd_daemon.c | ||
@@ -1659,6 +1659,7 @@ | ||
rrd_file = rrd_open(file, &rrd, RRD_READONLY | RRD_LOCK); | ||
if (!rrd_file) | ||
{ | ||
+ unlink(file); | ||
rrd_free(&rrd); | ||
free (ci); | ||
RRDD_LOG (LOG_ERR, "handle_request_update: Could not read RRD file."); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
Backport of: | ||
|
||
commit 254e4e44cd7828fba8f5bb18a7a29668221e0af5 | ||
Author: John W. O'Brien <[email protected]> | ||
Date: Sat Mar 14 08:49:47 2020 -0400 | ||
|
||
Fix double meaning of time 0 as uninitialized value | ||
|
||
Treat "VRULE:0#..." as "VRULE:1#..." because elsewhere xrule==0 is | ||
used to mean xrule has not been set, which can lead to an array | ||
bounds violation. | ||
|
||
--- src/rrd_graph_helper.c.orig 2020-03-14 17:06:47 UTC | ||
+++ src/rrd_graph_helper.c | ||
@@ -776,6 +776,10 @@ static graph_desc_t* newGraphDescription(image_desc_t | ||
} | ||
if (gf==GF_VRULE){ | ||
gdp->xrule=val; | ||
+ if (gdp->xrule == 0) { | ||
+ /* distinguish from uninitialized */ | ||
+ gdp->xrule++; | ||
+ } | ||
} | ||
else { | ||
gdp->yrule=val; |
Oops, something went wrong.