Skip to content

Commit

Permalink
package/exim: update patches to be applied with fuzz 0
Browse files Browse the repository at this point in the history
Commit 8f88a64 "support/scripts/apply-patches.sh: set the maximum
fuzz factor to 0" reduced the fuzz factor.

Due to this change, exim fails to build with output:

    Applying 0004-exim_lock-fix-lstat-related-build-errors.patch using patch:
    patching file src/exim_lock.c
    Hunk #1 FAILED at 13.
    Hunk #2 succeeded at 27 (offset 1 line).
    1 out of 2 hunks FAILED -- saving rejects to file src/exim_lock.c.rej

This commit rebases the package patches on the current package version
when needed.

Fixes:
http://autobuild.buildroot.net/results/ff27d5ebd7f24ac8cb236b83c67c2c75255e51c6/

Signed-off-by: Bernd Kuhls <[email protected]>
Reviewed-by: Luca Ceresoli <[email protected]>
Reviewed-by: Yann E. MORIN <[email protected]>
Tested-by: Yann E. MORIN <[email protected]>
Signed-off-by: Yann E. MORIN <[email protected]>
  • Loading branch information
bkuhls authored and yann-morin-1998 committed Jun 28, 2024
1 parent 15e5c51 commit 2097314
Show file tree
Hide file tree
Showing 5 changed files with 18 additions and 10 deletions.
4 changes: 3 additions & 1 deletion package/exim/0001-Build-buildconfig-for-the-host.patch
Original file line number Diff line number Diff line change
Expand Up @@ -2,6 +2,8 @@ buildconfig is meant to be executed on the host, so it has to be compiled
using $(HOSTCC), not $(CC).

Signed-off-by: Luca Ceresoli <[email protected]>
[Bernd: rebased for version 4.97.1]
Signed-off-by: Bernd Kuhls <[email protected]>
---
OS/Makefile-Base | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
Expand All @@ -10,7 +12,7 @@ diff --git a/OS/Makefile-Base b/OS/Makefile-Base
index 29a6ad3..420ba60 100644
--- a/OS/Makefile-Base
+++ b/OS/Makefile-Base
@@ -114,8 +114,8 @@ allexim: config.h $(EXIM_MONITOR) exicyclog exinext exiwhat \
@@ -258,8 +258,8 @@ allexim: config.h $(EXIM_MONITOR) exicyclog exinext exiwhat \

# Targets for special-purpose configuration header builders
buildconfig: buildconfig.c
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,6 +5,8 @@ This leads to useless duplicated files on the target, so disable this
piece of code.

Signed-off-by: Luca Ceresoli <[email protected]>
[Bernd: rebased for version 4.97.1]
Signed-off-by: Bernd Kuhls <[email protected]>
---
scripts/exim_install | 18 +++++++++---------
1 files changed, 9 insertions(+), 9 deletions(-)
Expand All @@ -13,7 +15,7 @@ diff --git a/scripts/exim_install b/scripts/exim_install
index 616ab3c..e68e7d5 100755
--- a/scripts/exim_install
+++ b/scripts/exim_install
@@ -344,15 +344,15 @@ while [ $# -gt 0 ]; do
@@ -348,15 +348,15 @@ while [ $# -gt 0 ]; do

else
if ../scripts/newer ${name} ${BIN_DIRECTORY}/${name}; then
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -9,8 +9,8 @@ Inspired by:
http://patch-tracker.debian.org/patch/series/view/exim4/4.76-2/35_install.dpatch

Signed-off-by: Luca Ceresoli <[email protected]>
(rebased against exim 4.89)
Signed-off-by: Bernd Kuhls <bernd[email protected]>
[Bernd: rebased for version 4.89 & 4.97.1]
Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
scripts/exim_install | 7 +++++--
1 files changed, 5 insertions(+), 2 deletions(-)
Expand All @@ -19,7 +19,7 @@ diff --git a/scripts/exim_install b/scripts/exim_install
index e68e7d5..487a4e1 100755
--- a/scripts/exim_install
+++ b/scripts/exim_install
@@ -58,6 +58,8 @@
@@ -61,6 +61,8 @@
shift
done

Expand All @@ -28,7 +28,7 @@ index e68e7d5..487a4e1 100755
# Get the values of BIN_DIRECTORY, CONFIGURE_FILE, INFO_DIRECTORY, NO_SYMLINK,
# SYSTEM_ALIASES_FILE, and EXE from the global Makefile (in the build
# directory). EXE is empty except in the Cygwin environment. In each case, keep
@@ -217,9 +219,7 @@
@@ -220,9 +223,7 @@
# The exim binary is handled specially

if [ $name = exim${EXE} ]; then
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -22,6 +22,8 @@ Fixes:

Signed-off-by: Luca Ceresoli <[email protected]>
Upstream-status: https://bugs.exim.org/show_bug.cgi?id=2523
[Bernd: rebased for version 4.97.1]
Signed-off-by: Bernd Kuhls <[email protected]>
---
src/exim_lock.c | 3 +++
1 file changed, 3 insertions(+)
Expand All @@ -30,16 +32,16 @@ diff --git a/src/exim_lock.c b/src/exim_lock.c
index 068216816054..cb140aff6436 100644
--- a/src/exim_lock.c
+++ b/src/exim_lock.c
@@ -13,6 +13,8 @@ Argument: the name of the lock file
Copyright (c) The Exim Maintainers 2016
@@ -14,6 +14,8 @@ Copyright (c) The Exim Maintainers 2016 - 2021
SPDX-License-Identifier: GPL-2.0-or-later
*/

+#define _XOPEN_SOURCE
+
#include "os.h"

#include <stdio.h>
@@ -26,6 +28,7 @@ Copyright (c) The Exim Maintainers 2016
@@ -27,6 +29,7 @@ Copyright (c) The Exim Maintainers 2016
#include <unistd.h>
#include <utime.h>
#include <sys/utsname.h>
Expand Down
4 changes: 3 additions & 1 deletion package/exim/0005-sieve-fix-build-errors.patch
Original file line number Diff line number Diff line change
Expand Up @@ -21,6 +21,8 @@ buildsystem.

Signed-off-by: Luca Ceresoli <[email protected]>
Upstream-status: https://bugs.exim.org/show_bug.cgi?id=2523
[Bernd: rebased for version 4.97.1]
Signed-off-by: Bernd Kuhls <[email protected]>
---
src/sieve.c | 2 ++
1 file changed, 2 insertions(+)
Expand All @@ -29,7 +31,7 @@ diff --git a/src/sieve.c b/src/sieve.c
index 5e8d1e6f4776..9632f2d43810 100644
--- a/src/sieve.c
+++ b/src/sieve.c
@@ -12,6 +12,8 @@
@@ -14,6 +14,8 @@

/* Sieve mail filter. */

Expand Down

0 comments on commit 2097314

Please sign in to comment.