forked from buildroot/buildroot
-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
package/libglfw: update the patches to be applied with fuzz 0
Commit 8f88a64 ("support/scripts/apply-patches.sh: set the maximum fuzz factor to 0") reduced the fuzz factor. Due to this change, libglfw fails to build with output: Applying 0002-src-CMakeLists.txt-allow-override-of-wayland-pkgdata.patch using patch: patching file src/CMakeLists.txt Hunk #1 FAILED at 75. 1 out of 1 hunk FAILED -- saving rejects to file src/CMakeLists.txt.rej This commit refreshes the package patch on the current package version. Signed-off-by: Dario Binacchi <[email protected]> Signed-off-by: Romain Naour <[email protected]>
- Loading branch information
1 parent
4309211
commit 9ede791
Showing
3 changed files
with
22 additions
and
17 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
From 2747e47393cbca2d09db56223e735bd94b21e2eb Mon Sep 17 00:00:00 2001 | ||
From 8ebf1067390948d03330a5a0c814e5f7f860e678 Mon Sep 17 00:00:00 2001 | ||
From: Joel Winarske <[email protected]> | ||
Date: Mon, 28 Sep 2020 22:23:02 -0700 | ||
Subject: [PATCH] Wayland: Remove extra-cmake-modules dependency | ||
|
@@ -8,17 +8,18 @@ Fixes #1774. | |
[Retrieved (and backported) from: | ||
https://github.com/glfw/glfw/commit/2747e47393cbca2d09db56223e735bd94b21e2eb] | ||
Signed-off-by: Fabrice Fontaine <[email protected]> | ||
[Dario: make the patch to be applied with fuzz factor 0 dropping all Hunks] | ||
Signed-off-by: Dario Binacchi <[email protected]> | ||
--- | ||
.gitignore | 4 --- | ||
CMakeLists.txt | 16 ++++++------ | ||
src/CMakeLists.txt | 62 ++++++++++++++++++++++++++++------------------ | ||
3 files changed, 45 insertions(+), 37 deletions(-) | ||
2 files changed, 45 insertions(+), 33 deletions(-) | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index 42bfa1806d..394827520b 100644 | ||
index 75069161fc36..b315eaa15305 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -191,20 +191,18 @@ endif() | ||
@@ -249,20 +249,18 @@ endif() | ||
# Use Wayland for window creation | ||
#-------------------------------------------------------------------- | ||
if (_GLFW_WAYLAND) | ||
|
@@ -47,10 +48,10 @@ index 42bfa1806d..394827520b 100644 | |
include(CheckIncludeFiles) | ||
include(CheckFunctionExists) | ||
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt | ||
index 2f2bdd883d..e834506c6c 100644 | ||
index b6dd86c54512..29be6515ae58 100644 | ||
--- a/src/CMakeLists.txt | ||
+++ b/src/CMakeLists.txt | ||
@@ -45,30 +45,44 @@ if (_GLFW_X11 OR _GLFW_WAYLAND) | ||
@@ -40,30 +40,44 @@ elseif (_GLFW_WAYLAND) | ||
posix_time.c posix_thread.c xkb_unicode.c | ||
egl_context.c osmesa_context.c) | ||
|
||
|
@@ -119,3 +120,6 @@ index 2f2bdd883d..e834506c6c 100644 | |
elseif (_GLFW_OSMESA) | ||
set(glfw_HEADERS ${common_HEADERS} null_platform.h null_joystick.h | ||
posix_time.h posix_thread.h osmesa_context.h) | ||
-- | ||
2.43.0 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
From 46aaf2b2b4d3ec240b9aad175bb3eddb6ae11ead Mon Sep 17 00:00:00 2001 | ||
From a2c88988b6cfe4023fe78f13519b56a8ac9f568b Mon Sep 17 00:00:00 2001 | ||
From: Fabrice Fontaine <[email protected]> | ||
Date: Fri, 4 Mar 2022 17:59:19 +0100 | ||
Subject: [PATCH] src/CMakeLists.txt: allow override of wayland pkgdatadir | ||
|
@@ -7,17 +7,19 @@ Allow the user to override WAYLAND_{PROTOCOLS_BASE,CLIENT_PKGDATADIR} | |
(needed when cross-compiling) | ||
|
||
Signed-off-by: Fabrice Fontaine <[email protected]> | ||
[Upstream status: https://github.com/glfw/glfw/pull/2053] | ||
Upstream: https://github.com/glfw/glfw/pull/2053 | ||
[Dario: make the patch to be applied with fuzz factor 0] | ||
Signed-off-by: Dario Binacchi <[email protected]> | ||
--- | ||
src/CMakeLists.txt | 8 ++++++-- | ||
1 file changed, 6 insertions(+), 2 deletions(-) | ||
src/CMakeLists.txt | 4 +++- | ||
1 file changed, 3 insertions(+), 1 deletion(-) | ||
|
||
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt | ||
index 01f191c9..475ce882 100644 | ||
index 29be6515ae58..1767b3c8ad8f 100644 | ||
--- a/src/CMakeLists.txt | ||
+++ b/src/CMakeLists.txt | ||
@@ -75,7 +75,9 @@ if (GLFW_BUILD_WAYLAND) | ||
include(FindPkgConfig) | ||
@@ -42,7 +42,9 @@ elseif (_GLFW_WAYLAND) | ||
|
||
find_program(WAYLAND_SCANNER_EXECUTABLE NAMES wayland-scanner) | ||
pkg_check_modules(WAYLAND_PROTOCOLS REQUIRED wayland-protocols>=1.15) | ||
- pkg_get_variable(WAYLAND_PROTOCOLS_BASE wayland-protocols pkgdatadir) | ||
|
@@ -26,7 +28,7 @@ index 01f191c9..475ce882 100644 | |
+ endif() | ||
|
||
macro(wayland_generate protocol_file output_file) | ||
add_custom_command(OUTPUT "${output_file}.h" | ||
add_custom_command(OUTPUT ${output_file}.h | ||
-- | ||
2.34.1 | ||
2.43.0 | ||
|