Skip to content

Commit

Permalink
Sync some more with marcuscom
Browse files Browse the repository at this point in the history
  • Loading branch information
Kris Moore committed Sep 5, 2014
1 parent 87d4646 commit 1911633
Show file tree
Hide file tree
Showing 10 changed files with 28 additions and 29 deletions.
22 changes: 16 additions & 6 deletions Mk/bsd.gnome.mk
Original file line number Diff line number Diff line change
Expand Up @@ -90,7 +90,7 @@ _USE_GNOME_ALL+= atk atspi cairo desktopfileutils eel2 gal2 \

# GNOME 3 components
_USE_GNOME_ALL+=dconf evolutiondataserver3 gnomecontrolcenter3 gnomedesktop3 \
gnomemenus3 gtk30 gtkhtml4 gtksourceview3 libgda5 \
gnomemenus3 gnomepanel3 gtk30 gtkhtml4 gtksourceview3 libgda5 \
libgda5-ui libwnck3 metacity nautilus3 py3gobject3 \
pygobject3 vte3

Expand Down Expand Up @@ -364,7 +364,7 @@ gnomedesktop3_USE_GNOME_IMPL= gtk30
gnomedesktopsharp20_DETECT= ${LOCALBASE}/libdata/pkgconfig/gnome-desktop-sharp-2.0.pc
gnomedesktopsharp20_BUILD_DEPENDS= ${gnomedesktopsharp20_DETECT}:${PORTSDIR}/x11-toolkits/gnome-desktop-sharp20
gnomedesktopsharp20_RUN_DEPENDS= ${gnomedesktopsharp20_DETECT}:${PORTSDIR}/x11-toolkits/gnome-desktop-sharp20
gnomedesktopsharp20_USE_GNOME_IMPL= gnomesharp20 gtkhtml3 librsvg2 vte libgnomeprintui gtksourceview2 libwnck
gnomedesktopsharp20_USE_GNOME_IMPL= gnomesharp20 gnomepanel3 gtkhtml3 librsvg2 vte libgnomeprintui gtksourceview2 libwnck
gnomedesktopsharp20_GNOME_DESKTOP_VERSION=2

libwnck_LIB_DEPENDS= libwnck-1.so:${PORTSDIR}/x11-toolkits/libwnck
Expand Down Expand Up @@ -395,6 +395,11 @@ eel2_LIB_DEPENDS= libeel-2.so:${PORTSDIR}/x11-toolkits/eel
eel2_DETECT= ${LOCALBASE}/libdata/pkgconfig/eel-2.0.pc
eel2_USE_GNOME_IMPL= gnomedesktop

gnomepanel3_LIB_DEPENDS=libpanel-applet-4.so:${PORTSDIR}/x11/gnome-panel
gnomepanel3_DETECT= ${LOCALBASE}/libdata/pkgconfig/libpanelapplet-4.0.pc
gnomepanel3_USE_GNOME_IMPL=gnomedesktop3 libwnck3 gnomemenus3 gnomedocutils librsvg2
gnomepanel3_GNOME_DESKTOP_VERSION=3

nautilus3_LIB_DEPENDS= libnautilus-extension.so:${PORTSDIR}/x11-fm/nautilus
nautilus3_DETECT= ${LOCALBASE}/share/gir-1.0/Nautilus-3.0.gir
nautilus3_USE_GNOME_IMPL=gnomedesktop3 gvfs libxml2
Expand Down Expand Up @@ -522,7 +527,7 @@ gnomedocutils_USE_GNOME_IMPL= libxslt
pygnomedesktop_DETECT= ${LOCALBASE}/libdata/pkgconfig/gnome-python-desktop-2.0.pc
pygnomedesktop_BUILD_DEPENDS= ${pygnomedesktop_DETECT}:${PORTSDIR}/x11-toolkits/py-gnome-desktop
pygnomedesktop_RUN_DEPENDS= ${pygnomedesktop_DETECT}:${PORTSDIR}/x11-toolkits/py-gnome-desktop
pygnomedesktop_USE_GNOME_IMPL= pygnome2 libgnomeprintui gtksourceview libwnck nautilus2 metacity
pygnomedesktop_USE_GNOME_IMPL= pygnome2 libgnomeprintui gtksourceview gnomepanel libwnck nautilus2 metacity
pygnomedesktop_GNOME_DESKTOP_VERSION=2

gtksharp10_DETECT= ${LOCALBASE}/libdata/pkgconfig/gtk-sharp.pc
Expand All @@ -538,7 +543,7 @@ gtksharp20_USE_GNOME_IMPL= gtk20
gnomesharp20_DETECT= ${LOCALBASE}/libdata/pkgconfig/gnome-sharp-2.0.pc
gnomesharp20_BUILD_DEPENDS= ${gnomesharp20_DETECT}:${PORTSDIR}/x11-toolkits/gnome-sharp20
gnomesharp20_RUN_DEPENDS= ${gnomesharp20_DETECT}:${PORTSDIR}/x11-toolkits/gnome-sharp20
gnomesharp20_USE_GNOME_IMPL= gtkhtml3 gtksharp20 librsvg2 vte
gnomesharp20_USE_GNOME_IMPL= gnomepanel3 gtkhtml3 gtksharp20 librsvg2 vte

libgnomekbd_DETECT= ${LOCALBASE}/libdata/pkgconfig/libgnomekbd.pc
libgnomekbd_LIB_DEPENDS= libgnomekbd.so:${PORTSDIR}/x11/libgnomekbd
Expand Down Expand Up @@ -797,7 +802,7 @@ GNOME_PRE_PATCH+= ; ${${component}_PRE_PATCH}
. endfor
.endif

. if defined(GCONF_SCHEMAS)
. if defined(GCONF_SCHEMAS) && ! defined(NO_STAGE)
MAKE_ENV+= GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
. endif
.endif
Expand Down Expand Up @@ -887,13 +892,18 @@ gnome-post-install:
. if defined(INSTALLS_ICONS)
@${RM} -f ${TMPPLIST}.icons1
@for i in `${GREP} "^share/icons/.*/" ${TMPPLIST} | ${CUT} -d / -f 1-3 | ${SORT} -u`; do \
${ECHO_CMD} "@rmtry $${i}/icon-theme.cache" \
${ECHO_CMD} "@unexec /bin/rm %D/$${i}/icon-theme.cache 2>/dev/null || /usr/bin/true" \
>> ${TMPPLIST}.icons1; \
${ECHO_CMD} "@exec ${LOCALBASE}/bin/gtk-update-icon-cache -q -f %D/$${i} 2>/dev/null || /usr/bin/true" \
>> ${TMPPLIST}; \
${ECHO_CMD} "@unexec ${LOCALBASE}/bin/gtk-update-icon-cache -q -f %D/$${i} 2>/dev/null || /usr/bin/true" \
>> ${TMPPLIST}; \
done
.if defined(NO_STAGE)
@for i in `${GREP} "^share/icons/.*/" ${TMPPLIST} | ${CUT} -d / -f 1-3 | ${SORT} -u`; do \
${LOCALBASE}/bin/gtk-update-icon-cache -q -f ${PREFIX}/$${i} 2>/dev/null || ${TRUE}; \
done
.endif
@if test -f ${TMPPLIST}.icons1; then \
${CAT} ${TMPPLIST}.icons1 ${TMPPLIST} > ${TMPPLIST}.icons2; \
${RM} -f ${TMPPLIST}.icons1; \
Expand Down
6 changes: 3 additions & 3 deletions Mk/bsd.gstreamer.mk
Original file line number Diff line number Diff line change
Expand Up @@ -70,7 +70,7 @@ GST1_MINIMAL_VERSION= .0
_GSTREAMER_PLUGINS= \
a52dec aalib amrnb amrwbdec cairo cdio \
cdparanoia dts dv faac faad flac flite \
gdkpixbuf gme gnonlin gsm jack jpeg lame libcaca \
gdkpixbuf gme gsm jack jpeg lame libcaca \
libmms libvisual mad mpeg2dec mpeg2enc neon ogg \
opencv opus pango pulse resindvd schroedinger \
shout2 sidplay soundtouch soup speex taglib \
Expand All @@ -80,8 +80,8 @@ _GSTREAMER_PLUGINS= \
.if defined(USE_GSTREAMER)
_GSTREAMER_PLUGINS+= \
annodex bz2 cdaudio dvd esound ffmpeg fluendo-mp3 \
fluendo-mpegdemux gconf gio gl gnomevfs hal \
ladspa libpng mm mp3 musepack nas pulse python qt4 \
fluendo-mpegdemux gconf gio gl gnomevfs gnonlin hal \
ladspa libpng mm mp3 musepack nas python qt4 \
sdl sndfile spc vdpau vp8 xvid
.endif

Expand Down
4 changes: 2 additions & 2 deletions accessibility/atkmm/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -42,9 +42,9 @@ include/atkmm-1.6/atkmm/wrap_init.h
lib/atkmm-1.6/include/atkmmconfig.h
lib/atkmm-1.6/proc/m4/convert.m4
lib/atkmm-1.6/proc/m4/convert_atk.m4
lib/libatkmm-1.6.la
lib/libatkmm-1.6.so
lib/libatkmm-1.6.so.1
lib/libatkmm-1.6.so.1.1.0
lib/libatkmm-1.6.so.2
libdata/pkgconfig/atkmm-1.6.pc
@dirrm lib/atkmm-1.6/proc/m4
@dirrm lib/atkmm-1.6/proc
Expand Down
2 changes: 2 additions & 0 deletions devel/gvfs/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -29,6 +29,7 @@ libexec/gvfsd-afp-browse
libexec/gvfsd
libexec/gvfsd-archive
libexec/gvfsd-burn
%%CDDA%%libexec/gvfsd-cdda
libexec/gvfsd-computer
libexec/gvfsd-dav
%%AVAHI%%libexec/gvfsd-dnssd
Expand Down Expand Up @@ -75,6 +76,7 @@ share/gvfs/mounts/afp-browse.mount
share/gvfs/mounts/afp.mount
%%DATADIR%%/mounts/archive.mount
%%DATADIR%%/mounts/burn.mount
%%CDDA%%%%DATADIR%%/mounts/cdda.mount
%%DATADIR%%/mounts/computer.mount
%%DATADIR%%/mounts/dav.mount
%%AVAHI%%%%DATADIR%%/mounts/dav+sd.mount
Expand Down
3 changes: 0 additions & 3 deletions editors/ghex/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -25,7 +25,4 @@ INSTALL_TARGET= install-strip

GLIB_SCHEMAS= org.gnome.GHex.gschema.xml

post-patch:
@${REINPLACE_CMD} '/^ghex2_LDADD =/s/$$/ -lm/' ${WRKSRC}/src/Makefile.in

.include <bsd.port.mk>
6 changes: 0 additions & 6 deletions mail/evolution/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -109,12 +109,6 @@ post-patch:
-e 's|-Wl,--no-undefined||g' \
-e 's|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
@${REINPLACE_CMD} 's/g_thread_init.*/(void)0;/' \
${WRKSRC}/calendar/gui/alarm-notify/notify-main.c \
${WRKSRC}/capplet/settings/mail-guess-servers.c \
${WRKSRC}/capplet/anjal-settings-main.c \
${WRKSRC}/plugins/backup-restore/backup.c \
${WRKSRC}/shell/main.c
@${REINPLACE_CMD} -e 's|/usr|${LOCALBASE}|g' \
${WRKSRC}/modules/spamassassin/evolution-spamassassin.c \
${WRKSRC}/modules/bogofilter/evolution-bogofilter.c
Expand Down
6 changes: 0 additions & 6 deletions net-im/empathy/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -83,10 +83,4 @@ post-patch:
s|MISSION_CONTROL_PLUGINS_DIR=`pkg-config -|MISSION_CONTROL_PLUGINS_DIR=$${libdir}/`pkg-config -|g' \
${WRKSRC}/configure

post-patch:
@${REINPLACE_CMD} \
-e '/^empathy_av_LDADD =/s/$$/ -lm/' \
-e '/^empathy_call_LDADD =/s/$$/ -lm/' \
${WRKSRC}/src/Makefile.in

.include <bsd.port.mk>
1 change: 0 additions & 1 deletion www/chromium/pkg-plist
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
bin/chrome
man/man1/chrome.1.gz
share/applications/chromium-browser.desktop
%%DATADIR%%/protoc
%%DATADIR%%/chrome
%%DATADIR%%/chrome-wrapper
%%DATADIR%%/chrome_100_percent.pak
Expand Down
5 changes: 4 additions & 1 deletion x11-toolkits/gtk30/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -723,7 +723,10 @@ share/themes/Emacs/gtk-3.0/gtk-keys.css
@dirrmtry share/locale/an
@dirrm share/gtk-3.0
@exec %D/bin/gtk-query-immodules-3.0 --update-cache > /dev/null 2>&1 || /usr/bin/true
@rmtry lib/gtk-3.0/%%GTK3_VERSION%%/immodules.cache
@unexec /bin/rm -f %D/lib/gtk-3.0/%%GTK3_VERSION%%/immodules.cache
@exec /bin/mkdir -p %D/lib/gtk-3.0/modules
@exec /bin/mkdir -p %D/lib/gtk-3.0/%%GTK3_VERSION%%/engines
@exec /bin/mkdir -p %D/lib/gtk-3.0/%%GTK3_VERSION%%/loaders
@dirrm lib/gtk-3.0/modules
@dirrm lib/gtk-3.0/%%GTK3_VERSION%%/printbackends
@dirrm lib/gtk-3.0/%%GTK3_VERSION%%/loaders
Expand Down
2 changes: 1 addition & 1 deletion x11-toolkits/pangomm/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -53,9 +53,9 @@ include/pangomm-%%API_VERSION%%/pangomm/tabarray.h
include/pangomm-%%API_VERSION%%/pangomm/types.h
include/pangomm-%%API_VERSION%%/pangomm/wrap_init.h
lib/libpangomm-%%API_VERSION%%.a
lib/libpangomm-%%API_VERSION%%.la
lib/libpangomm-%%API_VERSION%%.so
lib/libpangomm-%%API_VERSION%%.so.1
lib/libpangomm-%%API_VERSION%%.so.1.0.30
lib/pangomm-%%API_VERSION%%/include/pangommconfig.h
lib/pangomm-%%API_VERSION%%/proc/m4/convert.m4
lib/pangomm-%%API_VERSION%%/proc/m4/convert_pango.m4
Expand Down

0 comments on commit 1911633

Please sign in to comment.