Skip to content

Commit

Permalink
- Update to 1.0
Browse files Browse the repository at this point in the history
PR:		145239
Submitted by:	[email protected]
  • Loading branch information
AMDmi3 committed Sep 11, 2014
1 parent f94d532 commit 8637a72
Show file tree
Hide file tree
Showing 4 changed files with 33 additions and 22 deletions.
21 changes: 6 additions & 15 deletions games/openxcom/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,25 +2,24 @@
# $FreeBSD$

PORTNAME= openxcom
PORTVERSION= 0.9.0
PORTREVISION= 4
PORTVERSION= 1.0.0
CATEGORIES= games

MAINTAINER= [email protected]
COMMENT= Open-source reimplementation of the original X-Com

LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_FILE= ${WRKSRC}/LICENSE.txt

LIB_DEPENDS= libyaml-cpp.so:${PORTSDIR}/devel/yaml-cpp

USE_GITHUB= yes
GH_ACCOUNT= SupSuper
GH_PROJECT= OpenXcom
GH_TAGNAME= v0.9
GH_COMMIT= 5c8b540
GH_TAGNAME= v1.0
GH_COMMIT= b396c74

USES= gmake pkgconfig
USES= compiler:c++11-lang gmake pkgconfig
USE_SDL= sdl mixer image gfx
USE_GL= gl

Expand All @@ -37,15 +36,7 @@ PORTDATA= *

OPTIONS_DEFINE= DOCS

.include <bsd.port.options.mk>

.if ${OSVERSION} < 1000000
USE_GCC= yes
.endif

post-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/pch.h \
${WRKSRC}/src/Engine/Surface.cpp
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/README.txt \
${WRKSRC}/src/Engine/CrossPlatform.cpp

Expand All @@ -55,6 +46,6 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/res/linux/icons/openxcom.svg ${STAGEDIR}${PREFIX}/share/pixmaps/
cd ${WRKSRC}/bin && ${COPYTREE_SHARE} data ${STAGEDIR}${DATADIR}/
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/README.txt ${WRKSRC}/CHANGELOG.txt ${STAGEDIR}${DOCSDIR}/

.include <bsd.port.mk>
4 changes: 2 additions & 2 deletions games/openxcom/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (openxcom-0.9.0.tar.gz) = 340ff7292baa9a2b7ce4b244cc6dc0200c1d3b807a59087ef9827bba5c135634
SIZE (openxcom-0.9.0.tar.gz) = 1540556
SHA256 (openxcom-1.0.0.tar.gz) = d0bbc9fcd1671ad952c1b825a137a67ac5ed339827cedb660e46678c9a369557
SIZE (openxcom-1.0.0.tar.gz) = 2069030
19 changes: 19 additions & 0 deletions games/openxcom/files/patch-src__Engine__RNG.cpp
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
--- src/Engine/RNG.cpp.orig 2014-06-13 23:14:43.000000000 +0400
+++ src/Engine/RNG.cpp 2014-09-11 18:52:08.000000000 +0400
@@ -17,6 +17,7 @@
* along with OpenXcom. If not, see <http://www.gnu.org/licenses/>.
*/
#include "RNG.h"
+#include <limits>
#include <math.h>
#include <time.h>

@@ -86,7 +87,7 @@
double generate(double min, double max)
{
double num = next();
- return (double)(num / ((double)UINT64_MAX / (max - min)) + min);
+ return (double)(num / ((double)std::numeric_limits<uint64_t>::max() / (max - min)) + min);
}

/**
11 changes: 6 additions & 5 deletions games/openxcom/files/pkg-message.in
Original file line number Diff line number Diff line change
Expand Up @@ -2,13 +2,14 @@

OpenXcom requires original UFO: Enemy Unknown / X-Com: UFO Defense
data files. Please copy all subfolders from original game into
%%PREFIX%%/share/openxcom/data directory.
%%DATADIR%%/data directory.

Also note that if you get "GMDEFENT NOT FOUND" message, you need
to patch your UFO to at least version 1.4. See
Also note that if you get messages like "GMDEFENT NOT FOUND" or
"INVALID CHRYS.PCK", you need to patch your UFO date to the latest
version. See section `Data Patch' of

http://openxcom.org/forum/index.php?topic=1129.0
http://openxcom.org/index.php/downloads-extras/

for reference.
for details.

==========================================================================

0 comments on commit 8637a72

Please sign in to comment.