forked from freebsd/freebsd-ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Support stage - Add LICENSE - Rename patches PR: 192202 Submitted by: tkato432 yahoo com
- Loading branch information
1 parent
4a771fe
commit 9f9a4d9
Showing
8 changed files
with
170 additions
and
117 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,34 +1,45 @@ | ||
# Created by: gelf | ||
# $FreeBSD$ | ||
|
||
PORTNAME= fte | ||
PORTVERSION= 20051115 | ||
PORTREVISION= 2 | ||
CATEGORIES= editors | ||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} | ||
DISTFILES= ${PORTNAME}-${PORTVERSION:S/./b/}-src.zip \ | ||
${PORTNAME}-${PORTVERSION:S/./b/}-common.zip | ||
PORTNAME= fte | ||
PORTVERSION= 20110708 | ||
CATEGORIES= editors | ||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} | ||
DISTFILES= ${PORTNAME}-${PORTVERSION:S/./b/}-src.zip \ | ||
${PORTNAME}-${PORTVERSION:S/./b/}-common.zip | ||
DIST_SUBDIR= ${PORTNAME} | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Full-featured text editor for X11 | ||
|
||
WRKSRC= ${WRKDIR}/fte | ||
LICENSE= ART10 GPLv2 | ||
LICENSE_COMB= dual | ||
|
||
WRKSRC= ${WRKDIR}/fte | ||
|
||
USE_XORG= x11 xpm | ||
USES= perl5 zip | ||
USE_PERL5= build | ||
USE_XORG= x11 xpm | ||
|
||
CFLAGS+= -DHAVE_STRLCAT -DHAVE_STRLCPY | ||
|
||
OPTIONS_DEFINE= DOCS | ||
|
||
NO_STAGE= yes | ||
post-patch: | ||
@${REINPLACE_CMD} -e 's,^PREFIX=,PREFIX?=,' \ | ||
${WRKSRC}/Makefile | ||
@${REINPLACE_CMD} -e \ | ||
's|^PREFIX=|PREFIX?=|' ${WRKSRC}/Makefile | ||
@${REINPLACE_CMD} -e \ | ||
's|\([[:space:]]\)\($$BINDIR\)|\1$$DESTDIR\2|g ; \ | ||
s|\([[:space:]]\)\($$LIBDIR\)|\1$$DESTDIR\2|g ; \ | ||
s|\([[:space:]]\)\($$CONFIGDIR\)|\1$$DESTDIR\2|g ; \ | ||
s|\([[:space:]]\)\($$LOCALCONFIGDIR\)|\1$$DESTDIR\2|g ; \ | ||
/fterc/s|^|#|' ${WRKSRC}/install | ||
|
||
post-install: | ||
.if !defined(NOPORTDOCS) | ||
@${MKDIR} ${DOCSDIR} | ||
@cd ${WRKSRC}/doc && \ | ||
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \; | ||
.endif | ||
@${MKDIR} ${STAGEDIR}${DOCSDIR} | ||
@(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}) | ||
.for i in cfte xfte | ||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${i} | ||
.endfor | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
SHA256 (fte/fte-20051115-src.zip) = bb4135e5c39223fa346d20613052e69090b14ed46855d5134bf2dbc4ba40d962 | ||
SIZE (fte/fte-20051115-src.zip) = 549216 | ||
SHA256 (fte/fte-20051115-common.zip) = 794031dd1d06156259d21ddcb3dec3196001818ea7116e9786b54314484dabf4 | ||
SIZE (fte/fte-20051115-common.zip) = 187849 | ||
SHA256 (fte/fte-20110708-src.zip) = d6311c542d3f0f2890a54a661c3b67228e27b894b4164e9faf29f014f254499e | ||
SIZE (fte/fte-20110708-src.zip) = 504199 | ||
SHA256 (fte/fte-20110708-common.zip) = 58411578b31958765f42d2bf29b7aedd9f916955c2c19c96909a1c03e0246af7 | ||
SIZE (fte/fte-20110708-common.zip) = 200007 |
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,88 @@ | ||
--- src/fte-unix.mak Sun Nov 13 12:47:25 2005 | ||
+++ src/fte-unix.mak Tue Feb 28 12:29:41 2006 | ||
@@ -5,10 +5,10 @@ | ||
|
||
# vfte - for Linux console directly (with limitations, see con_linux.cpp) | ||
|
||
-TGT_NFTE = nfte | ||
+#TGT_NFTE = nfte | ||
#TGT_QFTE = qfte | ||
-TGT_SFTE = sfte | ||
-TGT_VFTE = vfte | ||
+#TGT_SFTE = sfte | ||
+#TGT_VFTE = vfte | ||
TGT_XFTE = xfte | ||
|
||
TARGETS = $(TGT_XFTE) $(TGT_VFTE) $(TGT_NFTE) $(TGT_SFTE) $(TGT_QFTE) | ||
@@ -27,15 +27,16 @@ | ||
CPPOPTIONS = -Wall -Wpointer-arith -Wconversion -Wwrite-strings -Winline | ||
|
||
# try this for smaller/faster code and less dependencies | ||
-#NOEXCEPTION = -fno-rtti -fno-exceptions | ||
+NOEXCEPTION = -fno-rtti -fno-exceptions | ||
|
||
|
||
# choose your os here | ||
|
||
####################################################################### | ||
# Linux | ||
-UOS = -DLINUX | ||
-#XLIBDIR = | ||
+UOS = -DFREEBSD | ||
+XINCDIR = -I$(LOCALBASE)/include | ||
+XLIBDIR = -L$(LOCALBASE)/lib | ||
|
||
####################################################################### | ||
# HP/UX | ||
@@ -55,7 +56,7 @@ | ||
#MINCDIR = -I/usr/include/Motif1.2 | ||
#MLIBDIR = -L/usr/lib/Motif1.2 | ||
|
||
-SINCDIR = -I/usr/include/slang | ||
+#SINCDIR = -I/usr/include/slang | ||
|
||
####################################################################### | ||
# AIX | ||
@@ -111,18 +112,18 @@ | ||
|
||
####################################################################### | ||
|
||
-QTDIR = /usr/lib64/qt-3.3 | ||
+#QTDIR = /usr/lib64/qt-3.3 | ||
#/users/markom/qt | ||
-QLIBDIR = -L$(QTDIR)/lib | ||
+#QLIBDIR = -L$(QTDIR)/lib | ||
#QINCDIR = -I$(QTDIR)/include | ||
#QINCDIR = -I/usr/include/qt | ||
-QINCDIR = -I/usr/include/qt3 -I/usr/lib64/qt-3.3/include | ||
-MOC = moc | ||
+#QINCDIR = -I/usr/include/qt3 -I/usr/lib64/qt-3.3/include | ||
+#MOC = moc | ||
|
||
LIBDIRS = | ||
INCDIRS = $(XINCDIR) $(QINCDIR) $(MINCDIR) $(SINCDIR) | ||
|
||
-OPTIMIZE = -g # -O -g | ||
+#OPTIMIZE = -g # -O -g | ||
#OPTIMIZE = -O2 | ||
#OPTIMIZE = -Os | ||
#OPTIMIZE = -O2 -s | ||
@@ -148,7 +149,7 @@ | ||
$(XOBJS:.o=.cpp) | ||
|
||
XLIBS = $(XLIBDIR) -lX11 $(SOCKETLIB) $(XPMLIB) $(XTLIB) | ||
-VLIBS = $(VLIBDIR) -lgpm | ||
+VLIBS = $(VLIBDIR) -lncurses | ||
NLIBS = $(NLIBDIR) -lncurses | ||
SLIBS = $(SLIBDIR) -lslang | ||
#QLIBS = $(QLIBDIR) -lqt | ||
@@ -223,6 +224,6 @@ | ||
# | ||
# include dependency files if they exist | ||
# | ||
-ifneq ($(wildcard .depend),) | ||
-include .depend | ||
-endif | ||
+#ifneq ($(wildcard .depend),) | ||
+#include .depend | ||
+#endif |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
--- src/stl_string.cpp.orig | ||
+++ src/stl_string.cpp | ||
@@ -10,6 +10,13 @@ | ||
#include <stdlib.h> | ||
#include <string.h> | ||
|
||
+#ifdef tolower | ||
+#undef tolower | ||
+#endif | ||
+#ifdef toupper | ||
+#undef toupper | ||
+#endif | ||
+ | ||
FTE_BEGIN_NAMESPACE; | ||
|
||
/* |
File renamed without changes.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
#!/bin/sh | ||
|
||
case $2 in | ||
POST-INSTALL) | ||
cd $PKG_PREFIX/lib/fte/config; $PKG_PREFIX/bin/cfte main.fte $PKG_PREFIX/lib/fte/system.fterc | ||
exit 0 | ||
;; | ||
esac |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters