Cap the domain deposit amount for certain assets #7
Annotations
10 errors and 6 warnings
lint:
crypto/edwards_test.go#L16
Error return value of `rand.Read` is not checked (errcheck)
|
lint:
crypto/edwards_test.go#L21
Error return value of `rand.Read` is not checked (errcheck)
|
lint:
crypto/key_test.go#L63
Error return value of `rand.Read` is not checked (errcheck)
|
lint:
crypto/batch.go#L92
Function 'Verify' has too many statements (41 > 40) (funlen)
|
lint:
crypto/cosi_test.go#L13
Function 'TestCosi' has too many statements (66 > 40) (funlen)
|
lint:
crypto/signature_test.go#L18
Function 'testSignature' has too many statements (50 > 40) (funlen)
|
lint:
crypto/key.go#L107
captLocal: `A' should not be capitalized (gocritic)
|
lint:
crypto/key.go#L120
captLocal: `R' should not be capitalized (gocritic)
|
lint:
crypto/key.go#L132
captLocal: `P' should not be capitalized (gocritic)
|
lint:
crypto/hash_test.go#L50
assignOp: replace `msg = msg + msg` with `msg += msg` (gocritic)
|
lint:
kernel/election.go#L179
unused-parameter: parameter 's' seems to be unused, consider removing or renaming it as _ (revive)
|
lint:
rpc/info.go#L125
unused-parameter: parameter 'params' seems to be unused, consider removing or renaming it as _ (revive)
|
lint:
rpc/consensus_test.go#L1161
unused-parameter: parameter 'deposit' seems to be unused, consider removing or renaming it as _ (revive)
|
lint:
rpc/custodian.go#L5
unused-parameter: parameter 'params' seems to be unused, consider removing or renaming it as _ (revive)
|
lint:
rpc/http.go#L27
unused-parameter: parameter 'r' seems to be unused, consider removing or renaming it as _ (revive)
|
lint:
command.go#L964
unused-parameter: parameter 'deposit' seems to be unused, consider removing or renaming it as _ (revive)
|